[Résolu] Paquets .deb


#1

Après l’installation, non sans mal ! Je veux installer des logiciels. J’ai bien vu le synaptic, mais les versions proposées ne sont pas les dernières (exemple de Grisbi). J’ai donc téléchargé le .deb, mais comment je l’installe à partir de là ?

Merci


#2

#3

ok merci
Comment on désinstalle un logiciel, peut-on le faire via synaptic ?
Par exemple je veux enlever mozill car j’utilise Firefox. :wink:


#4

slt,

“man synaptic” && “man apt-get”


#5

Salut,

Pour les désinstallations, à moins d’être a court de place, prudence :blush:


#6

[quote]Comment on désinstalle un logiciel, peut-on le faire via synaptic ?[/quote]Tu es sûr d’avoir fait l’effort minimum de chercher ?
Ds Synaptic, les paquets qui sont installé sont “marqués”.
Cilque DR sur le paquet que tu veux virer et là, tu regardes ce qu’il te propose.


#7

[quote=“ricardo”][quote]Comment on désinstalle un logiciel, peut-on le faire via synaptic ?[/quote]Tu es sûr d’avoir fait l’effort minimum de chercher ?
Ds Synaptic, les paquets qui sont installé sont “marqués”.
Cilque DR sur le paquet que tu veux virer et là, tu regardes ce qu’il te propose.[/quote]

Oui excuse-moi de suite après mon post je suis allé voir synaptic et en effet j’ai vu qu’on pouvait désinstaller. Mille pardon… :blush:


#8

majormax, attention, si tu installes un paquet d’une version récente (surement instable), il va te demander les dépendances et celles ci devront être récentes. Finalement il y a trois solutions:

  1. des backports si tu es sur sarge, j’en propose quelqu’uns et tu en trouveras d’autres sur des sites dédiés. Attention, tu ne peux plus prétendre être sur une sarge pure si tu changes des librairies en pagaille. Notamment, un apt-get dist-upgrade risque de complètement s’emméler les pinceaux (aptitude va un peu mieux), j’ai ainsi une woody complètement bloquée suite à rajout de backports sur backports.

  2. Une installation ponctuelle de paquets sid ou etch sur sarge, une lecture attentive de man apt-preferences s’impose faute de quoi, tu vas mettre à jour tout ton système.

  3. Un passage en etch ou sid. Il vaut mieux sid en ce moment, etch ne va pas fort mais ça ne devrait pas tarder à aller mieux. C’est une bonne solution si la machine n’est pas essentielle.

En tout cas je doute fortement que

dpkg -i grisbi-lastversion-cvs-derniereheure.deb

fonctionne sans difficultés


#9

Merci fran.b, comme je l’ai dit je vais rester en Sarge et je vais m’occuper d’avoir une Debian bien clean déjà. On verra plus tard (un peu plus tard, pas trop !! :wink: )


#10

Remarque, si tu as un gros disque et de la place, tu peux installer une etch dans ta sarge via debootstrap, c’est la meilleure façon d’utiliser un logiciel récent (je l’avais oublié alors que je le fais fréquemment):

Tu fais un debootstrap de la sid dans un repertoire:
Tu installes dedans ton truc mega récent mega instable mega risqué
Ca plante plusieurs fois, ça casses tout mais ça n’est pas grave, au pire tu effaces le répertoire et c’est tout. Bref, après trois nuits blanches ça marche.
Tu fais un chroot via dchroot pour utiliser sous sarge ton logiciels. Tu peux même imprimer et avoir accès à ton home en montant à bind les répertoires.