[Résolu] pas de console ? (Crt+Alt+F1/F2 etc ...)


#1

Bonjour,

Je viens d’installer debian sarge 3.1 et cette fois il est impossible de basculler en mode console, il ne se passe rien lorsque je fais Crt+Alt+Fx ?
L’interface graphique se lance bien.

De meme lorsque je lance une session terminal en su dans l’interface graphique, elle so’uvre sans me demander le mot de passe root ???
Apres des que je tape une commande, la fenetre est réduite dans la barre de tache sans qu’il ne se passe rien dans la session terminal.

d’avanc emerci de votre aide
Jean-Michel


#2

A l’install, tu as bien donné un mdp pour root ?
quel gestionnaire de fenêtres as-tu installé ?


#3

En fait j’ai eu un probleme, au premier lancement il ne reconnaissait pas le passwr root ?, j’ai donc bidouillé les fichiers passwd et shadow.

Cela vient de la tu crois ?
Suis je bon pour une réinstall complete ? :frowning:

Merci de ton aide


#4

Attends les autres réponses car Matt te dira qu’on ne réinstalle jamais une Debian, on la corrige :wink:
(Je ne l’ai pas tjrs écouté
:unamused: )


#5

ben si tu arrive a te logger en root sans pass tu peux lui en remettre un avec passwd
Regarde aussi au niveau de la gestion d’utilisateur useradd ou adduser pour arranger tes fichiers surtout ne modifie plus tes fichiers /etc/passwd et /etc/shadow a la main :wink: :smiley:


#6

Je viens de reinstaller et ca me fait pareil.

Je suis absolument sur d’avoir saisi le bon password pour root (je le tape tous les jours) pourtant lorsque je fais su il me dit Authentification failure.

Toujours pas de bascullement vers les consoles sous gnome.

Heeeeeeeeeeeelp please :frowning:


#7

j’ai deja eu le cas lors de précédentes installations d’avoir un clavier US lors de la saisie du pass root, essayes d’entrer ton pass en mode “clavier US”, par contre, je ne connais pas par coeur le disposition du clavier US hormis que “A”, “Z” et “M” se trouve en fait sur les touches “Q”, “W” et “,” (virgule)

depuis a chaque install je précise :


#8

j’ai pensé au clavier US, mais meme en tapant à la mode QWERTY, le pass est toujours refusé.

Par contre, lorsque je boot en rescue mode, mon password est bien accepté.


#9

Pour le passwd c’était surement un probleme de clavier, j’ai réussi à la changer en mode rescue, par contre je n’ai toujours pas acces aux consoles avec les touches Crtl+Alt+Fx

Comment peut on booter sans l’interface graphique svp ?


#10

pour booter sans interface graphique tu dois pouvoir faire ca avec grub, mais je ne sais pas comment faire, j’ai seulement “vu” qqu’un le faire


#11

Comment t’as fait s’il te plait, car j’ai le même problème il n’accepte pas mon mot de passe même en clavier us !!! :cry:


#12

[quote=“bilbo194”]Pour le passwd c’était surement un probleme de clavier, j’ai réussi à la changer en mode rescue, par contre je n’ai toujours pas acces aux consoles avec les touches Crtl+Alt+Fx

Comment peut on booter sans l’interface graphique svp ?[/quote]
Avec ça:

Tu rentres en single user, donc forcément sans interface graphique.
Sinon, pour désactiver le login graphique, le temps de débugger tu fais:

update-rc.d -f gdm remove (ou kdm selon ton login manager)


#13

[quote=“bilbo194”]Pour le passwd c’était surement un probleme de clavier, j’ai réussi à la changer en mode rescue, par contre je n’ai toujours pas acces aux consoles avec les touches Crtl+Alt+Fx
[/quote]
Comment se présente ton fichier /etc/inittab ? Chez moi:

# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

C’est là que tu définis le nombre de consoles virtuelles que tu veux.


#14

voici le contenu du fichier /etc/inittab :

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

les consoles semblent declarees, non
je viens de m’apercevoir que la touche maj n’est pas prise en compte,ni les accents j’ai un probleme de clavier sous X :frowning:


#15

Comment t’as fait s’il te plait, car j’ai le même problème il n’accepte pas mon mot de passe même en clavier us !!! :cry:[/quote]

au boot, tu as le choix entre le boot normal et le boot rescue, si tu choisis le boot rescue, il te demande le passwd root avec le meme clavier que lors de l’install, apres tu le changes en prenant soin d’utiliser des touches valides dans tous les claviers.


#16

Je me demande si il n’y a tout simplement pas un souci dans le chargement de la carte clavier (pas de touche alt)…
Test: que donne Alt-gr 0 (devrait faire @)

Est ce que /etc/init.d/keymap.sh start règle le pbm du ctrl-Alt-F1?

Qui y-a-il dans /etc/console?

Que donne

loadkeys /usr/share/keymaps/i386/azerty/fr-latin9.kmap.gz

règle-t-il en partie le pbm???


#17

J’ai changé le clavier de fr-latin9 en fr et maintenant tout est rentré dans l’ordre :slightly_smiling: