[Résolu] Passage au kernel 2.6.14


#1

Voila je vient d’installer une sarge sur mon vaio, et pour avoir le son, je désire mettre le kernel 2.6.14, car alsa est includans le kernel, mais j’arrive pas.
Synaptics me sort :


#2

Il te manque mkinitrd. Installe le paquet initrd-tools.
Mais ça m’épate, je croyais que c’était dans les dépendances des kernel 2.6 :confused:


#3

mkinitrd est présent, mais je l’ai mis a jour et maintenant quant j’instal le kernel j’ai :

[quote]
Sélection du paquet linux-image-2.6.14-1-686 précédemment désélectionné.
(Lecture de la base de données… 99286 fichiers et répertoires déjà installés.)Dépaquetage de linux-image-2.6.14-1-686 (à partir de …/linux-image-2.6.14-1-686_2.6.14-1_i386.deb) …

You are attempting to install an initrd kernel image (version
2.6.14-1-686) while running a kernel of version 2.4.27-2-386, but
you have no suitable ramdisk generation tool installed among
/usr/sbin/mkinitrd /usr/sbin/mkinitrd.yaird /usr/sbin/mkinitramfs. This will break the installation, unless a
suitable ramdisk generation tool is also being installed right
now.

Could not find . at /var/lib/dpkg/tmp.ci/preinst line 228.
Sélection du paquet linux-image-2.6-686 précédemment désélectionné.
Dépaquetage de linux-image-2.6-686 (à partir de …/linux-image-2.6-686_2.6.14-1_i386.deb) …
Sélection du paquet kernel-image-2.6-686 précédemment désélectionné.
Dépaquetage de kernel-image-2.6-686 (à partir de …/kernel-image-2.6-686_1%3a2.6.14-1_i386.deb) …
Paramétrage de linux-image-2.6.14-1-686 (2.6.14-1) …
Failed to find suitable ramdisk generation tool for kernel version 2.6.14-1-686 on running kernel 2.4.27-2-386 in /usr/sbin/mkinitrd /usr/sbin/mkinitrd.yaird /usr/sbin/mkinitramfs
dpkg : erreur de traitement de linux-image-2.6.14-1-686 (–configure) :
le sous-processus post-installation script a retourné une erreur de sortie d’état 2
dpkg : des problèmes de dépendances empêchent la configuration de linux-image-2.6-686 :
linux-image-2.6-686 dépend de linux-image-2.6.14-1-686 ; cependant :
Paquet linux-image-2.6.14-1-686 n’est pas encore configuré.
dpkg : erreur de traitement de linux-image-2.6-686 (–configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de kernel-image-2.6-686 :
kernel-image-2.6-686 dépend de linux-image-2.6-686 ; cependant :
Paquet linux-image-2.6-686 n’est pas encore configuré.
dpkg : erreur de traitement de kernel-image-2.6-686 (–configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l’exécution :
linux-image-2.6.14-1-686
linux-image-2.6-686
kernel-image-2.6-686

Échec, toutes les modifications n’ont pas pu être appliquées. - Faites défiler la fenêtre pour trouver l’erreur.


#4

ça me laisse dubitatif, ça te donne quoi un ‘which mkinitrd’ ?


#5

which mkinitrd = /usr/sbin/mkinitrd


#6

c bon g trouver initramfs-tools n’était pas installer, maintenent je suis bien en 2.6.14 et g du sons, merci BobX


#7

Sauf erreur, alsa est inclu dans le noyau à partir de la série 2.6.8 il me semble … :question: