[Résolu] Pb Configuration LCD LG1715LS


#1

Avant je tournais avec un vieux 14’’ que j’ai remplacé par un LCD 17’’.
Le modèle est un LG1715LS. 50 fois que je lance dpkg-reconfigure -xserver-xfree, aucun changement dans KDE 3.3. Toujours en 800x600, impossible d’aller plus haut. Je n’y comprends plus rien.
J’ai retouché /etc/X11/XF86Config-4 pour rajouter les résolutions dans la Section “Screen” -> SubSection “Display”. Rien ne bouge.
HEEELP ! I need somebody ! HEEEEELP !
Quelle est la meilleure alternative pour moi ?

  • Me jeter par la fenêtre (avec le PC biensûr il s’en sortira pas comme ça),
  • Passer à KDE 4.x et là je sais pas trop comment faire (désinstaller la 3.3, écraser avec une 4.x, …),
  • Je ne modifies pas les bons paramètres ou pas au bon endroit et je suis une buse.
    Le seul truc qui me rassure c’est l’icône nvidia qui m’indique que je ne suis pas un looser complet et que j’ai réussi à installer le module nvidia…

A l’aide ! Je craque. Plus tôt dans la semaine, j’ai essayé de faire marcher ma Sound Blaster Audigy LS et elle me ch… dans les bottes aussi. Je ne veux pas être un esclave de Billou pliiiiiiise.

Un énorme merci d’avance pour votre aide.
Bonne journée


#2

Si c’est bien reconfiguré, qui le cession KDE Gnome ou autre et redémarre-là pour que les changements soient pris en compte.
Les deux méthodes utilisées sont les bonnes, une seule suffit …


#3

Le fais-tu en mode “Expert” afin de saisir tous les paramètres importants de ton nouvel écran (fréquences de raffraichissement par exemple) ?

T’es-tu assuré de “réactiver” ton fichier XF86Config-4 avant de lancer le reconfigure (lire les 1ères lignes du fichier qui explique la méthode).

Peux-tu nous donner ton /etc/X11/XF86Config-4 ?


#4

Il faut faire plus que ça : il faut redémarrer le serveur graphique par la commande CTRL + ALT + BACKSPACE.


#5

Tout d’abord merci pour vos réponses. J’ai vérifié mon fichier de config et je me suis aperçu que j’avais un fichier XF86config et un XF86Config-4 dans mon /etc/X11.

Voici le XF86Config-4:

# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	#Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	#Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"Geforce5900XT"
	Driver		"nvidia"
EndSection

Section "Monitor"
	Identifier	"LG1711"
	HorizSync	31-65
	VertRefresh	50-60
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Geforce5900XT"
	Monitor		"LG1711"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

#6

Wouououououaouououou !!
Un Ctrl-Alt-Backspace et c’était réglé. J’en étais pas si loin que ça. :wink:
Merci beaucoup et bon we.


#7

[quote=“hn2k5”]Wouououououaouououou !!
Un Ctrl-Alt-Backspace et c’était réglé. J’en étais pas si loin que ça. :wink:
Merci beaucoup et bon we.[/quote]
Je l’avais dit le : Posté le: 29 Mar 2006 07:18 pm
Mais tu as une excuse. Avec Windows, t’es si souvent obligé de redémarrer que tu l’aurais vu de suite, mais sous Debian, il faut le faire volontairement :wink:

Bon WE aussi.


#8

lol merci.
:wink: