[RESOLU] Pb de config d'Apache2


#1

Voila, suite a un crash de mon disk dur j’ai reinstallé debian sarge…
Aucun pb l’installer fait tout tout seul comme un grd…

Mais G kelkes soucis, en voici un, le plus récurrent…
Des que j’installe ou desinstalle des packages G droit aux messages d’erreurs suivants a propos de la config du serveur apache2

B406:~# apt-get  remove --purge exim4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  exim4*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
5 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 32,8ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n]
(Lecture de la base de données... 99683 fichiers et répertoires déjà installés.)Suppression de exim4 ...
Paramétrage de apache2-common (2.0.52-2) ...
dpkg : erreur de traitement de apache2-common (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de apache2-mpm-prefork :
 apache2-mpm-prefork dépend de apache2-common (= 2.0.52-2) ; cependant :
  Paquet apache2-common n'est pas encore configuré.
dpkg : erreur de traitement de apache2-mpm-prefork (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de apache2 :
 apache2 dépend de apache2-mpm-worker (= 2.0.52-2) | apache2-mpm-prefork (= 2.0.52-2) | apache2-mpm-perchild (= 2.0.52-2) ; cependant :
  Paquet apache2-mpm-worker n'est pas installé.
  Paquet apache2-mpm-prefork n'est pas encore configuré.
  Paquet apache2-mpm-perchild n'est pas installé.
dpkg : erreur de traitement de apache2 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libapache2-mod-perl2 :
 libapache2-mod-perl2 dépend de apache2-common (>= 2.0.50-9) ; cependant :
  Paquet apache2-common n'est pas encore configuré.
dpkg : erreur de traitement de libapache2-mod-perl2 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libapache2-mod-php4 :
 libapache2-mod-php4 dépend de apache2-mpm-prefork (>= 2.0.50-10) ; cependant :
  Paquet apache2-mpm-prefork n'est pas encore configuré.
dpkg : erreur de traitement de libapache2-mod-php4 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 apache2-common
 apache2-mpm-prefork
 apache2
 libapache2-mod-perl2
 libapache2-mod-php4
E: Sub-process /usr/bin/dpkg returned an error code (1)

alors G bien tenté de reconfiguré la bête… de supprimer les âquets deja installés puis les reinstallé…
rien ne passe j’obtiens le meme message d’erreur ke ci dessus!

Ben j’fais koi moi maint’nant???
:confused: [/code]


#2

as tu essayer de les installer un par un, en prenant dans l’ordre des dépendances ?


#3

ouais c’est ce que j’ai fait en premier apres avoir tenté de le reconfigurer et meme message d’erreur…

Je retente on sait jamais…
[edit]
je confirme ce que je dis ci dessus… rien ne passe
dpkg --configure

B406:/home/vequaud# dpkg --configure apache2-mpm-prefork
dpkg : des problèmes de dépendances empêchent la configuration de apache2-mpm-prefork :
 apache2-mpm-prefork dépend de apache2-common (= 2.0.52-2) ; cependant :
  Paquet apache2-common n'est pas encore configuré.
dpkg : erreur de traitement de apache2-mpm-prefork (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 apache2-mpm-prefork
B406:/home/vequaud# dpkg --configure apache2-common
Paramétrage de apache2-common (2.0.52-2) ...
dpkg : erreur de traitement de apache2-common (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 apache2-common
B406:/home/vequaud#

avec apt-get install and co… tjrs le meme message d’erreur.
:confused:
[/edit]


#4

mais la, tu en as installé plusieurs d’un coup, non ?
ce qu’il faut savoir, c’est lequel des paquets pose probleme precisement.
tu les à bien enlevés avec --purge ?


#5

[quote=“MattOTop”]mais la, tu en as installé plusieurs d’un coup, non ?
ce qu’il faut savoir, c’est lequel des paquets pose probleme precisement.
tu les à bien enlevés avec --purge ?[/quote]

j’ai bien tenté de les désinstaller tous ensemble et un par un …
meme message erreur

pareil je retente on C jamais…
[edit]
je confirme ca passe pas
[/edit]


#6

comme quoi des fois suffit juste d’un pti apt-get update/upgrade pour arranger pas mal de choses…