[Résolu]Pilotes ATI, quelque soucis :


#1

bonsoir,

voilà, j’ai installé les pilotes ATI suivant le tuto présent dans ce forum. A priori tout s’est bien passé, n’ayant pas eut le moindre message d’erreur. J’ai réinstallé cedega (5.1) depuis mon compte, le problème est que lorsque je passe les tests pour l’acceleration 3D, il ne me valide rien ou presque (il me valide que POSIX, copy protection et OSS sounds).

Voilà ce que me renvoit un glxinfo :

[quote]name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None[/quote]

par ailleurs le test avec glxgears ne me pose aucun problème.

Y-t-il un autre moyen de tester si mes pilotes fonctionnent ? je connais pas trop les appli 3D en dehors de cedega :\


#2

SI c’est une carte de type Ati Radeon, tu peux tester le pilote avec fglrxinfo,
en particulier la commande fglrxinfo -v

C’est étrange, ça donne bien les infos sous XFree86, mais je remarque que maintenant que je suis sous Xorg en 2.6.12, ça n’indique pas l’accéleration 3D non plus. Mais bon, l’essentiel c’est que ça fonctionne.


#3

Bon ça ne marche toujours pas, mais j’ai plus d’infos :

Tout d’abord, un dmesg me dit que le module est introuvable.

ensuite un fglrxinfo -v me renvoit :

[quote]
display: :0.0 screen:0
OpenGL vendor string: Mesa project: mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glx server vendor string: SGI
glx server version string: 1.2
glx server extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
glx client version: 1.3
glx client extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample

Visual ID: 23 depth=24 class=TrueColor
bufferSize=24 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=0
auxBuffers=0 depthSize=16 stencilSize=0
accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 24 depth=24 class=TrueColor
bufferSize=24 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=0
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=0
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 25 depth=24 class=TrueColor
bufferSize=32 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=8
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=16
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 26 depth=24 class=TrueColor
bufferSize=32 level=0 renderType=rgba doubleBuffer=0 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=8
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=16
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 27 depth=24 class=DirectColor
bufferSize=24 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=0
auxBuffers=0 depthSize=16 stencilSize=0
accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 28 depth=24 class=DirectColor
bufferSize=24 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=0
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=0
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 29 depth=24 class=DirectColor
bufferSize=32 level=0 renderType=rgba doubleBuffer=1 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=8
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=16
multiSample=1 multiSampleBuffers=0
Opaque.
Visual ID: 2a depth=24 class=DirectColor
bufferSize=32 level=0 renderType=rgba doubleBuffer=0 stereo=0
rgba: redSize=8 greenSize=8 blueSize=8 alphaSize=8
auxBuffers=0 depthSize=16 stencilSize=8
accum: redSize=16 greenSize=16 blueSize=16 alphaSize=16
multiSample=1 multiSampleBuffers=0
Opaque.[/quote]

Un petit coup de more sur mon seul log xorg, à la section “fglrx” :

Je reboot et je vous dis ça =)


#4

J’ai mis à jour le tuto, pour le serveur Xorg (section truc et astuces).


#5

[quote=“Damsss”]J’ai mis à jour le tuto, pour le serveur Xorg (section truc et astuces).[/quote]Plop tout est rentré dans l’ordre, merci à tous.