[Résolu] Prob Installation Drivers Nvidia


#1

Bonjour, je viens d’installer la distrib Debian et je veux installer le driver Nvidia car la résolution de mon écran est 1024X768 et X ne veut pas monter plus haut alors que mon écran supporte le 1600X1200.

J’ai downloader les drivers Nvidia pour ma carte et je l’installe à partir de la console en root après avoir tuer X (j’espère qu’il m’en voudra pas trop ) comme marqué dans le manuel et à l’installation il me dit qu’il doit downloader le kernel source ensuite je fais OUI et il mem mais une error du type “pas de kernel compiler pour installer le
driver, vous devez compiler le kernel” en gros.

Quelqu’un à une solution ?

Merci et à bientôt


#2

Tu pourrais nous mettre le fichier de log de l’installeur nvidia?


#3

j’espère que c’est bien ça le fichier que tu demande :

[code]vidia-installer log file '/var/log/nvidia-installer.log’
creation time: Sat Sep 24 12:30:41 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
’kernel-source’ rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
’–kernel-source-path’ commandline option.
ERROR: Installation has failed. Please see the file
’/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.[/code]


#4

Ok, donc il faut que tu installes le kernel-headers correspondant au kernel que tu utilises.


#5

Hum oui mais je suis + ou moins débutant ici sur Debianm ais j’apprend vite…
Masi tu pourrais pas m’expliquer, comme si j’avais 5 ans, comment installer le kernel headers pas à pas !

Si je de le télécharger quelque part, comment fairepour l’installer sous Debian se serait sympa

Merci et à bientôt


#6

Pour installer un paquet sous Debian, c’est simplissime. Petit exemple pour installer le kernel-headers de ton noyau.

D’abord, fait un uname -a pour connaître la version de ton noyau.
Ensuite tu fais un apt-get install kernel-headers-version_de_ton_noyau
Tu fais oui à chaque question, et voilà c’est installé !


#7

voilà ce que j’ai :

dexmon:/usr/src# uname -a Linux dexmon.myftp.org 2.6.8-2-k7 #1 Thu May 19 18:03:29 JST 2005 i686 GNU/Linux dexmon:/usr/src# apt-get install kernel-headers-2.6.8-2-k7 Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait kernel-headers-2.6.8-2-k7 est déjà la plus récente version disponible. Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes : Les paquets suivants contiennent des dépendances non satisfaites : nvidia-kernel-source: Dépend: debhelper (> 4.0.0) mais ne sera pas installé Dépend: dpatch (>= 2.0.0) mais ne sera pas installé E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet (ou indiquez une solution).


#8

j’ai donc fait apt-get -f install
et ensuite j’ai réussi à installer le driver Nvidia
J’ai été dans le fichier de configuration de Xfree86 et j’ai vu que dans la section “device” il y avait déjà le driver “Nvidia”

Alors j’ai essayer de redimensionner mon écran mais il a rajouter des valeur plus basse que 1024X768 mais pas plus haute !!!

Et je suis toujours en 1024X768 !

Je ne vais tout de même pas désinstaller Debian ( que j’adore) à cause de cette p… de résolution de m… !!!


#9

Si le mode que tu désirs n’est pas accessible, c’est que ton serveur X a été mal configuré.
Dans le fichier /etc/X11/XF86Config-4, tu as la section screen, qui défini, pour chaque profondieur de couleur, les modes d’affichage disponibles. Les différentes lignes “Modes” contiennent-elles “1600x1200” ?


#10

non elles contiennent tout sauf 1280X1024 et 1600x1200 :

[code]# XF86Config-4 (XFree86 X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the XF86Config-4 manual page.

(Type “man XF86Config-4” at the shell prompt.)

This file is automatically updated on xserver-xfree86 package upgrades only

if it has not been modified since the last upgrade of the xserver-xfree86

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom

md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum

dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Device"
Identifier "nVidia GeForce2 MX 100/200"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Xdebc Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia GeForce2 MX 100/200"
Monitor "Xdebc Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 4
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 8
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 15
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 16
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 24
Modes “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
[/code]

voilà !


#11

Ok, donc modifie le lignes Modes en n’y mettant uniquement les modes que tu souhaites utiliser. Par exemple, remplace les par :

Modes “1600x1200” “1280x1024”

Si tu souhaites pouvoir utiliser ces deux résolutions


#12

et ensuite je dois redémarrer X ?


#13

Vi vi, d’ailleurs si tout se passe bien, il devrait démarrer directement en 1600x1200


#14

et bien non !!!
Mais j’ai remarqué qu’il m’a crée un deuxième fichier à côté du fichier XF86Config-4, c’est XF86Config-4~

[code]# XF86Config-4 (XFree86 X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the XF86Config-4 manual page.

(Type “man XF86Config-4” at the shell prompt.)

This file is automatically updated on xserver-xfree86 package upgrades only

if it has not been modified since the last upgrade of the xserver-xfree86

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom

md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum

dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Device"
Identifier "nVidia GeForce2 MX 100/200"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Xdebc Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia GeForce2 MX 100/200"
Monitor "Xdebc Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 4
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 8
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 15
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 16
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
SubSection "Display"
Depth 24
Modes “1600x1200” “1280x1024” “1024x768” “800x600” “640x400” “640x480” “320x240” “320x200” "320x400"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
[/code]


#15

et j’ai fait ça comme c’est marqué dans le fichier de config lorsqu’on l’a modifié :

[code]# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom

md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum

dpkg-reconfigure xserver-xfree86 [/code]

Et dans la console enmode root ilme demande :

et je met quoi ?


#16

Le dpkg-reconfigure xserver-xfree86 pose juste quelques questions pour reparamétrer ton serveur X. En gros, il édite le fichier XF86Config-4 à ta place. Pour l’dentifiant de la carte video, ne met rien, xfree trouve ça tout seul.


#17

j’ai trouvé !

pour une carte AGP il faut mettre PCI:1:0:0

j’ai redémarrer X et je suis en 1280X1024 !

MAis parcontre le 1600X1200 il me l’a pas accepté mais je m’en fou

Merci pour ta patience et ton attention et vive DEBIAN

A bientôt


#18

[quote=“dexmon”]Bonjour, je viens d’installer la distrib Debian et je veux installer le driver Nvidia car la résolution de mon écran est 1024X768 et X ne veut pas monter plus haut alors que mon écran supporte le 1600X1200.

J’ai downloader les drivers Nvidia pour ma carte etje l’installe dans une console en root après avoir tuer X comme marqué dans le manuel et à l’installation il me dit qu’il doit downloader le kernel source ensuite je fais OUI et il mem mais une error du type “pas de kernel compiler pour installer le
driver, vous devez compiler le kernel” en gros.

Quelqu’un à une solution ?

Merci et à bientôt[/quote]
Salut,

peut tu nous dire qu’elle version de la debian tu utilises (sarge, sid…)
Si tu utilise la sarge, les drivers OpenSource sont tres bien fait, et casi aussi performant que les drivers propriétaires. Donc, si c’est le cas, passe par ‘apt-get’ et tout sera automatique, tu n’aura plus a configurer ton serveur X avec les bonnes resolutions.

A+


#19

Salut,
j’utilise la Sarge !


#20

Un petit truc que je viens de remarquer en réinstallant ma Sarge !

Pendant l’installation de Debian, il vous demande à un moment de configurer votre carte graphique…

Pour ceux qui ont une carte nvidia mettez ‘nv’ et non ‘vesa’ ensuite pour les paramètres de la carte mettez PCI:1:0:0

Voilà, j’espère que ça vous aidera.