[Résolu] Problème de quotas sur Ext3


#1

Bonsoir à tous !

Je suis toujours sur ma Debian Sarge, et je voudrais activer les quotas sur un système de fichier ext3. Voici mes partitions :

/dev/hda1 ext3, /
/dev/hda2 ext3, /home
/dev/hda3 swap

Pour commencer, j’ai regardé si mon kernel supportait les quotas :

grep -i quota /boot/config-2.4.27-2-686 CONFIG_QUOTA=y CONFIG_XFS_QUOTA=y

Donc, ne voulant activer les quotas que sur /dev/hda2, j’ai ajouté dans mon /etc/fstab :

Bien sûr, j’ai aussi installé les quotas…

Puis, après avoir rebooté :

quotaon -a quotaon: using /home/aquota.user on /dev/hda2 [/home]: Aucun processus de ce type quotaon: Quota format not supported in kernel.

Cela vient-il du fait qu’il y ait dans la config de mon kernel CONFIG_XFS_QUOTA=y, et que donc ca marche UNIQUEMENT pour les systèmes de fichiers XFS ? Mystère…

J’ai déjà cherché longuement, rien à faire… Ca part en débat sur le raid, ou bien personne n’a de solution :frowning:

Merci pour votre aide !


#2

non. l’option de noyau n’est pas exclusive, et comme tu as activé CONFIG_QUOTA tu as le support des QUOTAS.
Le pb vient d’ailleurs, c’est sûr…
Es tu sûr d’être en 2.4.27-2-686 ?
as tu essayé un bête noyau 2.6 dernière génération ?
Y a t il une contre indication au changement de noyau ?
Juste pour essayer ?


#3

Non, je n’ai pas essayé de changer de noyau… Actuellement, je suis en train de passer en 2.4.27-3-686 (apt-get upgrade). Pour passer en 2.6, il me suffirait d’un bête apt-get install kernel-image-2.6.16-1-686 ? Je vais rebooter sur le 2.4.27-3… Argh, toujours le même problème :s C’est parti pour un kernel 2.6… Voilà, c’est en téléchargement, c’est un 2.6.8 !

Yahoo ! Ca marche :slightly_smiling:

Une fois encore, merci beaucoup :wink:


#4

Oui, sous Sarge et avec apt-get, je ne pense pas que tu puisses avoir un 2.6.16. Seulement sous Sid, il me semble.


#5

[quote=“Martin”]Non, je n’ai pas essayé de changer de noyau… Actuellement, je suis en train de passer en 2.4.27-3-686 (apt-get upgrade). Pour passer en 2.6, il me suffirait d’un bête apt-get install kernel-image-2.6.16-1-686 ? Je vais rebooter sur le 2.4.27-3… Argh, toujours le même problème :s C’est parti pour un kernel 2.6… Voilà, c’est en téléchargement, c’est un 2.6.8 !

Yahoo ! Ca marche :slightly_smiling:

Une fois encore, merci beaucoup :wink:[/quote]A préciser aussi qu’a partir de la version 2.6.11 ce n’est plus kernel-image mais linux-image.
2 tutos interressant sur le changement de kernel