[Résolu] Problème d'installation Amule


#1

J’essaye veinement d’installer Amule et cela coince sur libwxgtk2.6-0

J’ai ce message lorsqu’il essaye de le mettre apt-get install libwxgtk2.6-0 Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Les NOUVEAUX paquets suivants seront installés : libwxgtk2.6-0 0 mis à jour, 1 nouvellement installés, 0 à enlever et 16 non mis à jour. Il est nécessaire de prendre 3184ko dans les archives. Après dépaquetage, 9110ko d'espace disque supplémentaires seront utilisés. Réception de : 1 http://www.proesdorf.de stable/main libwxgtk2.6-0 2.6.1.1.dirk.31.1 [3184kB] 3184ko réceptionnés en 23s (137ko/s) (Lecture de la base de données... 111310 fichiers et répertoires déjà installés.) Dépaquetage de libwxgtk2.6-0 (à partir de .../libwxgtk2.6-0_2.6.1.1.dirk.31.1_i386.deb) ... dpkg : erreur de traitement de /var/cache/apt/archives/libwxgtk2.6-0_2.6.1.1.dirk.31.1_i386.deb (--unpack) : tentative de remplacement de « /usr/lib/libwx_baseu-2.6.so.0 », qui appartient aussi au paquet libwxbase2.6 Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/libwxgtk2.6-0_2.6.1.1.dirk.31.1_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
J’ai essayé d’autres moyens, mais y’a pas moyen… :cry:


#2

slt,

[quote]
Dépaquetage de libwxgtk2.6-0 (à partir de …/libwxgtk2.6-0_2.6.1.1.dirk.31.1_i386.deb) …
dpkg : erreur de traitement de /var/cache/apt/archives/libwxgtk2.6-0_2.6.1.1.dirk.31.1_i386.deb (–unpack) :
tentative de remplacement de « /usr/lib/libwx_baseu-2.6.so.0 », qui appartient aussi au paquet libwxbase2.6 [/quote]

Apparement un conflit de paquet, as tu essayé de force l’install “apt-get install -f”


#3

Essaye avec mon dépot, je n’ai pas eu ces soucis:

deb boisson.homeip.net/sarge/ ./


#4

Non mais la ce n’est pas un pb de depot, clairement :

Donc avec ou sans ton depot c’est idem.


#5

[quote=“stonfi”]Non mais la ce n’est pas un pb de depot, clairement :

Donc avec ou sans ton depot c’est idem.[/quote]

En effet j’ai toujours le même problème.

[quote]as tu essayé de force l’install “apt-get install -f”[/quote] Oui et ça veux pas :cry:


#6

slt,

Essai juste d’installer “libwxbase2.6” pour voir


#7

[quote]Essai juste d’installer “libwxbase2.6” pour voir[/quote] Ben en fait c’est lui qui posait problème, je l’ai désinstallé (via synaptic) et j’ai pu alors installé libwxgtk2.6-0, et ensuite amule. :laughing:

J’ai gardé tes sources fran.b

Merci de votre aide, et finalement c’est par cette discusion que… :wink:


#8

Avec retard, il est arrivé que dans des backports, des fichiers se mettent en doublons. Ici

/usr/lib/libwx_baseu-2.6.so.0 appartenaient à deux paquets. Dans le backport de wx que j’ai fait, j’ai fait attention à ce pbm. C’est pour cela que je te suggérais d’utiliser mon backport. Le même pbm est arrivé sur des backports de clamav. La solution d’un install avec force peut aussi fonctionner mais c’est peu satisfaisant.


#9

Heu finalement aujourd’hui il ne demarre plus j’ai cela :amule: Symbol `_ZTI7wxSizer' has different size in shared object, consider re-li nking Fatal Error: Mismatch between the program and library build versions detected. The library used 2.6 (no debug,Unicode,compiler with C++ ABI 102,wx containers,c ompatible with 2.4), and your program used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx contai ners,compatible with 2.4). Abandon

Ca veut dire quoi ?

Entre temps j’ai changé de noyau je suis en 2.6.15-1-K7


#10

Installe paquet à la main. Chez moi ca a fonctionné.
http://packages.debian.org/cgi-bin/download.pl?arch=i386&file=pool%2Fmain%2Fw%2Fwxwidgets2.6%2Flibwxgtk2.6-0_2.6.1.2_i386.deb&md5sum=264c896e54e0b1555c767d316abd68c1&arch=i386&type=main


#11

Merci cela à l’air de fonctionner. :wink: