[résolu]probleme montage automatique de cle USB


#1

je suis sous debian 2.6.15-1-686
et ma cle usb ne semble pas etre montée automatiquement, du mon je ne la vois nul part, meme pas dans fstab
/dev/hda1 /media/winc ntfs defaults,ro,user,auto,umask=000 0 0
/dev/hda5 /media/wind ntfs defaults,ro,user,auto,umask=000 0 0
/dev/hda7 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

voici les messages affichés lors de l’insertion de la cle en utilisant la commande : sudo tail -f /var/log/messages

May 2 15:50:22 localhost kernel: usb 4-3: new high speed USB device using ehci_hcd and address 7
May 2 15:50:22 localhost kernel: scsi5 : SCSI emulation for USB Mass Storage devices
May 2 15:50:27 localhost kernel: Vendor: Generic Model: USB Flash Disk Rev: 2.00
May 2 15:50:27 localhost kernel: Type: Direct-Access ANSI SCSI revision: 02
May 2 15:50:28 localhost kernel: ready
May 2 15:50:28 localhost kernel: SCSI device sda: 2047488 512-byte hdwr sectors (1048 MB)
May 2 15:50:28 localhost kernel: sda: Write Protect is off
May 2 15:50:28 localhost kernel: SCSI device sda: 2047488 512-byte hdwr sectors (1048 MB)
May 2 15:50:28 localhost kernel: sda: Write Protect is off
May 2 15:50:28 localhost kernel: sda: unknown partition table
May 2 15:50:28 localhost kernel: sd 5:0:0:0: Attached scsi removable disk sda


#2

Il y a un truc assez intéressant sur Lea Linux pour le montage de clé USB, je n’ai pas regardé si ici il y avait un sujet qui en parlait, tiens voici le lien :
lea-linux.org/cached/index/Fiche … b_%3F.html


#3

ok ca c pour le montage, ca marche, mais pour le montage automatique avec ouverture de la cle automatique sous Konqueror et pourquoi pas affichage de la cle sur le bureau lorsqu’elle est connectée ? je fais comment ?


#4

[quote=“aswat”]ok ca c pour le montage, ca marche, mais pour le montage automatique avec ouverture de la cle automatique sous Konqueror et pourquoi pas affichage de la cle sur le bureau lorsqu’elle est connectée ? je fais comment ?[/quote]l’automatisation comme avec un CD quand elle ne fonctionne pas chez moi (ce qui arrive fréquemment), ben je me dis que zut, faudra que je regarde pourquoi, un jour :mrgreen: .
Par contre, j’ai toujours un raccourcis matériel KDE dans le fond du bureau que j’ai créé avec le clic droit, et qui me permet d’accèder à la clé en la montant automatiquement quand j’ouvre le lien, et qui me permet de la démonter par clic droit.
Tu as regardé si un icone de clé n’apparaissait pas sur le bureau ?
sinon, par une url du type ‘media:’ ?


#5

C’est peut-etre bebete mais moi j’ai juste fait comme dans l’url citée plus haut , j’ai rajouté cette ligne dans /etc/fstab :

on met ce qu’on veut à la place de usb.

et créé le répertoire

Il faut juste avoir le même nom dans fstab et /mnt

Comme ca on peut la monter/démonter avec le clic droit dans Konkeror ou bien en deux clics avec KwickDisk quand il est iconifié.

Je me demande si elle ne se monte pas toute seule quand on a automount (que je n’ai pas).

Mais parfois j’ai des pépins pour la démonter, p. ex quand konkeror est encore ouvert sur un bureau. C’est encore un truc qu’il faudrait regarder un jour[/i]


#6

je connaisais le truc pour creer l’icone, mais avec cette maniere de proceder, l’icone reste si la cle est demonte, et konqueror ne s’ouvre pas quand je la monte


#7

comme je te disais, j’ai cherché un peu quand même, mais j’ai arrèté de me prendre la tête dessus depuis longtemps: quand ca marche c’est bien, sinon, je clique.
Maintenant peut être qu’un autre a une idée ?


#8

Je crois qu’il y a un paquet pour cela, [troll]mais qui n’est pas necessaire sous gnome…[/troll]


#9

Essayes le paquet “usbmount”


#10

j’ai trouve la solution, alors je la poste si jamais ca interesse quelqun:(notamment MattOTop, merci pour ton aide)

il ne faut rien rajouter a fstab !!!
apt-get install hal
apt-get install pmount
pmount /dev/sda cle
reboot et ca marche !!!
la cle sera alors accessible a partir de /media/cle !!! et ce lancera automatiquement au demarrage


#11

[quote=“aswat”]j’ai trouve la solution, alors je la poste si jamais ca interesse quelqun:(notamment MattOTop, merci pour ton aide)

il ne faut rien rajouter a fstab !!!
apt-get install hal
apt-get install pmount
pmount /dev/sda cle
reboot et ca marche !!!
la cle sera alors accessible a partir de /media/cle !!! et ce lancera automatiquement au demarrage[/quote]

Et ça marche qu’elle soit branchée ou non à l’allumage ?? C’est à dire si tu lances ton micro sans ta clé en qu’ensuite tu la branche elle est montée automatiquement ??


#12

oui tout a fait, c’est le but :wink:


#13

Bonjour,

Bien vu capucine, et c’est bien pmount & hal, en tout cas sous gnome, et je les ai, ça marche nickel … curieux je me souviens plus de l’avoir installé …

Faut voir, sur kde … doit y avoir un équivalent sinon .


#14

Super la manip çà marche… :laughing: :laughing:


#15

bien sur que ca marche sous KDE, je suis sous KDE 3.5.2