[resolu]probleme premiere installation debian


#1

Bonjour,

Je suis un nouvel utilisateur de Debian/linux et donc pour ne pas faire de betises, j’ai utilise ce tuto pour ma premiere installation

Tout se passe bien jusqu’a l’installation de KDE et XFree
J’ai taper la comande : “apt-get install kde kde-i18n-fr x-window-system-core” Comme indique dans le tutoriel

apres, j’attaque la configuration des paquets
Fontconfig et xserver ; pas de nouvelle kpilot, cvs et libpangoO (est ce normal)

Apres, je tape donc startx et la, j’ai une petite fenetre avec ce message :

X session: unable to start X session — no"/root/xsession" file, no"/root/Xsession" file, no session managers, no window managers, and no terminal emulators found ; aborting .

Si quelqu’un a l’une ou l’autre idee, je l’en remercie d’avance


#2

Bonjour,

Précision : je suis aussi débutant sous Linux (je viens de galérer pendant une semaine pour réussir à installer, et surtout à faire démarrer, une Debian sur du RAID 1).

Je vois déjà un truc qu’il est conseillé de ne pas faire dans tes manips : se connecter en root au serveur graphique. Dans l’idéal, crée-toi un compte utilisateur, à qui tu donneras des droits au fur et à mesure (en ouvrant un terminal root, au pire, bien que tu puisses accéder aux consoles à partir du mode graphique en appuyant sur les touches Ctrl+Alt+Fn, avec n le numéro de console - Ctrl+Alt+F2 pour la deuxième, quoi).

Pour le reste, je vois pas. A priori, t’as pas utilisé avec apt-get avec l’option “-s”, sinon t’aurais rien pu configurer.
Comme je suis un peu brut, je te dirais bien de faire un “apt-get remove” de tout ça et de recommencer le apt-get.

Ou même, de tenter le coup avec un autre environnement (Gnome, au hasard - tu trouveras un tuto sur cette page - je suis en train de le suivre, d’ailleurs :), ou bien FluxBox ou XFce.

Bon courage en tout cas !!


#3

je ne me suis pas connecte en root, j’ai bien cree un utilisateur, pour ce qui est des apt-get avec -s, ces sont des simulation d’installation, je les ai faites, et ca ne m’as pas mis d’erreur, donc je suis passe a l’etape suivante, c’est a dire le meme sans le -s


#4

Ok, bah je vois rien d’autre que la désinstallation/réinstallation, alors.
Remarque, pour l’instant j’ai essayé fluxbox, XFce et Gnome, mais pas encore KDE…
Pour ton problème, la recherche sous Google ne m’a rien donné, alors… Sans doute quelqu’un d’autre aura la solution ?!

Bon courage !

Edit : Je pense à un truc : tes installations, tu les fais bien avec le compte root ? (pour ce que j’en sais, ce n’est pas possible avec un autre compte, mais bon). Parce que le fait que XFree esasie d’aller chercher son fichier .xsession dans le compte du root me paraît quand même bizarre : si tu lances startx à partir de ton compte utilisateur, il devrait aller chercher dans le répertoire racine de cet utilisateur, et pas dans celui de root…

J’ai vu un truc aussi, sur une page, qui disait, pour lancer gnome, de faire :
echo “gnome-session” > ~/.xsession
Pourquoi alors ne pas essayer de faire :
echo “kde-session” > ~/.xsession
avant de lancer startx ? Au pire, ça ne fera pa de mal… ?


#5

ok, merci de ton aide


#6

Sinon, si tu penses utiliser kde comme wm, tu peux essayer d’installer directement kdm comme login manager: par le jeux des dépendances, c’est ce que j’ai trouvé de mieux pour installer directement un kde qui fonctionne.
Tu es sur que toutes les configurations d’apt se sont bien passées ? que donne un ‘apt-get -f install’ ?


#7

[quote=“Jabba”]La meilleure chose à faire est d’installer un max. d’outils de détection hardware.
apt-get install discover1 hwinfo read-edid xdebconfigurator kudzu mdetect gpm

Et ensuite, tu tapes:

xdebconfigurator -diklr
puis:
dexconf

Ca te génère un superbe fichier XF86Config-4 avec quasiment toutes les modes et résolutions supportées par ton matos.

Depuis que j’utilise cette méthode, fini la galère de config. pour X11 ! :smiley:
Il y a des fois des petits détails à modifier à la main mais c’est rare…[/quote]

J’ai trouver ceci dans un autre post, est ce que ca pourais etre une solution si j’ai mal configure XFree ?


#8

Ouaip ! C’est mouâh qui l’avais posté :smiley:
Si tu lances ces commandes dans cet ordre, ca te fait une config quasi automatique de X11.
Essayes et tu m’en diras des nouvelles :slightly_smiling:

Pour être sûr d’avoir tout installé les paquets requis pour X11 tapes:

apt-get install kde ou gnome.

Je crois que le paquet kde (ou gnome) est un paquet générique (ou virtuel ou métapackage, ne m’rapelle plus le terme consacré …) qui regroupera tout ce qui est nécessaire pour faire un environnement graphique complet et cohérent. D’après tes messages d’erreur, on dirait que ton install n’est pas complète…

Et en plus, ca économise tes pt’its doigts de ne taper qu’un seul nom de package … :wink:


#9

en ne tapent qu’apt-get install KDE, cela ne risque pas de m’installe plain de truc inutiles ?


#10

A mon avis, t’es loin du compte : ça va t’installer PLETHORE de trucs dont tu ne te serviras pas, et qui te pollueront l’espace jusqu’à ce que tu les aies retirés.
D’un autre côté, ça marchera enfin. En gros, t’auras (sans doute) une interface graphique qui marche. Mais au prix d’un gros bazar logiciel.


“C’est VOTRE choix et nous le respectons” (désolé)


#11

Effectivement, ca va installer beaucoup de choses … Mais l’idée serait plutôt d’installer une config qui marche, sans être optimale, et ensuite seulement de virer l’inutile.
Ca me paraît plus réaliste que de vouloir tout de suite faire une config. optimisée sur une install qui ne marche pas …

Ensuite, il y a des tas d’outils qui t’aideront à faire le tri entre ce que tu veux garder et l’inutile.

Encore mieux: tu dédies une partition de ton disque pour les tests. Et sur cette partition, tu fais une install identique à ton install principale. C’est à dire FULL.
Ensuite, tu optimise cette copie et tu peux ainsi VALIDER tes changements, AVANT de les faire sur ton install principale, sans risquer de casser ton install principale …


#12

ok merci du conseil, je vous tien au courant, ce sera certainement pour demain, pas trop le temps aujourd’hui :smiling_imp:


#13

Apres un apt-get install kde, ca marche, il devais certainement me manquer une dependance :slightly_smiling: