[resolu]Probleme startx suite mise à jour Kernell


#1

Bonjour

J’étais en kernell 2.6.8 losque j’ais fais une apt-get install pour install un kernell 2.6.16 . lors de cette installation il a mis a 85 packages dont celui de gdm.

Je reboot. la je ne vois pas la nouvelle ligne de boot 2.6.16 .
donc je boot sur la 2.6.8 .
A ce moment la pas moyen de lancer le startx.
Pouvez me dire comment faire pour revenir a la version precedente de gdm??? si possible? ou une autre mùethode ???

Merci de votre aide


#2

essais de booter sur un live cd et de mettre a jour ton grub, ou modifie à la main ton /boot/grub/menu.lst


#3

ok je v tenter l’opération.

Mais je ne vois pas l’interet !!

Je ne pourrais quand meme pas avoir mon startx ?? si ??

et que dois je mettre dnas le fichier menu.lst ??? je suppose la ligne du kernel 2.6.16 ??? je copie la syntaxe comme les autres???


#4

slt,

[quote]
ok je v tenter l’opération.

Mais je ne vois pas l’interet !!

Je ne pourrais quand meme pas avoir mon startx ?? si ?? [/quote]

L’interet c’est que tu puisse modifier ton chargeur de boot et effectivement ajouté ton new kernel, tu me diras tu arrive a booter avec l’ancien kernel donc si tu as accés a ton fichier de conf du chargeur pour le modifier et ajouter ton new kernel c’est idem.

[quote]
et que dois je mettre dnas le fichier menu.lst ??? je suppose la ligne du kernel 2.6.16 ??? je copie la syntaxe comme les autres???[/quote]

je suppose la ligne du kernel 2.6.16, oui :laughing:
je copie la syntaxe comme les autres, oui :laughing:


#5

Essaie aussi

chmod 1777 /tmp

c’est assez classique comme panne après un upgrade.


#6

[quote=“stonfi”]slt,

[quote]
ok je v tenter l’opération.

Mais je ne vois pas l’interet !!

Je ne pourrais quand meme pas avoir mon startx ?? si ?? [/quote]

L’interet c’est que tu puisse modifier ton chargeur de boot et effectivement ajouté ton new kernel, tu me diras tu arrive a booter avec l’ancien kernel donc si tu as accés a ton fichier de conf du chargeur pour le modifier et ajouter ton new kernel c’est idem.

[quote]
et que dois je mettre dnas le fichier menu.lst ??? je suppose la ligne du kernel 2.6.16 ??? je copie la syntaxe comme les autres???[/quote]

je suppose la ligne du kernel 2.6.16, oui :laughing:
je copie la syntaxe comme les autres, oui :laughing:[/quote]

ok j ai fait ca
au reboot je choisi donc ma nouvelle ligne. mais il ne boot aps dessu car en fait de compte dans le dossier boot je n ai pas d image vmlinuz et initrd qui correspon a mon nouveau kernell

don *c je pense pas qu’il l’a installé.
cepdendant il a mis a jour mon gdm!!
commenert peut on faire pour revenir à la version précedente.
je peux tout de meme acceder a debian en version commande.


#7

[quote=“ricardo”]Essaie aussi

chmod 1777 /tmp

c’est assez classique comme panne après un upgrade.[/quote]

je vais tenter ca!!


#8

marche pas le chmod :frowning:

Faudrait il reinstaller le système ??? Ca serait plus rapie mais je n’apprendrais pas à réparer mes erreurs !!


#9

slt,

Non c’est clairs que ce n’est pas le meilleur moyen de réinstallé, il met arriver de plancher plus de 2 semaines sur des problémes…Oui donc si tu n’as pas le nouveau kernel si qu’il n’est pas installé Si tu as accés a ta Debian en ligne de commande peut tu lançé gdm et voir ce qu’il ce passe, si il y a des messages d’erreurs, des infos, etc… ? est tu sur que “apt” a fini de tout installer essai “apt-get install” et regarde le nombre de paquets non installé ou non mis a jours.


#10

si quelqun pouvait donner une solution, j’ai exactement le meme probleme…


#11

Je n’ai pas la solution mais je peux donner des pistes pour les trouver …
Suite à une évolution de sarge à testing, aptitude voulait installer la nouvelle version de udev et un autre paquet dont j’ai oublié le nom. Pour cela il faut tourer sur un kernel > 2.6.12 et on est en 2.6.8 … et udev ne si’installle pas ! Et les paquets suivants de la liste non plus, dont le kernel 2.6.15 … On tourne en rond !
Ce que j’ai fait et a fonctionné (sans garanties) :

  • un reboot
  • avec aptitude installer le nouveau kernel et enlever udev
  • reboot avev le nouveau kerne. startx ne fonctionne pas car l’écran n’est pas détecté
  • si c’est le 2.6.15 (ou +) installer udev
  • reboot : startx devrait fonctionner
    Bonne chance :wink:

#12

essaye d enlever hotplug je sais que j ai une icompatibilté avec udev


#13

ok je teste et je dis koi


#14

[quote=“ginkgo biloba”]Je n’ai pas la solution mais je peux donner des pistes pour les trouver …
Suite à une évolution de sarge à testing, aptitude voulait installer la nouvelle version de udev et un autre paquet dont j’ai oublié le nom. Pour cela il faut tourer sur un kernel > 2.6.12 et on est en 2.6.8 … et udev ne si’installle pas ! Et les paquets suivants de la liste non plus, dont le kernel 2.6.15 … On tourne en rond !
Ce que j’ai fait et a fonctionné (sans garanties) :

  • un reboot
  • avec aptitude installer le nouveau kernel et enlever udev
  • reboot avev le nouveau kerne. startx ne fonctionne pas car l’écran n’est pas détecté
  • si c’est le 2.6.15 (ou +) installer udev
  • reboot : startx devrait fonctionner
    Bonne chance :wink:[/quote]

donc j’ai essaye ca mais moi meme je tourne en boucle car il ne veut pa installer le kernell!!! il trouve pas les paquets alors qu’il y sont
je fais apt-cache search linux-image et la je le vois :slightly_smiling:

j’enleve udev enfin je fais tout comme tu dis. et ca marche pas.

par ailleurs mon fichier de log Xfree86 m’indique no core pointer. Pourtant il y a mon touchpad et ma souris en usb.

any ideas ???

Merci :slightly_smiling:


#15

bon j’ai reinstalle le kernel , reboot.

mon startx demarre comme il faut.

Merci de votre aide :slightly_smiling::d


#16

vais tester ca de suite

merci


#17

c’est bon

suppression de udev,
reinstall du kernel, et le tour est joué

merci