[résolu] Quel depot pour vlc sous debian etch ?


#1

je ne parviens pas a installer vlc :

apt-get install vlc me donne :

adrien@X31:~$ sudo apt-get install vlc
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Aucune version du paquet vlc n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet vlc

mon sources.list :

deb cdrom:[Debian GNU/Linux testing Etch - Official Snapshot i386 Binary-1 (20060403)]/ etch contrib main

deb ftp2.fr.debian.org/debian/ etch main
deb-src ftp2.fr.debian.org/debian/ etch main

deb security.debian.org/ etch/updates main contrib
deb-src security.debian.org/ etch/updates main contrib
deb security.debian.org/ testing/updates main

deb ftp2.fr.debian.org/debian etch main contrib non-free
deb ftp.fr.debian.org/debian/ testing main contrib non-free

deb ftp2.fr.debian.org/debian/ testing main contrib
deb-src ftp2.fr.debian.org/debian/ testing main contrib

#deb download.videolan.org/pub/videolan/debian sid main
#deb-src download.videolan.org/pub/videolan/debian sid main


#2

$ apt-cache policy vlc vlc: Installé : (aucun) Candidat : 0.8.1.svn20050314-1sarge1 Table de version : 0.8.5-test3.debian-3 0 800 http://ftp.debian.org unstable/main Packages 0.8.1.svn20050314-1sarge1 0 990 http://security.debian.org stable/updates/main Packages 990 http://ftp.rfc822.org stable/updates/main Packages 990 ftp://ftp.nerim.net stable/main Packages 0.8.1.svn20050314-1 0 100 /var/lib/dpkg/status
Voilà plusieurs dépôts possibles :wink:


#3

je suppose qu’il faut rajouter deb devant les liens, mais ca ne marche pas ik me met plein de bugs :


#4

je te conseil d’aller faire un tour sur apt-get.org :laughing:

tu trouvera surement ton bonheur


#5

et aussi debian.org/distrib/packages


#6

Bonsoir,
je l’ai installé sans probleme en sarge, avec différents dépots de base sarge (ftp non ftp2) et unofficial … avec la plupart des paquets recommandés par apt, (lirc ne me parait pas utile … pour moi), et ça marchait … oui au passé, car là j’ai un petit souci avec vlc …
bon courage .


#7

essaie ça :

deb ftp://ftp.nerim.net/debian-marillat/ sarge main deb ftp://ftp.nerim.net/debian-marillat/ etch main


#8

merci au petiti chat noir car seul ton lien m’a donné des possibilitées, sur packages.debian.org/ , pas de vlc, ni en stable, etc, ou unstable,

apt-get.org me donne ca :

(Verified) Latest Debian packages of VideoLAN software for Woody/Sarge/Sid (Added 2002-11-30, last checked 2006-01-18) (Download as text)
Packages in database: flac, gnome-vlc, gvlc, kvlc, libdvbpsi2, libdvbpsi2-dev, libdvbpsi3, libdvbpsi3-dev, libdvdcss2, libdvdcss2-dev, …
Architectures: all, i386, powerpc
deb download.videolan.org/pub/videolan/debian woody main
deb-src download.videolan.org/pub/videolan/debian woody main
deb download.videolan.org/pub/videolan/debian sarge main
deb-src download.videolan.org/pub/videolan/debian sarge main
deb download.videolan.org/pub/videolan/debian sid main
deb-src download.videolan.org/pub/videolan/debian sid main

je teste et j’edite pour vous tenir au courant

Resultat des courses il ne veut pas s’installer:adrien@X31:~$ sudo apt-get install vlc
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.

Puisque vous n’avez demandé qu’une seule opération, le paquet n’est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
vlc: Dépend: aalib1 (>= 1.2)
Dépend: slang1 (> 1.4.4-7.1) mais il n’est pas installable


#9

Mais qu’est ce que c’est que ton sources.list même pas complet sur les dépots de base ?

console@matlin:~$ apt-cache policy vlc vlc: Installé : (aucun) Candidat : 0.8.1.svn20050314-1sarge1 Table de version : 0.8.5-test3.debian-3 0 96 http://ftp2.fr.debian.org sid/main Packages 0.8.1.svn20050314-1sarge1 0 990 http://ftp2.fr.debian.org sarge/main Packages 991 http://security.debian.org sarge/updates/main Packages 0.8.1.svn20050314-1 0 100 /var/lib/dpkg/status
1/mets contrib et non-free partout ou tu as main sur les depots debian. Ce n’est pas normal qu’ils ne soient pas là…
2/les dépots marillat indiqués par Ricardo, même s’ils ne contiennent pas VLC (bizarre tt de même) sont incontournables dés que tu fais de la video (divx, codecs divers, logiciels de télé, etc…).


#10

[quote=“aswat”]merci au petiti chat noir car seul ton lien m’a donné des possibilitées, sur packages.debian.org/cgi-bin/sear … elease=all

[code]Package vlc

* oldstable (graphics): a free MPEG and DVD player
  0.2.92-8: alpha arm hppa i386 ia64 mips mipsel powerpc s390 sparc
* stable (graphics): multimedia player for all audio and video formats
  0.8.1.svn20050314-1sarge1: alpha amd64 arm hppa i386 ia64 mips mipsel powerpc s390 sparc
  0.8.1.svn20050314-1: amd64
* unstable (graphics): multimedia player for all audio and video formats
  0.8.5-test3.debian-3: alpha amd64 arm hppa i386 ia64 mips mipsel s390 sparc
  0.8.4.debian-2+b1: powerpc

[/code]Ben alors :smiley:


#11

milles excuses si mon sources.list n’est pas complet,
je suis debutant, et mon sources.list est celui de base lors de l’installe de ma debian etch + quelques depots dont j’ai eu besoin pour ma carte wifi, pour le reste je ne sais pas :frowning: ,
a quoi devrais il resembler ?

uname -a me donne:

2.6.15-1-686

dans sources.list j’ai :

deb cdrom:[Debian GNU/Linux testing Etch - Official Snapshot i386 Binary-1 (20060403)]/ etch contrib main

deb ftp2.fr.debian.org/debian/ etch main
deb-src ftp2.fr.debian.org/debian/ etch main

deb security.debian.org/ etch/updates main contrib
deb-src security.debian.org/ etch/updates main contrib
deb security.debian.org/ testing/updates main

deb ftp2.fr.debian.org/debian etch main contrib non-free
deb ftp.fr.debian.org/debian/ testing main contrib non-free

deb ftp2.fr.debian.org/debian/ testing main contrib
deb-src ftp2.fr.debian.org/debian/ testing main contrib

deb download.videolan.org/pub/videolan/debian woody main
deb-src download.videolan.org/pub/videolan/debian woody main
deb download.videolan.org/pub/videolan/debian sarge main
deb-src download.videolan.org/pub/videolan/debian sarge main
deb download.videolan.org/pub/videolan/debian sid main
deb-src download.videolan.org/pub/videolan/debian sid main

effectivement packages.debian.org/cgi-bin/sear … elease=all me propose pleins de versions je vais essayer ca, mais j’atends vous conseils pour le sources.list, merci d’avance

Aswat


#12

Lis les fils qui ont eu lieu ici, et fais le toi même, s’il te plait. On est pas ici pour faire nous même ton install, et ca, c’est la base, et c’est toi qui choisit.
Tu trouveras 50 sources.list convenables ici même.


#13

j’ai lu tout le topic sur les sources.list mais franchement en tant que debutant c’est deroutant et lors des apt-get update j’ai tres souvent pleins d’erreurs que je ne comprends pas en utilisants d’autres depots, c’est pour cette raison que je demande de l’aide, pas pour faire chier mon monde.

C’est pas evident de galerer dans le monde de linux quand on est un habitué du monde de Microsoft ou il faut bien l’avouer, les chose sont certe pas optimisées mais plus accéssible… maintenant, comme je suis “curieux” et aussi parceque j’aime le concepte du logiciel libre, l’esprit de communauté qui y reigne, je me tourne vers linux, et apres avoir utilisé des distributions simple du genre Ubuntu, je me suis mis a debian et la je me prend une claque en pleine face, je fait tt moi meme, j’ai mis deux jours pour faire marcher mon wifi, !!!, alors svp un petit effort .

De plus je me suis demandé si le fait de mettre des serveurs contenant des paquets pour une autre version que la ETCH, n’est il pas prejudiciable pour mon systeme ?

Merci de votre aide :cry:

aswat


#14

Bonjour, :stuck_out_tongue:
Accroches toi ptit, ça en vaut la peine … 8)
Non sérieux, le sources list dans truc et astuces c’est une super idée,ça aide vachement, mais quand on est bébé informaticien (windozien exclusif), on se perd dans tous les exemples … je sais, j’en ai fait les frais.

On pourrait faire un sources.list typique débutant pour sarge, etch, sid avec les preférences qui vont avec, plus quelques illustrations de cas particuliers non (style un package sid alors qu’on est en sarge :wink: ), une synthèse en trois volets quoi ?


#15

Non ce n’est pas préjudiciable de mettre d’autre dépots du moment que tu lui rajoute un fichier preferences pour organiser tout ca. Dans le topic sur les sources.list (cf forum.debian-fr.org/viewtopic.php?t=1810 ) tu peux y voir mon fichier sources.list ainsi que mon fichier preferences il a été concu pour avoir tout les paquets etch et recupéré les paquets linux-source-2.6.* nmap ethereal nvidia-glx et nvidia-glx-dev unstable. N’hésite surtout pas à tous les regarder, ils sont tous interressant.

Il te suffit de les regarder et d’essayer de comprendre pourquoi ca a été fait comme ca. Si tu as des questions pose les plus précisement sur un autre fil ca permettera de te faire avancer dans la conception de ton sources.list et de te faire toi meme le tien. Tout dépend de ce que tu veux.

Essaye aussi dans la conception de ce fichier de l’organiser ca permet de mieux se retrouver et de faciliter son entretien.


#16

Allez je suis de bonne humeur et j’ai 5 min voila un sources.list et son fichier preferences typiquement stable avec récupération des linux-sources unstable. J’y ai aussi rajouté les depots marillat. Les # au debut de la ligne sont pour commenté la ligne ainsi les depots sources ne sont pas récupérés mais on peux le changer facilement en retirant les # devant les deb-src qui nous conviennent.

[u]/![/u]Surtout ne pas oublier de rajouter une ligne vide à la fin des fichiers.

/etc/apt/sources.list

[code]# Stable
deb http://security.debian.org stable/updates main contrib non-free
#deb-src http://security.debian.org/ stable/updates main contrib non-free
deb http://ftp.fr.debian.org/debian stable main contrib non-free
#deb-src http://ftp.fr.debian.org/debian stable main contrib non-free

Testing

deb http://security.debian.org etch/updates main contrib non-free
#deb-src http://security.debian.org/ etch/updates main contrib non-free
deb http://ftp.fr.debian.org/debian etch main contrib non-free
#deb-src http://ftp.fr.debian.org/debian etch main contrib non-free

Unstable

deb http://ftp.fr.debian.org/debian unstable main contrib non-free
#deb-src http://ftp.fr.debian.org/debian unstable main contrib non-free

Mirroir video et autre http://debian.video.free.fr/

deb ftp://ftp.nerim.net/debian-marillat/ sarge main[/code]/etc/apt/preferences[code]Package: *
Pin: release a=stable
Pin-Priority: 550

Package: *
Pin: release a=apt-build
Pin-Priority: 990

Package: *
Pin: release a=testing
Pin-Priority: 33

Package: *
Pin: release a=unstable
Pin-Priority: 33

Package: *
Pin: release a=experimental
Pin-Priority: 15

package: linux-source-2.6.*
pin: release a=unstable
pin-priority: 550
[/code]


#17

merci beaucoup a toi Ashgenesis, en effet je suis windowsien depuis plus de 10 ans, alors il y a des habitudes a faire passer… je teste ton /etc/apt/sources.list, youhou vlc marche !!!

enfin

je tenterais de l’ameliorer au fur et a mesure (sources.list)

aswat


#18

Super ash !!
ps: une ligne vide : tu veux dire presser “Enter” pour valider la dernière ligne … si c’est un ajout que l’on a fait en fin de fichier oui …


#19

moi j’ai ce message qui s’affiche apres avoi fait un : apt-get update

W: GPG error: ftp://ftp.nerim.net sarge Release: Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 07DC563D1F41B907
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.


#20

bonjour,
je sais pas aswat, mais ici il en est question, mais je crois que quelqu’un saura te donner une explication :
http://forum.debian-fr.org/viewtopic.php?t=1741&highlight=cl%E9+publique+nest+pas+disponible
ps: dans votre sources.list - trucs et astuces - page 4 aussi .
@+