[Resolu]Rtorrent et routeur


#1

Je souhaiterais utiliser le téléchargement via rtorrent mais le problème c’est que j’ai quelques difficultés a tout configurer chez moi je ne comprends pas trop pourquoi je n’arrive pas a télécharger quoi que ce soit.

J’ai un routeur que j’ai configurer pour laisser passer les paquets a destinations de rtorrent. Et je n’ai rien d’activer au niveau iptables.

Doù pourrais venir se probleme de connection sachant que la navigation, et le mail fonctionne tres bien.

Pour plus d’info 36 15 questions et j’y répond :slightly_smiling:

[code]iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
fail2ban-ssh tcp – anywhere anywhere tcp dpt:ssh

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain fail2ban-ssh (1 references)
target prot opt source destination
RETURN all – anywhere anywhere
[/code]


#2

allo ? 3615 questions ? que donne le resultat de ‘iptables -L -t nat’ ?
(si tu veux tout lister d’iptables, sinon, c’est iptables-save)
Si c’est comme les autres p2p que je connais, il faut en fait y rajouter une règle pour rediriger le port rtorrent de ton routeur vers celui de ta machine cliente (c’est du DNAT, en termes consacré).
Tu peux transposer ce que tu trouves à propos du port 4667 de la mule au travers d’un routeur.


#3

[code]iptables -L -t nat
Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[/code][quote=“MattOTop”]Si c’est comme les autres p2p que je connais, il faut en fait y rajouter une règle pour rediriger le port rtorrent de ton routeur vers celui de ta machine cliente (c’est du DNAT, en termes consacré).
Tu peux transposer ce que tu trouves à propos du port 4667 de la mule au travers d’un routeur.[/quote]Oui c’est en gros pareil, ce que je ne comprends pas c’est que j’ai cette regle sur mon routeur en fait je fait du forwarding (d’apres mon routeur) je transfert donc tous les paquets qui arrive sur mon routeur vers ma machine et inversement (normalement).

J’ai monté une patition FAT32 et mon torrent ainsi que le fichier telecharger seront sur cette partition est ce qu’il pourrais y avoir un probleme d’écriture?

drwxrwxrwx 4 ash ash 16K 2005-11-30 12:05 hdd1


#4

attends, les règles que tu m’indique pour le nat n’indiquent même pas de partage de l’internet.
Tu es sûr que tu me donnes bien les infos de pare feu de ton routeur, pas du client ?

pour ton pb d’ecriture, pas plus qu’avec n’importe quelle autre appli. Ca m’a l’air d’être bon. Tu as quoi ds le fstab ?


#5

J’ai bien peur que ce soit du client :blush: pour mon routeur c’est un wag54g de chez linksys je n’y ai donc pas acces en mode console seulement par l’interface web et tout se fait graphiquement.

[code]# /etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda4 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdb /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,umask=0 0 0
/dev/fd0 /mnt/floppy vfat rw,user,noauto,umask=0 0 0
/dev/hda1 /mnt/winnt ntfs ro,user,noauto,umask=0 0 0
/dev/hda5 /mnt/hdd1 vfat rw,user,noauto,umask=0 0 0
/dev/hda6 /mnt/hdd2 ntfs ro,user,noauto,umask=0 0 0
/dev/hda7 /mnt/hdd3 vfat rw,user,noauto,umask=0 0 0
/dev/hdd1 /mnt/hdd4 auto ro,user,noauto,umask=0 0 0
/dev/sda1 /mnt/usbkey auto rw,user,noauto,umask=0 0 0
/dev/sda5 /mnt/usbdrive auto rw,user,noauto,umask=0 0 0
/dev/sdb1 /mnt/usbkey256 auto rw,user,noauto,umask=0 0 0

[/code]


#6

bon je regarde un peu les docs de ton routeur (grande classe), mais déjà, il est sous linux à priori, et il existe des firmwares alternatifs comme dit ici en fin de page:
presence-pc.com/tests/Routeu … G-S-240/2/

bon en lisant la doc ( Linksys (édit par ed, url trop longue) ) j’ai pu vérifier que dans le mode avancé de l’interface, tu as une section port forwarding. C’est décrit page 56.
il faut juste que tu dise à ton routeur de rediriger son port rtorrent vers le port rtorrent de ta machine.

Sinon, je n’ai pas trouvé de ref dans la doc pour ce que j’en ai lu, mais essayes de te connecter en telnet sur ton routeur, pour voir…


#7

Merci pour tes réponses Matt mais c’est déjà fait j’ai forwarder le port 6881 vers mon pc (192.168.1.100)

Mais rien à faire aucune connection :confused:

Sinon mon routeur c’est un wag54g pas un wrt54g mais c’est presque pareil :slightly_smiling:

ftp://ftp.linksys.com/international/dat … _fr_ds.pdf
ftp://ftp.linksys.com/international/use … -fr_ug.pdf

Au niveau de telnet je n’arrive pas a me connecter 3 choses:
Soit je ne suis pas douer du tout :slightly_smiling:
Soit le routeur ne peux pas etre joint via telnet
Soit l’accès via telnet n’est pas activé

En tout cas merci pour les solutions proposés


#8

tu as ouvert le port 6881 en tcp, ou en udp ?
tu pourrais faire une photo de la page de config pour voir si tu l’as bien remplie ?
pour le telnet… ca m’etonne qu’il n’y ait pas de cli, mais bon, il y a peut être aussi une option dans l’interface web pour l’activer…


#9

au fait, tu es chez quel FAI ?


#10

ashgenesis.free.fr/routeur.jpg

FAI: wanadoo

J’ai déjà réussi à le faire fonctionner sous windows comprend pas pourquoi ca ne fonctionne pas???

Pour telnet je verifie


#11

dis moi: pourquoi ta photo montre que tu redirige vers le .103 alors que tu me dis que ta machine est en .100 ?


#12

C’est normal en fait quand j’ai pris la photo c’etait pour un test j’ai changé d’ip c’est con je sais mais je voulais tester et ca ne marche pas mieux mais c’est bien 100 et tout est configurer pour l’ip 100

dsl de l’embrouille

[edit] la capture est corriger[/edit]


#13

:open_mouth: :open_mouth: :open_mouth: C’est réglé je ne sais pas pourquoi mais en tout cas ca fonctionne

La seule chose que j’ai changé c’est que maintenant j’utilise ktorrent au lieu de rtorrent et ca passe va savoir pourquoi??? :open_mouth: :open_mouth: :open_mouth: