[Résolu] Samba problème avec win2000 mais marche avec winXP


#1

Bonjour,

j’ai un problème dont j’ai honte de parler sur ce forum mais le service venant de linux, tout linuxien peut être amené à rencontrer ce genre de problème.

Donc, j’ai installé un serveur samba avec lequel j’ai partagé des informations avec des ordi sous windows XP. Dernièrement j’ai recu un windows 2000 sur lequel je devais installer le disque partagé avec samba… et là ca ne marche pas.

Donc la commande que je tape est :

En fait l’erreur n’est pas direct, il me demande un mot de passe que je donne et il ne l’accepte pas… alors que sur un autre ordinateur il n y a pas de problème.

Merci par avance


#2

Plein de raisons possible et ta question n’est pas idiote (tu peux dc la poser aussi sur des forums samba, tu auras peut être de meilleures réponses qu’ici)
J’imagine que quand tu te connectes au share depuis explorer, ca ne fonctionne pas non plus ?
Quel type de machine se connecte bien: un autre 2000 ?
Est ce que tu gères un domaine ?
Qu’as tu dans ton smb.conf concernant le cryptage des mots de passe ?


#3

[quote=“MattOTop”]Plein de raisons possible et ta question n’est pas idiote (tu peux dc la poser aussi sur des forums samba, tu auras peut être de meilleures réponses qu’ici)
[/quote]
merci :smiley:

[quote=“MattOTop”]J’imagine que quand tu te connectes au share depuis explorer, ca ne fonctionne pas non plus ?
[/quote]

en effet ca ne marche pas…

non ce sont des ordis sous windows XP qui se connectent sans problème…

[quote=“MattOTop”]Est ce que tu gères un domaine ?
[/quote]
en fait je viens d’installer sur le serveur ou j’ai samba un cache DNS mais je n’ai pas eu le temps de faire plus… de le mettre en tant que vrai server DNS (il n’est pas DHCP)…

j’ai :

[quote][global]…
passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = Enter\snew\sUNIX\spassword: %n\n Retype\snew\sUNIX\spas
sword:
%n\n .

[public]
comment = echange
path = /home/public
valid users = @All
read only = No
force create mode = 0660
force directory mode = 0660

[/quote]

Merci du coup de main


#4

XP fonctionnant mieux que 2000 ! étonnant…
Bon, je n’ai pas trop le temps de lire la doc, mais il faudrait jouer avec les options d’encryptage de password, déjà, pour voir si en acceptant les password non cryptés (ou autres options de cryptage), c’est mieux.
Ah autre essai temporaire, tu peux aussi rendre le share complètement public (pas de “valid user”) comme ca, meme non autentifié, ca devrait donner accés normalement à ton 2000.
Sinon, je sais que j’ai du aller modifier des clés dans le registre pour un pb du meme genre, mais c’etait des XP qui ne se connectaient pas la ou des 2000 marchaient trés bien, et comme ca date un peu, je n’ai plus les textes de réfèrence.
Ah, sinon, quand je parlais de domaine, je parlais de domaine NT.


#5

je viens d’essayer le truc dont tu parles…
Panneau de config > outil d 'administration > stratégie de sécurité locale…

donc j ai activé l envoie de mdp non crypté… mais ca ne marche pas. J’ai également essayé de ne pas mettre de mot de passe sur le PUBLIC mais ca ne marche pas non plus… enfin j ai essayé tout ce que tu m as conseillé et tout ce qui me passait par la tete je n arrive pas a monter le serveur sous win2000…

Je ne sais meme pas si ca vient du mot de passe ou pas… car il me demande tout le temps le mot de passe sous 2000 alors que sous xp hier j ai installé le truc sous xp sans prob encore…

Merci du coup de main!


#6

Bon, je ne connais pas ce que tu utilises pour configurer ton samba, mais il va falloir que tu te plonges dans la doc de la config de smb.conf, et que tu configures à la main: il y a de trés nombreuses options concernant la manière dont les clients s’authentifient, et ca m’etonnerait que tout soit gèré sous GUI (à part webmin qui m’a semblé complet, je n’ai jamais vu un outil gèrant toutes les options).
J’ai cherché un peu sur ton pb, mais rien de probant.
Je penses que si tu n’a pas trop d’inquiétude quand à la securité de ton serveur, tu pourrais publier déja l’integralité de ton smb.conf.
Si tu peux, donc, je regarderais un peu mieux demain aprés midi à quoi il ressemble.


#7

Salut,

je ne pense pas que mon chef verrais ca d’un bon oeil, mais je ne vois pas ou ca peut poser problème que je te montre le code. Car s’il y a des failles dans le code autant que je m’en apercoive… et je sais qu’en matiere de sécurité ce n’est pas un code qui est caché qui est le plus sur. (j’ai juste enlevé le nom de l entreprise…)

Donc :

[global]
        unix charset = iso8859-15
        workgroup = entreprise
        server string = Sambaserver
        obey pam restrictions = Yes
        passdb backend = tdbsam, guest
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        printcap name = cups
        os level = 33
        dns proxy = No
        wins support = Yes
        panic action = /usr/share/samba/panic-action %d
        invalid users = root
        printing = cups
        print command =
        lpq command = %p
        lprm command =

[homes]
        comment = Home Directories
        read only = No
        create mask = 0700
        directory mask = 0700
        guest ok = Yes
        browseable = No

[printers]
        comment = All Printers
        path = /tmp
        printer admin = root, adrien
        create mask = 0700
        guest ok = Yes
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
        write list = root

[public]
        comment = Datentausch fuer alle
        path = /home/public
        valid users = @All
        read only = No
        force create mode = 0660
        force directory mode = 0660

[SVN]
        comment = Datentausch fuer Entwicklung
        path = /home/system/
        valid users = @All
        read only = No
        force create mode = 0660
        force directory mode = 0660

Merci pour le coup de main!


#8

c’est bon je viens de résoudre mon problème qui ne venait pas du coté server mais du coté de Windows 2000… je ne sais pas comment ca se fait, mais, j’ai un peu plus cherché la doc sur net use et j’ai essayé la commande :

net use p: \\<nom_serveur>\<rep_partagé> <mdp_user> /USER:<user_login> et donc ca a marché.

Cependant si tu vois des erreurs ou des failles dans ma config n’hésite pas à m’en faire part!

Merci du coup de main.

PS : Je fermerais ce topic si tu me dis que tu ne vois rien de problèmatique… :smiley:


#9

non, ben rien de particulier.
Tu devrais peut être preciser security = user, même si c’est le défaut, et je me demande si le guest ok sur le home est vraiment souhaitable, mais je n’ai rien à dire de particulier sinon.


#10

ok merci je vais réviser ces points… Merci!