[RESOLU]sarge: impossible de rentrer sur interface graphique


#1

Bonjour,

J’ai installé la debian Sarge avec le kernel 2.6.8-1-686. L’install c’est bien déroulée j’ai installé le mini pour avoir kde et gnome. Au début tout allez bien puis j’ai installé Mozilla-firefox par apt-get et depuis au lancement de ma cession kde il reste bloqué sur : initialisation des service du systeme.

J’ai donc desinstaller avec apt-get --purge remove mais toujours rien.

Quelqu’un pourrait-il m’indiquer ce qui pourrait bloquer?

Merci


#2

Dans une console, si tu arretes ton login manager “/etc/init.d/kdm stop”, est ce que ta session KDE démarre avec un startx ?


#3

Salut,

Bon en fait c’est pas que ça se lance pas c’est que c’est très lent.
Pour ouvrir une applic il me met une plombe.

J’ai tout reinstallé mais c’est idem. Je rentre la première fois et dès que je lance une applic c’est fini


#4

ça y est j’ai trouvé d’ou vient le ralentissement.
C’est dès que je suis connecté au net.
Je suis en free non dégroupé 2048 avec le sagem fast800.
Si quelqu’un peut me dire pourquoi dès que je suis connecté j’ai le système ralenti!

Merci


#5

est ce par hasard que ton resolver resoud bien localhost en 127.0.0.1 ?
(‘host localhost’ ou ‘nslookup localhost’ )
ton problème me dit qqchose…
C koi ta carte graohique (je sais ca peut paraitre lointain, mais es ce que ce n’est pas une Nvidia, par hasard ?)


#6

c’est effectivement une nvidia geforce4 mx440


#7

comme moi, et j’ai eu le même problème, mais je ne me souviens plus trop comment je l’avais résolu.
Comme je passe par un routeur, déjà, ce n’est pas forcément SPECIFIQUEMENT le fast800 qui pose probleme.
Maintenant, je ne sais pas si tu as le serveur nv ou nvidia, mais si tu es en nvidia, dans ftp://download.nvidia.com/XFree86/Linux … README.txt
j’ai lu [quote]Q: Why do OpenGL applications run so slow?
A: The application is probably using a different library still on your
system, rather than the NVIDIA supplied OpenGL library. Please see
APPENDIX C for details.[/quote] et dans l’appendix C [quote]Problems will arise if applications use the wrong version of a library.
This can be the case if there are either old libGL libraries or stale
symlinks left lying around.[/quote].
J’ai vu aussi: [quote]Q: X takes a long time to start (possibly several minutes). What can I do?
A: Most of the startx delay problems we have found are caused by incorrect data in video BIOSes about what display devices are possibly connected or what i2c port should be used for detection. You can work around these problems with the X config option “IgnoreDisplayDevices” (please see the description in (app-d) APPENDIX D: X CONFIG OPTIONS).[/quote].
déja, si tu es en nvidia, est ce que les modules GLcore et dri sont bien desactivés dans ton XF86config-4 ?
sinon, en nv, est ce qu’elles sont bien activées ?


#8

je comprend bien ce que tu me conseille mais je ne comprend pas le rapport qu’il peut y avoir avec ma connexion adsl.

Pourquoi tout rentre dans l’ordre quand je coupe ma connexion?


#9

ma premiere intuition etait qu’il y avait un problème de resolver, le serveur X faisant appel, entre autres, au serveur de fonte local.
Si ta machine ne résoud pas bien localhost une fois la ligne levée, ca peut venir de ca.
Mais comme tu n’a pas eu l’air de relever d’incohérence, je suis allé ds une autre direction. Je t’avouerais que je suis parfois allé trés loin des symptomes de base pour résoudre certains problèmes.
Alors je ne m’étonne plus des endroits ou se trouvent les solutions: quand ce qui est évident ne marche pas, je lis, je tatonne, je corrige, et je comprend aprés. :confused:
++


#10

je n’avais pas jusqu’à present installé les drivers nvidia. Là c’est fait mais malgré tes conseils c’est pareil.
Je vais essayer avec l’option : "IgnoreDisplayDevices"
et reverifier les option GLCore et DRI.
L’option glx doit etre activée il me semble pour les driver NVIDIA?


#11

oui: extrait de mon XF86config-4 en config nvidia:

[quote]Section “Module”

Load “GLcore”

    Load    "bitmap"
    Load    "dbe"
    Load    "ddc"

Load “dri”

    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "record"
    Load    "speedo"
    Load    "type1"
    Load    "vbe"
    Load    "xtt"

EndSection[/quote]
bon, est ce que ton resolver répond normalement quand tu fais un ‘host localhost’ ?
si oui, est ce que tu ping le 127.0.0.1 ?


#12

la commande host localhost repond bien mais par contre le ping 127.0.0.1 ne me donne aucun résultat

J’ai bien l’impression que cela vient de la.


#13

Ca y est j’ai trouvé!!!
je n’avait pas configrué ma carte reseau qui au moment de l’install n’etait pas activée.
Je lui attribué une ip est c’est ok
C’est quand tu m’a dit d’essayer ping 127.0.0.1 qui m’a mis la puce à l’oreille.

Merci pour ton aide precieuse