[RESOLU] "sound card not defined" + "cannot o


#1

Bonjour tout le monde,

Je tente de passer a debian depuis quelques jours et autant dire que je lutte serieusement. L’installation c’est pas tres complique, la configuration parcontre la je seche un peu…

Pour info, je suis en train d’installer ‘woody’ a partir des 7 isos avec la doc ecrite par alexis delattre sur une carte Asrock K7S8X, carte son Sond Blaster Live! 5.1

Tout va bien jusqu’a l’installation de base de woody (cad avec le noyau 2.4), ca part en freestyle a partir du moment ou j’installe le noyau 2.6.9
Je compile le noyau avec le module son emu10k1 ainsi que le module de gestion de l’alim acpi (mais pas apmd)
Je specifie bien snd-emu10k1 comme driver de la carte son ds le fichier /etc/modprob.d/alsa
Je fais bien update-modules. D’ailleurs au passage j’ai l’impression que cette comande merdouille un peu aussi, elle n’est pas cense cocatener tous les fichiers contenus ds /etc/modprob.d/ ??? Parce que si c’est le cas, et bien elle ne le fait pas puisque je ne retrouve pas le fichier /etc/modprob.d/alsa dans /etc/modprob.conf (au cas ou j’ai fait la concatenation a la main cat /etc/modprob.d/* >> /etc/modprob.conf)
Je reboot…

J’en viens a mes problemes: :imp:

  • au demarrage, l’instruction suivante s’affiche: sound card not defined (un truc ds le style quoi) et effectivement je n’ai plus les petits bip agacant qui vous font remarquer que votre commande de shell n’est pas complete! :wink:
    C’est quoi le pb??? Parce que je ne compte plus le nombre de reinstallations de debian, ni le nombre de reboot et la je perds patience!
  • ca ne m’a pas empeche de continuer l’installation… Pour en arriver a un pb qui lui ne m epermet plus d’avancer: le crash du serveurX! Le fichier /var/syslog m’indique un warning: “Cannot open APM” Warning plutot suprenant: le serveurX s’occupe de gestion graphiques pas de l’alim, non??? le “man apm” m’intrigue aussi… Bref je ne vois pas d’ou vient le pb: de ma carte graphique (ATI Radeon, rien d’extraordinaire pourtant) ou de l’APM? qu’est ce que je dois faire???

Bon et bien je remercie d’avance totu ceux qui pourront me venir ne aide ainsi que tous les courageux d’avoir tout lu! :laughing:
ciao


#2

tu as raison de faire la concat de modprobe.conf à la main, update-module ne fais (à ma connaissance) que la mise à jour de modules.conf depuis modutils…
as tu essayé de configurer ta carte avec alsaconf (il faut verifier ensuite que tu es synchro entre le modprobe et le modutil, car je ne suis pas sur qu’il fasse la mise à jour des deux).
Pour ton serveur X, il faut bien qu’il gére le DPMS, donc qu’il administre les fonctionnalités d’énergie…
question, as tu compilé l’apm dans ton noyau ?
d’ailleurs, comment as tu compilé ton noyau ?
parcequ’a ma connaissance (jusqu’a aujourd’hui), il n’existe pas de paquetage 2.6.9, pour compiler à la sauce debian, et même si j’ai réussi à le faire sur ma machine, en patchant ‘debian’ un noyau “kernel.org”. J’ai tellement de problemes pour l’instant que je continue à tourner en 2.6.8.
Quant à la réinstallation… tu viens de Redmond ? :laughing:


#3

ah non! a tester des ce soir alors…

et comment tu verifies la synchro entre modprob et modutil???
Desole je suis vraiment un debutant de debian… de linux en general en fait lol. Mis a part mdk10 que j’ai garde 3 mois set qui m’a vite saoule!

acpi seulement. Apm egalement?

suivant la methode suivante: people.via.ecp.fr/~alexis/format … noyau.html

ben j’ai choppe comme toi la semaine derniere le noyau 2.6.9 present sur kernel.org
J’ai egalement recupere sur ce meme site le 2.6.8.1 Est ce que je dois preferer ce noyau au 2.6.9?

euh sorry la j’ai po compris la private jock!


#4

[quote=“Echo”]<…>[quote=“MattOTop”]
(il faut verifier ensuite que tu es synchro entre le modprobe et le modutil, car je ne suis pas sur qu’il fasse la mise à jour des deux).
[/quote]
et comment tu verifies la synchro entre modprob et modutil???
Desole je suis vraiment un debutant de debian… de linux en general en fait lol. Mis a part mdk10 que j’ai garde 3 mois set qui m’a vite saoule! [/quote]
tu as bien compris qu’ils étaient tous les deux génèrés avec le contenu de deux sous répertoires différents ? ben tu regarde dans les deux ss rep, si les fichiers alsa sont similaires, et tu compares modules.conf et modprobe.conf, pour voir si ces deux éléments de config se sont bien reportés aussi.

[quote=“Echo”][quote=“MattOTop”]
question, as tu compilé l’apm dans ton noyau ?
[/quote]
acpi seulement. Apm egalement?[/quote]
oui, mais avec un minimum de coché (chez moi, juste le support apm, mais aucune autre fonctionnalité).

[quote=“Echo”][quote=“MattOTop”]
d’ailleurs, comment as tu compilé ton noyau ?
[/quote]
suivant la methode suivante: people.via.ecp.fr/~alexis/format … noyau.html[/quote]
bon, c’est une methode traditionnelle, mais pas forcement compatible debian. de plus, les developpements de numero impair sont traditionellement des versions de transit.
Je te conseille donc de reprendre ta compil avec un 2.6.8 rappatrié à coup d’apt-get (par exemple, le paquetage kernel-tree-2.6.8, prepackagé debian ), maais si tu n’utilise pas de patch ou de module externe (style nvidia) ce n’est peut etre pas la peine de recompiler…
sinon, la methode debian standard de compil est documentée ici:
qref.sourceforge.net/Debian/refe … el.fr.html

[quote=“Echo”][quote=“MattOTop”]
Quant à la réinstallation… tu viens de Redmond ? :laughing:
[/quote]
euh sorry la j’ai po compris la private jock![/quote]
euh, Redmond, c’est le siège de Microcrotte :wink:


#5

ouais c’est ce que je pensais mais au cas ou je voulais confirmation…
2eme question debile: et si c’est pas le cas?

ah ben merci bien ca va m’etre util ce truc

[quote=“MattOTop”][quote=“Echo”][quote=“MattOTop”]
Quant à la réinstallation… tu viens de Redmond ? :laughing:
[/quote]
euh sorry la j’ai po compris la private jock![/quote]
euh, Redmond, c’est le siège de Microcrotte :wink:[/quote]
mdrrrrrrrr
ben qd ca marche plus moi je reinstalle… ya mieux faire???


#6

[quote=“Echo”][quote=“MattOTop”]
tu as bien compris qu’ils étaient tous les deux génèrés avec le contenu de deux sous répertoires différents ? ben tu regarde dans les deux ss rep, si les fichiers alsa sont similaires, et tu compares modules.conf et modprobe.conf, pour voir si ces deux éléments de config se sont bien reportés aussi.
[/quote]
ouais c’est ce que je pensais mais au cas ou je voulais confirmation…
2eme question debile: et si c’est pas le cas?[/quote]
dans ce cas, tu reporte ce qu’il y a dans le systeme modules.conf. Le systeme modprobe, plus récent, sait utiliser la syntaxe modules, même s’il a une syntaxe beaucoup plus riche (notament pour déclencher des scripts au chargement des modules).

Oui, et tu l’as bien compris… Tu ajustes la config, et tu fais des mises à jour quand tu veux installer une nouvelle version.
A ce propos, je viens de m’apercevoir que tu installais une woody. C’est un peu conservateur comme stratègie. La sarge est en passe de passer ‘stable’. Mais tu peux passer de l’une à l’autre sans réinstaller, si tu as une liaison internet correcte… Ca résoudrait peut etre certains de tes problemes… :slightly_smiling:


#7

[quote=“MattOTop”][quote=“Echo”][quote=“MattOTop”]
tu as bien compris qu’ils étaient tous les deux génèrés avec le contenu de deux sous répertoires différents ? ben tu regarde dans les deux ss rep, si les fichiers alsa sont similaires, et tu compares modules.conf et modprobe.conf, pour voir si ces deux éléments de config se sont bien reportés aussi.
[/quote]
ouais c’est ce que je pensais mais au cas ou je voulais confirmation…
2eme question debile: et si c’est pas le cas?[/quote]
dans ce cas, tu reporte ce qu’il y a dans le systeme modules.conf. Le systeme modprobe, plus récent, sait utiliser la syntaxe modules, même s’il a une syntaxe beaucoup plus riche (notament pour déclencher des scripts au chargement des modules).
[/quote]
pfffffff s’que c’est complique!!!
Debian ca me depasse! :confused:

Oui, et tu l’as bien compris… Tu ajustes la config, et tu fais des mises à jour quand tu veux installer une nouvelle version.
A ce propos, je viens de m’apercevoir que tu installais une woody. C’est un peu conservateur comme stratègie. La sarge est en passe de passer ‘stable’. Mais tu peux passer de l’une à l’autre sans réinstaller, si tu as une liaison internet correcte… Ca résoudrait peut etre certains de tes problemes… :slightly_smiling:[/quote]

Hum mouais ben je crois que je vais attendre la sortie en stable de la sarge alors… Et puis je n’ai pas de connexion internet enfin si mais en ‘unstable’ et elle est pas prete d’etre ‘frozen’</debian joke>
c’est pour bientot j’espere?

En tout cas un grd merci d’avoir pris le temps de repondre a toutes mes questions (plus ou moins debiles oui je sais :unamused: )
Une derniere chose: j’ai recupere la totalite de la doc ou tu m’as conseille de lire la partie sur la compilation de noyau… Mais y aurait il une autre doc succeptible de m’interesser pr l’install de la sarge (ou woody je suppose que C le meme principe de tte facon)


#8

Comme je te l’ai dit, en debian, on ne réinstalle pas: si tu as une woody qui marche et une connection internet, le passage en sarge se fais super simplement: tu modifies ton fichier /etc/apt/souces.list, du dédouble les lignes en mettant testing, la ou c’est stable, et sarge, la ou c’est woody, de manière à taper dans les deux distrib. Puis tu rajoutes un petit fichier /etc/apt/apt.conf.d/00mesoptionsamoi

APT::Default-Release "testing"; APT::Cache-Limit 10000000; // corrige erreur "E: Dynamic MMap ran out of room" .

Une fois fait cet ajustement, tu fais une màj de la liste des paquets dispos :
apt-get update
(si tu vois que certaines sources sont indisponibles, tu les mets en commentaire dans sources.list, jusqu’a ce que ca passe sans erreur)
ensuite, tu fais la migration de distrib: apt-get dist-upgrade
pour maintenir ta distrib à jour (en woody ou en sarge), sinon, c’est apt-get update, suivi de apt-get upgrade…
et hop…


#9

[quote=“MattOTop”]Comme je te l’ai dit, en debian, on ne réinstalle pas: si tu as une woody qui marche …
[/quote]

Ben ouais j’ai juste installe Debian sans rien de cnfigure en fait…
cad j’en suis apres l’ecran “have fun!” si je me trompe pas…

Le truc apres c’est que je n’ai ni alsa, ni de serveur X a cause des pb su cites…
Et ca fait 2 semaines que je bloke la dessus! Ca me saoule j’ai pas envie de repartir sous Mdk!


#10

bon, dis moi,
1/tu n’as pas de connection internet rapide DU TOUT ou bien elle n’est pas configurée ?
2/tu tiens VRAIMENT à rester en woody ?
3/as tu réussi à compiler ou installer le paquetage d’un 2.6 propre en mode debian ?
je te promets: le plus simple pour toi, c’est VRAIMENT de faire le passage en sarge, d’installer un 2.6.8 (avec alsa integré).
Et la liaison internet est quasi imperative pour installer à la volée les paquetages dont tu pourrais avoir besoin en cours de route (les CD, c’est la galere: jamais à jour, et tu ne trouves jamais le bon quand tu cherches un paquet).
Pour info, sinon, je mesuis apercu que si aulieu de concatèner le contenu de modprobe.d dans modprobe.con, on y mettait juste ‘include modprobe.d’ ca marchait tout aussi bien… :slightly_smiling:
sinon, concernant ton serveur X, est ce qu’il plante avec ton noyau de distrib. Si oui, est ce que tu as installé le service apmd ?
as tu essayé, histoire d’avoire dèja une interface graphique, d’installer un serveur XFree générique, style vga16, ou svga, avec ‘dpkg-reconfigure xserver-xfree86’ ?


#11

oulalaaaa que de questions!!!
^^

En fait je réside ds une résidence étudiante qui attendait sa connexion depuis plus de 3 mois… Elle vient juste d’être installée cette semaine, donc le pb est désormais réglé! =)
Néanmoins, le débit reste faible: 20Ko/s max en journée, 70Ko/s après minuit…

Non pas spécialement…
La seule raison qui me poussait à installer ‘woody’ en premier c’est parce que j’avais une doc expliquant l’installation de ‘woody’ puis de l’upgrade vers ‘sid’ et pas de la sarge…
Mais raisonablement, je préfèrerais la ‘sarge’ bien sûr!

oui…
Avec les pbs que tu connais cad pas de démarrage d’ALSA qui ne semble pas reconnaitre la carte son et crash du server X.

Il n’y a que le débit de ma connexion internet qui peut poser problème…
En sachant que seul le port 80 est ouvert, l’admin réseau de Colt France (notre FAI) ayant eu la ‘superbe’ initiative de fermer tous les ports…

Génial! :smiley:

Je te dirai ca quand j’aurai installer la ‘sarge’!
:wink:


#12

on peut peut etre faire un tunnel jusqu’a chez moi par le port 80, et ressortir par mon p{(è-ain de FAI à moi (Wanabouse pour ne pas le citer :laughing:). à voir si je fais ca pour toi… (et si ce n’est pas trop cplx)


#13

J’ai recupere l’iso sarge-i386-netinst ainsi que le guide d’installation debian sarge avec l’intallateur
(je commence a avoir une sacree collec’ de docs moi! :smiley:)

Je tente d’installer ca ce soir si j’ai le temps et je te fais part du deroulement de la chose…


#14

Je viens de finir l’installation de base de debian sarge…
cad que je viens juste de rebooter, mais sous windob.

Pitite question avant de continuer… Si je n’ai que le port 80 d’ouvert…
C’est pas la peine que je continue l’install je suppose?
Les packages doivent etre recuperes sur les miroirs FTP ou HTTP de debian… Bref je doute que ca passe par le port 80… a moins que?


#15

et la, j’avais pas réalisé, mais il n’y a pas besoin de réinstaller pour passer en sarge… d’ailleurs, on ne reinstalle normalement jamais une debian, on la fait évoluer: on est pas chez bill gates…
regardes sur le fil concernant ‘rester en testing’, ou j’eclaire un peu sur l’usage du sources.list (je crois que c’est dans ce fil que j’explique la migration)
sinon, globalement, il suffit juste de modifier ton sources.list pour changer tes sources de woody ou stable en sarge ou testing respectivement partout, et apres, tu fais des ‘apt-get dist-upgrade’ et ‘apt-get upgrade’ simple, jusqu’a ce qu’il n’y ait plus de màj à faire…
contrairement à windowsupdate, même pas besoin de redémarrer et tu passes en sarge direct…


#16

bon, je t’ai envoyé un message perso, mais ca à l’air d’etre plus rapide par le forum…
donc le port http c’est 80, donc tu peux continuer ton installe avec tes sources http, pas de pb…
tiens en voila un de base tout en http:

deb http://debian.mur.at/debian/ testing main contrib non-free
deb http://ftp.fr.debian.org/debian-non-US/ testing/non-US main contrib non-free
deb http://debian.mur.at/debian/ stable main contrib non-free
deb http://ftp.fr.debian.org/debian-non-US/ stable/non-US main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

j’ai laissé aussi les sources stables, pour les paquets qui ont disparu en testing, mais qui sont compatibles (de ttes les manières, il ne prend que la version la plus récente…
allez, je vais me coucher cette fois :slightly_smiling:


#17

Bon et bien voila, je suis enfin sur ce site sous debian!
C’est pas trop tot et merci à la ‘sarge’…
J’aurais su j’aurais installer directement cette version… J’ai gravé les 3 premières isos et l’installation s’est faite en 1H de temps sans doc, le temps de quelques petits tatonements…

Bref ça a été presque trop simple…
Il n’y a que l’installation de KDE qui a foirée… A revoir donc.

Bon ben j’ai plus qu’à recompiler un bo noyau 2.6.8 tou bo tout petit tout neuf (ben ouais le 2.4 fo pas deconner non plus hein…) et je crois que ce sera presque nikel!


#18

une derniere chose, pour etre sur de bien installer kde, installes son login manager (kdm): il dépend de tous les paquets nécessaires à kde 3 (il reste aussi des paquets de l’ancienne version de kde incompatibles mais toujours disponibles, ce qui peut effectivement poser des pb de dépendance).