Résolu - Suppression par erreur de la partition /dev/sda1 sur debian 9

boot
grub
Tags: #<Tag:0x00007f092c6a2048> #<Tag:0x00007f092c6a1e40>

#1

Salut tout le monde

Je galère depuis une semaine car j’ai supprimé par erreur la partition /dev/sda1 de mon SSD
Du coup mon system ne démarre plus et j’ai pour l’instant beaucoup de donnés importantes car je l’utilisé comme PC principal là j’utilise l’ordinateur portable du bouleau

Après plusieurs recherche j’ai cru comprendre que c’est la partition EFI

au debut quand en mode rescue quand je lancais sur le shell la commande fdisk -l j’avais
/dev/sda2
/dev/sda3

et j’avais un espace disque libre d’environ 500 mo

J’ai essayé de recréer cette partition en “EFI” via le mode rescue graphique dispo sur le DVD de l’installation mais cela ne marchais pas, apres coup j’en ai créé une en mode CLI FAT32 avec fdisk

réinstaller le grub sur /dev/sda1 ne marche pas et j’ai une erreur qui dit en gros je n’ai pas selectionné de d’environnement root

on m’a indiqué rEFIne, testdisk, etc etc comme utilitaires mais j’ai regardé dans tout les sens je ne veut pas appliquer betement ca, je n’ai pas vraiment trouvé de réponse claire et je prefere bien analyser la situation avant de tenter quoi que ce soit dabord pour eviter d’empirer la situation mais ensuite parce que c’est une opportunité pour moi d’apprendre donc j’aimerais comprendre ce systeme de partitionnement, ce que j’ai exactement cassé en supprimant cette partition, ce à quoi elle sert, en quel system de ficher elle est, les fichiers qui y sont à ce a quoi ils servent et ce qu’il faut que je fasse pour récupéer l’acces au systeme

on me parle de grub, EFI, gpt, etc etc je suis vraiment largué

merci d’avance pour votre aide!


Installation UEFI GPT sur Acer Aspire ES11 ES1-132-C9UA
#2

salut
Si ton sda1 correspondait à la racine / donc à ce qui contient tous les programmes c’est en effet un sérieux problème et je ne me prononcerai pas sur la possibilité de réparation

pour en savoir plus sur le partitionnement
https://www.debian.org/releases/stable/amd64/apc.html.fr

Voici un exemple d’un cas standard

root@debian:~# fdisk -l
Disque /dev/sda : 298,1 GiB, 320072933376 octets, 625142448 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x00038c4c

Périphérique Amorçage    Début       Fin  Secteurs Taille Id Type
/dev/sda1    *            2048  40011775  40009728  19,1G 83 Linux
/dev/sda2             40011776 625142447 585130672   279G  5 Étendue
/dev/sda5             40013824  55717887  15704064   7,5G 82 partition d'échange Linux / Solaris
/dev/sda6             55719936 625141759 569421824 271,5G 83 Linux


root@debian:~# df -hT
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
udev             devtmpfs   1,8G       0  1,8G   0% /dev
tmpfs            tmpfs      370M     11M  359M   3% /run
/dev/sda1        ext4        19G     13G  5,6G  69% /
tmpfs            tmpfs      1,9G     42M  1,8G   3% /dev/shm
tmpfs            tmpfs      5,0M    4,0K  5,0M   1% /run/lock
tmpfs            tmpfs      1,9G       0  1,9G   0% /sys/fs/cgroup
tmpfs            tmpfs      1,9G    4,0K  1,9G   1% /tmp
/dev/sda6        ext4       268G    223G   31G  88% /home
tmpfs            tmpfs      370M     20K  370M   1% /run/user/1001

#3

D’abord, faire l’état des lieux depuis un système live ou le shell de l’installateur Debian en mode rescue.

  • la sortie de la commande fdisk -l
  • si possible la sortie de la commande efibootmgr -v
  • le contenu du fichier /etc/fstab sur /dev/sda2 ou /dev/sda3

#4

Et sinon, si tu as un support externe capable de stocker tes données utilisateur:

  • tu bootes sur un livecd,
  • tu copies tes data sur ton support externe,
  • pendant ce temps là, tu essayes de comprendre ce que tu as fait sauter juste pour la culture,
  • tu réinstalles,
  • tu rapatries tes données.

#5

Hello Pascal

Voici le output :
fdisk_efibootmgr fstab

merci beaucoup!


#6

mattotop je crois bien que je vais finir par faire ca, en meme temps le fix semble si simple! c’est juste moi qui suis nul :smiley:


#7

dans mon cas je pense que le root est heuresement sur SDA2, sda1 etait bien la partition efi seulement, j’espere pouvoir trouver une solution!


#8

Le fdisk -l indique que ta partition EFI sda1 est en “linux filesystem”, alors qu’elle devrait être en fat32:
il y a bien une couille, il me semble.
Mais je ne peux pas t’en dire plus.
Perso, j’essyerais de reformater sda1 en vfat, et je jouerais avec refind, je crois qu’il permet de reinstaller l’uefi sur la partoche (mais pas sur, j’ai rien compris).


#9

Non, elle devrait être de type “EFI system”. C’est le type de système de fichiers qu’elle contient qui doit être FAT mais cela, fdisk ne l’affiche pas.

En complément, qu’affiche blkid ?

Si l’ancienne partition EFI commençait au même emplacement et si tu n’a pas formaté la nouvelle partition ni effacé les méta-données de l’ancienne (fdisk peut le proposer), le contenu de l’ancienne partition devrait encore être présent. Même dans le cas contraire, cela ne devrait pas être très compliqué de recréer ce contenu.


#10

J’ai trouvé quelques part la meme suggestion que ce disait mattotop et j’ai formaté l’espace dispo au debut du SSD (environ 500 Mo) en FAT32, donc je pense ne plus pouvoir récupérer ce qu’il y’avait sur /dev/sda1
voici la commande blkid :
blkid

Je pense effectivement que la manip pour la réinstaller est facile mais je n’ai pas vraiment trouvé d’explication claire pour l’instant, j’avais tenté plein de chose mais j’ai eu des blocages/erreur qui m’en empechait pour l’instant (réinstallation de grub etc), la seule chose que j’ai pu faire est de formater sda1 en fat32 en CLI car en passant par le formatage en mode graphique il m’etait possible de la formater en mode EFI et de la flag comme bootablemais ca bloque et me demande de choisir un environnement root

merci !


#11

blkid ne détecte pas de système de fichiers FAT (ni d’un autre type connu) dans la partition /dev/sda1, donc tu ne l’as pas formatée mais as simplement indiqué le type FAT32, mais les anciennes données ne sont pas visibles donc

  • soit tu les as effacées lors de la création de la partition (fdisk demande s’il doit le faire, t’en souviens-tu ?) ;

  • soit elles ont été effacées lors de la suppression de la partition, mais je n’ai pas connaissance qu’un des partitionneurs courants de GNU/Linux (fdisk, gdisk, parted) fasse cela ;

  • soit l’ancienne partition ne commençait pas à la même position, ce qui m’étonnerait un peu car le secteur 2048 est la position normale de début de la première partition.

Bref, autant considérer le contenu de l’ancienne partition EFI comme perdu.
Pour commencer, donner à la nouvelle partition le type “EFI”.

fdisk /dev/sda

Taper “t” pour changer le type, sélectionner la partition 1 et le type 1 (EFI).
Tant qu’on y est, on va aussi lui remettre le même GUID (PARTUUID) que l’ancienne, qui figure entre parenthèses aux lignes Windows et Debian de la sortie de efibootmgr -v qu’on voit sur ta capture d’écran.
Toujours dans fdisk, taper “x” pour passer en mode expert et “u” pour changer l’UUID/GUID de partition. Taper l’UUID sous la même forme avec les tirets au même endroit. Une fois fait, taper “w” pour écrire les modifications sur le disque et quitter.

Ensuite, remettre le contenu : Formater la partition avec le même UUID de système de fichiers que la précédente (trouvé dans /etc/fstab), monter la partition EFI, y copier l’exécutable GRUB EFI.

mkdosfs -i 04E9B07A -n "EFI" /dev/sda1
mount -t vfat /dev/sda1 /mnt
mkdir -p /mnt/EFI/BOOT /mnt/EFI/debian
cp /boot/grub/x86_64-efi/core.efi /mnt/EFI/BOOT/BOOTX64.EFI
cp /boot/grub/x86_64-efi/core.efi /mnt/EFI/debian/grubx64.efi
sync
umount /mnt

Avec un peu de chance, cela suffira à rendre le système amorçable à nouveau. Sinon, il faudra en plus recréer l’entrée de boot EFI ou réinstaller GRUB.


#12

Super! merci on avance petit a petit, j’ai maintenance le menu Grub qui apparait mais j’ai cette erreur
IMG_1271

j’ai l’impression qu’il faut editer quelque chose car ca pointe vers “/dev/disk/dev-disk-by/” qui m’a l’aire d’être une entrée par defaut? faut il faire la manip “recréer l’entrée de boot EFI” que tu as suggeré?

je suis passé par le live CD rescue et j’ai tenté de reinstaller GRUB mais cela ne marche pas

Merci


#13

Apparemment le système ne trouve pas l’UUID de la partition EFI pour la monter. Peut-être une erreur dans les options de la commande mkdosfs ? Entre dans le shell de secours proposé et vérifie l’UUID dans la sortie de

blkid /dev/sda1

Il devrait être égal à 04E9-B07A et correspondre à celui inscrit dans /etc/fstab. Si ce n’est pas le cas, il suffit de le corriger dans le fichier /etc/fstab pour qu’il corresponde à celui affiché par blkid (ce que je voulais éviter en le spécifiant lors du formatage par mkdosfs).

Surtout pas ! J’espère que ça n’a rien fait car c’est un coup à ruiner tout ce qu’on a fait… GRUB fonctionnait parfaitement et lançait le système. C’est le système qui a un problème, pas GRUB.


#14

on l’oublie souvent mai si c’ est possible cloner le disque avant de toucher les partitions est casi obligatoire. dans ce cas ça reste aussi valable après.
Avec dd dans la mesure ou tu refais une m… tu peux restituer ton disque tel quel à un instant donner, je dis ça je dit rien


#15

oui j’avais aparement rajouté un zéro de trop dans le UUID, le shell du live DVD est assez compliqué car il bug, pas possible d’uiliser les fleches mais maintenant … ca marche!!!
Merci beaucoup a tout le monde dans ce forum mais surtout merci PascalHambourg
L’admin devrait faire passer Pascal Admin vu le temps qu’il a passé pour m’aider et aider les autres!! (s’il veut bien de cette responsabilité) :wink:
A très bientôt
IMG_0556


#16

Bah, c’était facile. J’ai vu bien pire, pas plus tard que ce week-end en live. Une espèce de netbook-tablettoïde retors, il a fallu s’y mettre à trois pour en venir à bout.

J’ai déjà été promu modérateur du forum automatiquement pendant un temps puis je ne l’ai plus été sans que je sache pourquoi. A vrai dire, ça ne me manque pas.