[RÉSOLU] Toujours mes problèmes d'imprimante


#1

J’ai tt testé et mon imprimante (epson C44) est bien reconnue, la config se passe bien avec le gestionnaire d’impression de KDE (mon bureau) et l’état de l’imprimante est : “disponible (accepte les tâches)”. Tout est bien paramétré avec cupsys et le pilote est celui qui est préconisé pour cette imprimante.
Malgré tt ça, quand je lance “imprimer” à partir d’un TT queconque, rien ne se passe.
J’ai actuellemnt 4 installations de debian différentes pour différents tests.
Sur les deux installs les plus anciennes, l’imprimante fonctionne parfaitement.
Sur les deux plus récentes, que dalle :frowning:
J’ai donc cherché à comparer les versions de cupsys et de son driver : cupsys-driver-gimpprint.
Sur celles qui sont OK, les versions de cupsys sont dépassées : 1.1.20final+rc1-7
Sur celles qui sont KO, les versions sont les plus récentes : 1.1.23-4 (sans le ‘final+rc’)
Il en est de m^ pour le driver : 4.2.7-3 et 4.2.7-5
Question N°1 : Est-ce que l’absence de ‘final+rc1’ peut être une cause de la défaillance ?
Et ds ce cas, comment le charger (quelle commande ?)
Question N°2 : quelle est la commande pour charger un paquet d’une version ancienne ?
Si je fais apt-get install (ou dpkg) cupsys-1.1.20final+rc1-7 j’ai une erreur
Comment donc charger un “version” ?


#2

pour voir la liste des versions dispos dans tes repositories:
apt-cache show cupsys
pour ensuite installer le pkt:
apt-get install cupsys=<n° de version>


#3

Merci Mat, je vais voir ça maintenant que mon histoire de son est résolue.


#4

c’est réglé : ouf !
En fait, je suis resté avec les derniers paquets mais le fait de chercher avec apt-cache show cupsys, m’a permis de vérifier si ttes les dépendances étaient présentes.
Ttes les "obligatoires : oui mais j’ai rajouté les “recommends” qui étaient absentes :
gs-esp et smbclient
et ça a fonctionné :stuck_out_tongue:
Merci pour l’aide, une fois de plus.