[résolu]Une question et un problème (xawtv/zapping)


#1

bonjour,

première question :

J’ai remarqué ça depuis ma Sarge, mais j’ai l’impression que même en utilisant la commande apt-get --purge remove x, où x est le programme à virer, et bien même si on m’indique que les fichiers de configuration sont purgés, si je réinstall dans la foulée le dit programme, très curieusement, je n’aurai pas à reconfigurer ce dernier, car il sera configuré comme avant que je le désinstall.

Autrement dit, j’ai l’impression que même si je vire les fichiers de configurations avec apt, ceux-ci semblent rester. Ce qui me pose problème quand je veux virer un paquet proprement pour reconfigurer celui-ci en repartant de zero, puisque justement, je ne peux jamais repartir de zero.

Ai-je mal compris quelquechose avec apt ?

Bref, comment résoudre ce problème ?

Sinon, avec xawtv, le souci est qu’à la première install, je lui ai dis de partir sur du PAL, alors qu’en fait, je reçois m6 et les autres chaines en SECAM. Bon, je me dis que je vais virer tout ça et recommencer en SECAM. Le problème est que d’une part je n’arrive pas à virer proprement xawtv (et donc son fichier de config) à cause du premier souci dont je vous ai parlé plus haut, et par ailleurs, dans la config, dès que je lui dis de passer en SECAM, non il veut rien savoir, il me remet toujours en PAL.

Bref, quoi faire ? Y-a-t-il un autre utilitaire à prendre ? quand je fais un scantv, si je lui dis de passer en SECAM, il me trouve sans problème M6 et les autres chaines, mais XAWTV lui veut rien savoir.


#2

Pour xawtv, tu dois avoir un fichier .xavtv dans ton répertoire perso. Il suffit de l’effacer ou le modifier.


#3

Rien n’y fait.

PAreil, j’essaye un autre soft : zapping. Ca marche très bien, bon, je vais sur le shell, je tappe un truc, le temps de me rendre compte que je n’étais pas sur le shell mais dans zapping, bref, par inadvertance, j’ai utilisé un raccourci qui m’a planter le programme, résultat : plus d’affichage.

je le relance, même problème, plus d’affichage… je le réinstall…même problème plus d’affichage… j’essaye encore un autre programme, là non plus, pas d’affichage.

J’ypige rien.

Ca choque personne que mes fichiers de config soient toujours là alors que le précise bien le --purge quand je désinstall ?


#4

Bon, j’ai réussis à reproduire le bug avec zapping.

en fait, j’ai réinstallé zapping, mais au lieu de le lancer en utilisateur normal, je l’ai lancé en root, depuis un shell, et là, miracle ça a marché.

j’ai donc bricolé et j’ai vu qu’en lançant l’overlay (je ne sais pas ce que c’est), ça faisait tout planter, du moins l’affichage après était impossible, bien que j’ai eu le son.

Donc voilà ce qui sortait dans le shell pendant l’utilisation de zapping en root :

[code]blackbox:/home/julian# zapping

** (zapping:8736): WARNING **: GConf key ‘/apps/zapping/plugins/deinterlace/method’ is unset and has no default. Schemas incomplete or not installed?

© 2000-2004 Iñaki G. Etxebarria, Michael H. Schimek.
This program is freely redistributable under the terms
of the GNU General Public License.

Using video device ‘/dev/video0’, display ‘:0.0’, screen 0.
Querying frame buffer parameters from X server.
DMA not possible on screen 0.
Setup failed. Try -vv for details.
blackbox:/home/julian#
** (zapping:8813): WARNING **: GConf key ‘/apps/zapping/plugins/deinterlace/method’ is unset and has no default. Schemas incomplete or not installed?

© 2000-2004 Iñaki G. Etxebarria, Michael H. Schimek.
This program is freely redistributable under the terms
of the GNU General Public License.

Using video device ‘/dev/video0’, display ‘:0.0’, screen 0.
Querying frame buffer parameters from X server.
DMA not possible on screen 0.
Setup failed. Try -vv for details.
© 2000-2004 Iñaki G. Etxebarria, Michael H. Schimek.
This program is freely redistributable under the terms
of the GNU General Public License.

Using video device ‘/dev/video0’, display ‘:0.0’, screen 0.
Querying frame buffer parameters from X server.
DMA not possible on screen 0.
Setup failed. Try -vv for details.

blackbox:/home/julian# zapping

** (zapping:8827): WARNING **: GConf key ‘/apps/zapping/plugins/deinterlace/method’ is unset and has no default. Schemas incomplete or not installed?[/code]

Histoire de, je le réinstall et rééssaye de le lancer en root (contrairement à avant ou je le faisais avec un user normal), même problème, toujours ce même message :

blackbox:/home/julian# zapping

** (zapping:11290): WARNING **: GConf key '/apps/zapping/plugins/deinterlace/method' is unset and has no default. Schemas incomplete or not installed?

Je déduis donc de tout ça que chaque utilisateur a un profile de zapping. Vu que lorsque je l’ai fait planter avec l’utilisateur normal et qu’il m’était impossible de le relancer avec cet utilisateur, je pouvais toujours le lancer avec root, jusqu’à ce que biensur je le fasse aussi planter depuis ce dernier.

Donc si c’est bien une histoire de fichier de config par profile, pourquoi quand je fais apt-get --purge remove zapping et que je réinstall pardessus, pourquoi je me retrouve encore avec ces paramètres bugués alors qu’ils sont sensés avoir été effacés ?


#5

Problème à moitié résolu : zapping créé un .zapping qui contient la configuration de ce dernier.

donc j’ai fait un apt-get --purge remove zapping && rm -rf .zapping && apt-get install zapping et ça a marché.

c’est bien, mais ça ne m’explique pas pourquoi les fichiers de configs ne sont pas effacés.


#6

les fichiers UTILISATEURS restent, mais si tu regardes etc, les fichiers de config SYSTEME eux, disparaissent.
Par contre, quand tu réinstalles, il te repropose les options que tu avais sélectionnées pour le systême, mais pas parcequ’il a une copie de la config: uniquement parceque debconf a mêmorisé tes réponse de la fois d’avant.