[Résolu] Virer Windows pour faire de la place - Partitions


#1

Bonjour à toute la communauté,

J’ai installé Debian sur une une installation Windows et j’aimerais la supprimer (Windows, pas Debian!) et récupérer ainsi l’espace disque pour Linux.

Partitions actuelles:

[code]Disk /dev/hda: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 5 40131 6 FAT16
/dev/hda2 6 4746 38082082+ 83 Linux
/dev/hda3 4747 4808 498015 82 Linux swap / Solaris
/dev/hda4 4809 9725 39495802+ f W95 Ext’d (LBA)
/dev/hda5 4809 8632 30716248+ b W95 FAT32
/dev/hda6 8633 9725 8779491 b W95 FAT32[/code]

Comment, ensuite, récupérer l’espace libéré en faveur de GNU/Linux. J’ai un peu peur de faire des bêtises…


#2

tu peux utiliser cfdisk pou supprimer définitivement les partitions windows. Ensuite, il va te falloir créer une (ou des) partitions Linux. Puis, tu peux soit:

  1. Redimentionner tes partitions
  2. En créer de nouvelles

Personellement, je te conseilles vivement la 2° solution si tu es en ext2fs :wink:

il ne te reste plu qu’a créer un (des?) systèmes de fichier sur les partitions fraichement crées. (Attention il faut peut être rebooter après avoir modifier la table de partitions)

mkfs.reiserfs /dev/pouet

par exemple :stuck_out_tongue:

Voili Voilu :stuck_out_tongue:


#3

cfdisk /dev/hdax (x = 4, 5 ou 6) me renvoie

Voici un détail de ce que voit cfdisk:

[code]Partition Table for /dev/hda

           First       Last

Type Sector Sector Offset Length Filesystem Type (ID) Flag


1 Primary 0 80324 63 80325 FAT16 (06) Boot
2 Primary 80325 76244489 0 76164165 Linux (83) None
3 Primary 76244490 77240519 0 996030 Linux swap / So (82) None
4 Primary 77240520 156232124 0 78991605 W95 Ext’d (LBA) (0F) None
5 Logical 77240520 138673079 63 61432560 W95 FAT32 (0B) None
6 Logical 138673080 156232124 63 17559045 W95 FAT32 (0B) None
Logical 156232125 156248189 0 16065 Free Space None
[/code]


#4

il ne faut pas spécifier le numéro de partition malheureux !!

Tu veux pas éditer la table de partitions qui est dans une partition, tu veux éditer la table de partitions de ton disque dur !!!

cfdisk /dev/hda


#5

Ooops. Ca a marché. J’ai effectivement dû rebooter et voici le résultat:

[code] First Last

Type Sector Sector Offset Length Filesystem Type (ID) Flag


1 Primary 0 80324 63 80325 FAT16 (06) Boot
2 Primary 80325 76244489 0 76164165 Linux (83) None
3 Primary 76244490 77240519 0 996030 Linux swap / So (82) None
4 Primary 77240520 156248189 0 79007670 Linux (83) None
[/code]

Merci. Mais maintenant, je suppose que je dois faire un mount dans fstab? Correct?


#6

Il faut créer un système de fichieravant …

genre mkfs.ext3 /dev/hdaX …

puis tu crée un point de montage, et tu monte :slightly_smiling:


#7

Super, ça a marché. Me voilà sans Windows, 100% Linux. Plus de retour en arrière maintenant!

Merci ed. Je n’avais jamais osé toucher aux partitions de peur de faire une con… heu, bêtise!

Ce fut mon premier fil sur ce forum. J’y reviendrai :wink:


#8

Bravo :slightly_smiling:


#9

Ooops. Ca a marché. J’ai effectivement dû rebooter et voici le résultat:

[code] First Last

Type Sector Sector Offset Length Filesystem Type (ID) Flag


1 Primary 0 80324 63 80325 FAT16 (06) Boot
2 Primary 80325 76244489 0 76164165 Linux (83) None
3 Primary 76244490 77240519 0 996030 Linux swap / So (82) None
4 Primary 77240520 156248189 0 79007670 Linux (83) None
[/code]

Merci. Mais maintenant, je suppose que je dois faire un mount dans fstab? Correct?[/quote]
Un petit tuyau: si tu avais lancé

partprobe /dev/hda après la création de tes partitions tu n’aurais pas eu besoin de rebooter… :wink:


#10

intéressant, je ne conaissais pas!


#11

[quote=“jabba”]Un petit tuyau: si tu avais lancé

Je n’ai pas trouvé partprobe sur ma distro (Sarge) et un apt-cache ne me renvoie rien!

Dommage car j’ai une manip similaire à faire sur une autre machine que je souhaiterais ne pas rebooter.


#12

Il te faut installer le paquet libparted1.6-13


#13

J’aurais dû chercher un peu plus!

Trouvé, merci!