[Resolu][WiFi]Automatiser la connexion au boot (essid...)


#1

EDIT : le titre ne désigne pas très bien sa résolution du pb… Disons que le souci venait du module eth1394, chargé de manière intempestive au boot.

Je viens de passer ma Debian de testing en unstable, ce qui a pété le WiFi en passant :neutral_face:
Après plusieurs recherches, j’ai reussi à le ramener à la raison.
J’ai d’abord retiré des morceaux de /etc/network/interfaces:[code]# The secondary network interface (WAN)
#auto eth1
#iface eth1 inet dhcp

wireless_essid LeMienAMoi

wireless_mode managed

wireless_channel 5[/code]Car ça sert plus à rien ?? :open_mouth:

Maintenant je dois faire les commandes:iwconfig eth1 essid LeMienAMoi dhclient eth1Pour récupérer le WiFi.
Ca a l’air de bien marcher… mais je serais pas contre l’automatiser :unamused:.
Y’a moyen? J’ai essayé de mettre divers trucs dans /etc/network/interfaces , mais dans ce cas il me crée une eth2 surprise au boot et m’envoie péter :confused:


#2

slt,

Oui, tu peut l’automatiser mais seulement ce que tu entre a la main, tu peut l’enter directement dans le fichier “/etc/networks/interfaces/” quelque chose comme ça :

[code]

The secondary network interface (WAN)

auto eth1
iface eth1 inet dhcp
wireless_essid LeMienAMoi
wireless_mode managed
wireless_channel 5[/code]


#3

En fait les directives à employer ont légèrement changé de nom. Jette un oeil à

man wireless

#4

[quote=“stonfi”]slt,

Oui, tu peut l’automatiser mais seulement ce que tu entre a la main, tu peut l’enter directement dans le fichier “/etc/networks/interfaces/” quelque chose comme ça :

[code]

The secondary network interface (WAN)

auto eth1
iface eth1 inet dhcp
wireless_essid LeMienAMoi
wireless_mode managed
wireless_channel 5[/code][/quote]Merci mais c’est justement ce que j’avais commenté car ca ne marchait pas

[quote=“BobX”]En fait les directives à employer ont légèrement changé de nom. Jette un oeil à

man wireless [/quote]Merci pour l’info. J’ai cru noter que les noms prenaient des “-” (tirets) au lieu de “_” (underscore). J’ai donc fait mon fichier comme ça:

# The secondary network interface (WAN) iface eth1 inet dhcp wireless-essid LeMienAMoi wireless-mode managedMais ça se connecte pas au boot :blush:.
On dirait que le systeme “oublie” d’exécuter dhclient pour les interfaces WAN (ca marche sans souci pour les LAN).
Je n’ai vu aucune ligne lors du boot qui indiquait qu’il essayait de lancer eth1. C’est possible/normal ça :question:


#5

Si tu n’as pas précisé “auto eth1” dans ton fichier interfaces, oui c’est normal :wink:


#6

En fait, lorsque je mets le “auto eth1”, j’ai des messages d’erreur:

[code]# /etc/init.d/networking restart

  • /etc/network/options is deprecated.
    Setting up IP spoofing protection…done (rp_filter).
    Reconfiguring network interfaces…ifup: interface lo already configured
    Internet Software Consortium DHCP Client 2.0pl5
    Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
    All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

sit0: unknown hardware address type 776
eth1: unknown hardware address type 24
sit0: unknown hardware address type 776
eth1: unknown hardware address type 24
Listening on LPF/eth0/00:00:39:41:17:89
Sending on LPF/eth0/00:00:39:41:17:89
Sending on Socket/fallback/fallback-net
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPNAK from 192.168.1.1
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPOFFER from 192.168.1.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.105 – renewal in 43200 seconds.
Error for wireless request “Set Mode” (8B06) :
SET failed on device eth1 ; Operation not supported.
Error for wireless request “Set ESSID” (8B1A) :
SET failed on device eth1 ; Operation not supported.
Internet Software Consortium DHCP Client 2.0pl5
Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

sit0: unknown hardware address type 776
eth1: unknown hardware address type 24
sit0: unknown hardware address type 776
eth1: unknown hardware address type 24
Listening on LPF/eth1/
Sending on LPF/eth1/
Sending on Socket/fallback/fallback-net
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database.

Exiting.

Failed to bring up eth1.
done.
#[/code]Y’a ce message:
Error for wireless request “Set Mode” (8B06) :
SET failed on device eth1 ; Operation not supported.
Error for wireless request “Set ESSID” (8B1A) :
SET failed on device eth1 ; Operation not supported.

au milieu. Pas terrible :confused:… et il termine sur “Failed to bring up eth1.” Pourquoi, monde cruel ?? :cry: (à 4h du mat, je craque un peu :laughing:)


#7

Tu utilise quel driver pout ta carte wifi ? linux-wlan-ng ?

Si oui, c’est tout a fais normal, tu peux pas modifier via iwconfig comme le fais le script qui interprete interfaces. Il faut le faire via les fichiers de configuration fournis avec linux-wlan-ng dans /etc/wlan


#8

C’ est une carte Intel Pro Wireless 2200, j’ utilise le driver ipw2200 :# lsmod | grep ipw2200 ipw2200 96236 0 ieee80211 29064 1 ipw2200 firmware_class 9696 2 pcmcia,ipw2200Je n’ ai pas de repertoire /etc/wlan .

J’ ai +/- avancé entre-temps : j’ ai installé network-manager-gnome. Ca me propose une petite applet qui me permet d’avoir le WiFi juste avec 2 clics. C’est mieux.

Mais c’ est toujours pas automatisé :cry:


#9

J’ai trouvé! :smiley:
En fait c’était un souci de conflit avec le Firewire (ieee1394), qui sert aussi d’interface réseau ou qqchose dans le genre. C’est ce qui faisait que j’avais une interface supplementaire +/- “fantome” qui se baptisait eth1 ou eth2 selon l’humeur, mais toujours pour emmerder le WiFi.
J’ai donc désactivé le module eth1394 au boot. Et ca roule! :astonished:

(Pour le désactiver, J’ai ajouté la ligneblacklist eth1394dans /etc/modprobe.d/blacklist )