Rétablir la réception automatique des fichiers téléchargés dans le dossier "Téléchargements"

mate
Tags: #<Tag:0x00007fa930e76fb8>

#1

Bonjour, sur une machine Debian9-Mate normalement les fichiers téléchargés étaent dirigés automatiquement dans un dossier nommé “Téléchargements” placé dans mon home, je voudrait rétablir cette fonctionnalité perdue après une fausse manœuvre qui a abouti à déplacer le dossier “Téléchargements” dans un sous-dossier. J’ai retrouvé ce dossier “Téléchargements” et je l’ai replacé dans mon home. Mais il y a un problème que je ne sais pas résoudre! En voici les manifestations:
(1) Avant cet incident l’icône du dossier Téléchargements avait un marquage similaire à celui du dossier “Documents”. Ce n’est plus le cas!
(2) Les documents fraîchement téléchargés n’arrivent plus dans le dossiers “Téléchargements”, mais directement dans mon home ce qui est gênant!
Je ne vois comment rétablir le bon fonctionnement!
Merci pour votre aide éventuelle!


#2

Bonjour Jet

Je n’ai pas de debian avec l’environnement de bureau Mate sous la main pour pouvoir vérifier,
mais ça devrait sans doute être la même chose qu’avec l’environnement Xfce

Depuis le compte utilisateur concerné,
lance la ligne de commande suivante :

xdg-user-dirs-update --set DOWNLOAD "$HOME/Téléchargements"

Ensuite, déconnecte toi de ta session
et ouvre une nouvelle session qui prendra alors compte de la modification effectuée.


#3

Salut
Il devrait y avoir un fichier .config/user-dirs.dirs dans le /home de l’utilisateur.
avec le contenu suivant
cat ~/.config/user-dirs.dirs

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
# 
XDG_DESKTOP_DIR="$HOME/Bureau"
XDG_DOWNLOAD_DIR="$HOME/Téléchargements"
XDG_TEMPLATES_DIR="$HOME/Modèles"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Musique"
XDG_PICTURES_DIR="$HOME/Images"
XDG_VIDEOS_DIR="$HOME/Vidéos"

#4

La ligne de commande que je propose dans mon précédent message
fera en sorte que la ligne commençant par :

XDG_DOWNLOAD_DIR=

dans le fichier

~/.config/user-dirs.dirs

sera remplacée par une ligne contenant :

XDG_DOWNLOAD_DIR="$HOME/Téléchargements"

#5

quel navigateur utilises tu pour télécharger?


#6

Merci pour vos réponses, dès que possible je testerai et vous enverrai le retour de manip.
Navigateur: J’utilise Firefox, mais cette rupture d’envoi sur “Téléchargement” concerne aussi DownloadHelpe.
Plus généralement le problème affecte d’autre téléchargements: banque, DÉBIAN DOWNLOAD, ETC…


#7

Bonjour MicP,
(1) j’ai utilisé ta ligne de commande en tant que root ===> aucune amélioration, hélas!Devais-je le faire en tant qu’utilisateur?
(2) De plus, j’ai cherché: .config/user-dirs.dirs dans le /home de l’utilisateur. en vain!
Problème non résolu!


#8

Est-ce que le compte utilisateur concerné était le compte utilisateur root ?
Si oui, alors la ligne de commande aura bien modifié le fichier ~/.config/user-dirs.dirs du compte utilisateur root
Si non, alors lance la ligne de commande depuis le compte utilisateur concerné,
et, depuis ce compte utilisateur,
le fichier ~/.config/user-dirs.dirs aura été modifié en conséquence.

Désolé, mais depuis ton premier message de ce fil,
quand tu écris :

on ne peut absolument pas savoir de quel compte utilisateur il s’agit
ni deviner quel est le répertoire personnel de ce compte utilisateur.


#9

dans preferences de firefox option téléchargements choisir ton dossier.


#10

J’ai depuis, créé une machine virtuelle en utilisant un fichier image ISO netinst de debian 9.4 et en installant un nouveau système debian utilisant l’environnement de Bureau Mate
Ce qui m’a permis de vérifier que la ligne de commande que je proposais fonctionne aussi bien sur Xfce que sur Mate


#11

Je confirme, idem pour downloadhelper


#12

Merci à tous! Je viens d’utiliser vos conseils en me concentrant un peu plus et tout marche bien à nouveau! Tout ce que vous m’avez indiqué est confirmé dans mon système!
Cette communauté autour de Debian est vraiment très réactive, c’est très important pour l’ensemble des utilisateurs, bravo! Je sais que je peux compter sur vous, pardonnez moi mes imperfection de style. Oui, pour ne pas être trop lourd j’ai été un peu trop elliptique avec “mon home”, mais vu le contexte je pensais que je pouvais sous entendre le home utilisateur que j’utilise le plus…Dorénavant je serais plus rigoureux et donc plus explicite, encore MERCI!


#13

Donc problème résolu!