Retour d’expérience d’un dual boot debian W10 en RAID ON ?


#21

Le disque D contient un espace de 109.05 déclaré “unallocated” par W. Je n’ai pas encore repris l’installation en choisissant "le plus grand espace libre car il y a encore des choix/termes qui me pertubent dans les différentes pages (LVM ou même encore RAID !).

Vous ne confirmez que cette façon de procéder (espace libre sur D) permet de bypasser complètement le passage RAID vers AHCI ?

Bien cordialement
gerod


#22

Oui, je confirme sans certitude absolue mais je trouve cela dommage
comme Pascal qui expliquait que le SSD était plus rapide :

Cette manipulation pour avoir AHCI dans le BIOS ne devrait pas t’effrayer.
C’est juste à noter à l’avance et à faire tranquillement.


#23

Pas besoin de ça. Partitions standard.
Le RAID, c’est pour faire du RAID avec plusieurs disques. Pas le cas ici.
LVM, c’est pour quand on sait ce que c’est et comment l’utiliser.

Ça devrait. Debian ne pourra pas détecter Windows et il faudra s’occuper du multiboot manuellement après l’installation.


#24

Bonsoir,
Je viens de terminer l’installation de debian 10 sur un espace libre de D. Tout s’est bien passé mais à la fin il y a eu le message sur grub : Installer le programme GRUB sur le secteur d’amorcages en précisant que d’autres systèmes n’avaient pas été détectés (et pour cause C n’est pas vu) et que si il y en avait un il pourrait ne pas pouvoir être lancé. Il m’a été proposé d’installer GRUB ailleurs (autre disque, clé) et je n’ai pas su faire.

Je suis alors revenu à W et compte sur vous pour éventuellement tout recommencer avec vos instructions.
Bien cordialement
gerod


#25

Cela signifie que l’installation se fait en mode BIOS/legacy. Or tu avais écrit que l’amorçage était de type UEFI. En es-tu sûr ? Il faut installer Debian et Windows avec le même mode d’amorçage, sinon le multiboot via GRUB ne fonctionnera pas et devra se faire via les options de démarrage du firmware.


#26

Bonjour,
En haut de la page de boot il est écrit :
Boot mode is set to : UEFI with Legacy OPROM; Secure boot : off
Normalement tous les ordinateurs récents (il s’agit d’un Dell de 2017) sont en UEFI. Le fait que linux ne voit pas C est il la cause de cette méprise ?

Quoi qu’il en soit l’installation a été jusqu’au bout au grub près. Peut on installer grub après coup ou faut il recommencer (ce qui ne serait pas un problème) et faire cette installation sur le disque D comme proposé, ce que j’aurai du faire mais ai mal réagi en croyant que le nom du disque proposé était celui de C (ce qui était stupide car je savais bien que C n’était pas vu).

Merci beaucoup pour votre réactivité.
Bien cordialement
gerod

PS je réserve pour plus tard le passage en AHCI (une chose à la fois est suffisant dans ce domaine qui pour moi s’apparente à des sables mouvants)


#27

Oui.

Ca peut être plus simple, en court circuitant le déroulé de l’install pour ne pas reformatter, etc:
je crois que c’est en faisant “revenir en arrière” que tu passes en déroulé manuel de l’install, et ça te permettra d’aller direct à l’étape grub.
Sinon, il y a accés à une console lors de l’install avec alt+f2, mais je ne sais plus quelles instructions exacte il faut à cet endroit là pour installer le grub à la main, je laisse ça à @PascalHambourg .


#28

Mais beaucoup sont encore capables de booter en mode BIOS/legacy avec un support compatible.

Dans Windows, lance le gestionnaire de disques et regarde si le type de table de partition du SSD est GPT et s’il contient une partition système EFI et une partition réservée Microsoft (MSR), toutes deux inférieures à 1 Go. Dans ce cas Windows démarre en mode EFI et il faut installer Debian en mode EFI aussi, donc démarrer l’installation en mode EFI. Si la table de partition du SSD est de type DOS/MBR et qu’il ne contient pas de partition système EFI ni de partition MSR, alors Windows démarre en mode BIOS/legacy et il faut installer Debian en mode BIOS, donc démarrer l’installation en mode BIOS.

Avec quoi fais-tu l’installation ? Quel support (clé USB, CD/DVD…), préparé comment, avec quelle image ISO, quel programme ?
Comment démarres-tu l’installateur ? En laissant l’ordinateur démarrer tout seul ou en forçant un choix particulier dans un menu de démarrage ?
L’écran du menu de démarrage de l’installateur Debian est différent selon qu’on le démarre en mode BIOS ou EFI. En mode EFI, c’est inscrit explicitement et il s’agit de GRUB. En mode BIOS, il s’agit d’ISOLinux (présence d’un menu help).

Non, aucun rapport a priori.

Je ne pense pas que la méthode évoquée par @mattotop soit possible. L’installateur ne devrait pas accepter d’exécuter l’étape d’installation de GRUB sans avoir réalisé les étapes précédentes.


#29

Bonjour,
La copie d’écran jointe donne les images disques vues par W. Sur D les partitions de 27.94 GB et 81.11 GB correspondent à l’installation d’hier de / et /home.

J’ai téléchargé l’image iso (Debian-10.0.0-amd64-DVD-1.iso) sur le site officiel et ai vérifié les MD5 et SH256 avec win32diskimager. C’est avec ce même logiciel que j’ai copié l’image iso sur une clé USB.

J’ai démarré l’installateur en forcant le boot sur la clé dans le menu de démarrage. Ensuite c’est le mode UEFI qui a été retenu.

Ces informations sont ells suffisantes ?
Bien cordialement et merci encore
gerod

disc_management_alw_gerod


#30

Bonjour,

Votre descriptif n’est pas facile à comprendre et les multiples réponses reçues ne m’aident pas vraiment a y voir plus clair.

Chez Dell ils activent le RAID dans le bios de tous leurs PC même si il n’y a qu’un disque dur d’installé sur leurs machines et qu’il ne l’exploite pas dans les faits.

Si c’est bien le cas pour vous, il vous faut changer dans votre Bios le réglage de RAID à AHCI, puis vous devez impérativement redémarrer WIndows en mode sans échec. Après changement complet de Windows en mode sans échec, redémarrer à nouveau votre Windows normalement et le tour sera joué, Windows démarrera alors avec succès en mode AHCI.

Après cela je en vous garanti pas que Linux verra votre disque mais cela devrait être le cas si vous utilisez un contrôleur standard de type Intel.


#31

On ne voit le type de table de partition des disques sur cette image, je crois qu’il faut afficher les propriétés du disque. On voit quand même que le SSD a une partition système EFI de 100 Mo, donc Windows devrait démarrer en mode EFI.

Pas de partition de swap ? Tu avais utilisé le partitionnement assisté ou manuel ?

Donc le résultat devrait être amorçable en mode EFI 64 bits et en mode BIOS/legacy.

Maintenant ou lors de la tentative d’installation interrompue ? Dans le second cas, c’est surprenant que l’installateur ait voulu installer GRUB pour l’amorçage BIOS. A un moment de l’installation EFI, si l’installeur détecte un autre système avec un amorçage BIOS il peut demander s’il faut continuer en mode EFI ou revenir en mode BIOS. As-tu vu cet écran et si oui, qu’as-tu choisi ?


#32

La copie d’écran des propriétés contient plus d’informations.

Dans le cas de la première tentative interrompue je suis sortie proprement (du moins j’espère) de l’installateur en cochant “interrompre l’installation” ou une phrase du même genre.

Lors de la deuxième tentative (qui a été jusqu’aux questions sur GRUB) j’ai souvenir d’avoir demandé de continuer en mode UEFI.

La remarque de phil995511 me laisse à penser que je ne vais pas échapper au passage AHCI !

Bien cordialement
gerod

ps : il y a quelques semaines cet ordinateur a été envoyé chez Dell pour des problèmes de fréquences anormales et je leur avais demandé de faire la reinstallation en mode AHCI, requête dont il n’ont pas tenu compte.

proprietes_C_alw_gerod%20(2)


#33

Proprement ou pas, peu importe, l’installation ne peut pas être reprise.

Mais non. Ceci dit d’après ses indications cela ne semble pas compliqué, donc pourquoi pas.

On voit bien que le SSD est en GPT. Et le disque dur ? S’il est en GPT aussi, tu peux refaire une installation en restant en mode EFI jusqu’au bout. Il faudra créer une partition EFI sur le disque. Si tu utilises le partitionnement assisté dans le plus grand espace libre, il faudra supprimer les deux partitions Linux avant.


#34

Voici les propriétés du disque D en PJ.

Je ne comprend pas la remarque “Proprement ou pas, peu importe, l’installation ne peut pas être reprise.”

Je n’avais pas mis de swap car avec 32 GB en RAM il ne devrait pas y en avoir besoin. D’ailleurs j’ai remarqué qu’en partitionnement assisté ((1er essai) la partition swap avait été mise à environ à 30 GB par l’installateur ce qui me paraît vraiment excessif.

Bien cordialement

gerodproprietes_D_alw_gerod%20(2)


#35

C’est normal, ils ne font pas des réinstallations, cela leur prendrait trop de temps pour chacune des machines sur les quelles ils bossent… Ils ne font que reposer une image disque “officielle” by Dell qu’un de leur architecte de station de travail/laptop a mis au point pour le PC concerné.

Et oui je vous conseille vivement de passer en mode AHCI car selon le gestionnaire de disque de Windows vous n’utilisez pas de disques en RAID. Si vous avez un ssd il fonctionnera un peu plus vite en AHCI et cela peut résoudre votre soucis de non visibilité de vos disques depuis l’installateur de Mint 19.2. Accessoirement veillez bien à ce que l’UEFI soit désactivé dans le bios de votre PC.


#36

Je pense donc que je vais essayer ce passage RAID - AHCI avec la méthode CTSI décrite dans le lien de r2mi. Je suppose que cette methode est équivalente, dans son résultat tout au moins, à celle proposée par PCAstuces qui consiste à modifier les valeurs DWORD de clés du registre storahci.

Le remplacement des drivers, notamment de intelRapidStorage, peut il être source de problèmes potentiels dans le cas d’une machine Dell fortement contrôlée par des logiciels internes du type SupportAssist.

Bien cordialement
gerod

PS mes hésitations viennent d’une part de mon incompétence dans le système et d’autre part de ce que depuis 2.5 annéees je n’ai pas arrêté d’avoir des problèmes avec cette machine (3 changements de carte mère ce qui est un record).


#37

Une installation interrompue doit être recommencée depuis le début. On ne peut pas la reprendre et la terminer. C’est clair ?

Le disque dur est aussi en GPT, bien, c’est mieux pour l’amorçage EFI.

Refais une installation complète en t’assurant qu’elle est en mode EFI. Si tu utilises le partitionnement manuel, crée une partition système EFI. Ensuite, quand Debian sera installé et démarrera, on avisera pour le multiboot. En attendant, tu pourras démarrer Windows via le menu de boot UEFI. Pour le moment il n’y a pas d’urgence à basculer en AHCI.

Donc tu as utilisé le partitionnement manuel, ça répond indirectement à ma question.
Note bien qu’un swap est nécessaire pour utiliser l’hibernation (suspend to disk).

Cela empêcherait à coup sûr Windows de démarrer. Pas sûr que ce soit l’objectif.


#38

Toujours cette question du vocabulaire : le libellé de l’instruction de la liste déroulante de l’installateur était “abandonner l’installation” et non pas “interrompre”. Dans mon deuxième essai j’ai évidemment tout repris depuis le début.

Désolé si je suis un perplexe : pH me conseille l’installation en mode (U)EFI et phil99551 de désactiver l’UEFI du BIOS du PC.

Dans la page boot j’ai le champ : Change Boot Mode Setting proposant le choix entre

  • Legacy Boot Mode, Secure Boot Off
  • UEFI Boot Mode, Secure Boot On

Concernant le partitionnement manuel je n’ai pas souvenir d’avoir vu le choix pour une partition système EFI (de quelle taille ? 1 MB ?). J’avais crée une partition / de 30 GB et une partition /home du reste disponible les deux étant du type ext4. Je pourrais rajouter une swap de 4 GB.

Que faire lors de la demande d’installation de GRUB ? Je suppose qu’il faut choisir le disque D (le seul visible avec la clé d’installation) sur lequel il y a la partition avec debian et surtout la partition efi.

Ensuite pour redemarrer W je me remets dans les conditions initiales “UEFI with Legacy OPROM. Secure Boot : off”.

Je suppose que la procédure sera la même après le passage AHCI.

Bien cordialement et merci de votre patience
gerod

PS J’ai vérifié que je pouvais redémarrer W10 depuis le disque externe sur lequel j’avais cloné le disque C. Tout est à l’identique sauf la vitesse bien évidemment.


#39

“Abandonner”, c’est encore plus explicite dans le sens qu’il n’est pas possible de reprendre l’installation.

Que ce soit bien clair : Windows est installé pour démarrer en mode EFI et ne démarrera pas en mode BIOS/legacy. Si tu désactives l’amorçage EFI natif, plus de Windows. Ou alors tu trouves une méthode pour convertir l’amorçage de Windows (que je ne connais pas, e tà mon avis ça n’existe pas), ou tu réinstalles Windows en mode BIOS/legacy.

Quelle est la configuration actuelle ? Si tu pouvais configurer “UEFI boot mode + secure boot off”, ce serait l’idéal même si Buster est compatible avec le secure boot.

Partition système EFI 100 Mo.
Le reste à ta convenance.
L’installation de GRUB ne devrait poser aucune question, et surtout pas l’emplacement d’installation. GRUB EFI s’installe dans la partition système EFI, c’est fait pour ça.


#40

J’ai un Dell XPS 9570 en dual boot sous Win 10 et Mint 19.2. UEFI acrivé ou pas mes 2 OS démarrent parfaitement.

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/disabling-secure-boot

Mint 19.x ou Debian 10 supportent officiellement les installations en mode UEFI, personnellement je suis de la vieille école, je désactive le secure boot.