Retrait de clef USB


#1

Salut,

j’ai un souci avec ma clef USB:
chaque fois que je tape:

je reçois le message:

Idem quand j’essaie de démonter une disquette

[quote][tequila:/media/floppy]$ umount /dev/fd0
umount: /media/floppy0: device is busy
umount: /media/floppy0: device is busy
[tequila:/media/floppy]$ umount /media/floppy
umount: /media/floppy0: device is busy
umount: /media/floppy0: device is busy[/quote]

Une solution ?

Merci


#2

Mon pauvre ami, :frowning: tu es en train de scier la branche sur laquelle tu es assis… :unamused:

Tu ne peux pas démonter un volume … en étant positionné dedans !
Par contre scier la branche ça marche … :laughing:

Donc:

cd /n’importe-ou-ailleurs-que-dans-ton-floppy
umount …

Ceci dit, surtout sous l’interface graphique, même en n’étant plus dans le répertoire du point de montage, il arrive que des processes bloquent le point de montage et empêchent le umount. Dans ce cas, on peut toujours essayer de lancer umount -f ou chercher le processe coupable avec:
fuser /point-de-montage
Ca retourne normalement le processe qui occupe /point-de-montage
Ensuite kill -TERM le N° du processe ou kill -9 s’il insiste…


#3

LOL
Bien vu Jabba 8)


#4

+1 pour tt ce que dit Jabba.
autre source pour trouver ce qui coince :
lsof | grep cleusb (cleusb étant le répertoire)
tu verras que c’est souvent
fam
qui merde
Réparation par le vide et plus d’em…
Virer fam
Maintenant, il y a uatre chose que je suis entrain de tester mais je n’ai pas encore cerné la configuration :
au lieu de mettre ds le fstab
/dev/sda1
essaie avec
/dev/uba1 (a1 étant bien sûr à modifier selon ta config)
Ça fonctionne avec les noyaux > 2.6.8, il me semble.
Par contre, il faut que ce soit allié à une configuration qui devrait se trouver ds la section "Drivers / ATA-ATAPI-MFM …"
J’ai réussi ds ma “test” mais je ne me souviens plus exactement ce que j’ai modifié :frowning:
Avec de /uba1, montage automatique de la clé à l’enclanchement.
Je n’ai pas trouvé le démontage auto.
Si tu es sous KDE, il y a un petit truc pratique pour ceux (comme moi) qui préfèrent le “graphique” :
KDiskfree
tu montes et tu démontes avec la souris en 2 secondes.


#5

[quote]essaie avec
/dev/uba1 (a1 étant bien sûr à modifier selon ta config) [/quote]
Ah ?
Il tombe de où ce nouveau device ?
Des options spéciales à activer dans le kernel ?


#6

Je ne me souviens plus où je l’ai vu mais le fait est que ça fonctionne :wink:
J’ai presque terminé mon examen approfondi de la configuration et je t’en dirai plus ds qq tps.
pour l’instant, j’essaie de me faire un noyau au minimum et je passe tt au crible.
Malheureusement, je n’ai pas tout marqué ds mes changements mais je sais à peu près où ça se passe.
Mes essais sont sur un 2.6.10 au départ mais j’ai modifié beaucoup de points.

PS : voici mon fstab : [code]# /etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda2 /home ext3 defaults 0 2
/dev/hda3 none swap sw 0 0
/dev/hdb /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

/dev/sda1 /media/cleusb auto rw,user,noauto 0 0

/dev/uba1 /media/cleusb auto rw,user,noauto 0 0

/dev/sda1 /media/sandisk auto rw,user,noauto 0 0
[/code]

tu y remarqueras l’ancien cleusb (commenté)
et le nouveau qui se monte automatiquement à l’enclanchement de la clé.

PS 2 :
le lecteur de smatmedia (sandisk), lui, fonctionne seulement sur sda1 et n’est pas monté auto.
Il faudra que je fasse l’essai en le plaçant sur un uba2 :laughing: