Samba et une imprimante


#1

J’ai 1 pb de printer.
J’ai ajouté une imprimante sur des postes client , nikel reconnu sous le nom de \RJCSERVEUR\Printer mais qd je veux imprimer depuis un poste client cela ne marche pas, rien ne se passe.
L’imprimante fonctionne bien sur le serveur.

Voici mon fichier de config:

[global]

#nom du domaine
workgroup = NETWORKRJC

#nom de la machine
netbios name = RJCSERVEUR
server string = Serveur %v

#crypter mot de passe
encrypt passwords = yes

#sécurité
security = user
guest ok = no
hosts allow = 192.168.0. 192.168.1. 127.

#synchro mdp + modif mdp depuis win
unix password sync = yes
smb passwd file = /etc/samba/smbpasswd
passwd program = /usr/bin/passwd %u
passwd chat = New %n\n Re %n\n pa

#table conversion nom linux win

username map = /etc/samba/smbusers
log file = /var/log/samba/log.%U
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

#chemin profil

logon path = \%L\profiles%U
logon script = logon.cmd

#repertoire perso utilisateur

logon drive = M:
logon home = \RJCSERVEUR%U

#controleur domaine principal

domain master = yes
local master = yes
preferred master = yes
domain logons = yes
os level = 64
domain admin group = @adm root aur
admin users = @adm root aur
dns proxy = no

#imprimantes

printcap name = cups
printing = cups
printer admin = @adm root

[netlogon]
path = /home/nelogon/%U
writeable = no
browsable = no
write list = @adm root
guest ok = no

[profiles]
path = /home/export/profile
browseable = no
writeable = yes
create mask = 0700
directory mask = 0700

[homes]
comment = Repertoire Personnel
browseable = no
writeable = yes
read only = no

[Internet]
comment = Internet
valid users = @adm,@users
write list = @adm,@users
browsable = yes
path = /internet

[Ftp]
comment = FTP
valid users = @adm,@users
write list = @adm,@users
browsable = yes
path = /ftp

[Printers]
comment = HP RJCSERVEUR
browseable = no
path = /tmp
printable = yes
public = no
create mask = 0700
guest ok = no
valid users = @users,@adm,root

[Print$]
comment = Printer drivers
path = /var/lib/samba/printers
read only = yes
guest ok = no
write list = @adm,root

Merci


#2

moi aussi j’ai ce probleme :unamused:

voila le mien de fichier conf (enfin une partie)

[code][global]
workgroup = MSHOME
printcap name = cups
log file = /var/log/samba/log.%m
max log size = 50
netbios name = DEBIAN
server string = Samba Debian BoOmSlAnGz
interfaces = eth0
security = SHARE
guest account = smbguest
printer admin = root
hosts allow = 10.0.0.
printing = cups

[printers]
comment = All Printers
path = /var/spool/cups
browseable = no
# to allow user ‘guest account’ to print.
guest ok = yes
writable = no
printable = yes
create mode = 0700

[HP 845c]
path = /tmp
guest ok = Yes
printable = Yes

[print$]
path = /var/lib/samba/printers
browseable = yes
write list = @adm root
guest ok = yes
inherit permissions = yes
[/code]


#3

2 petites remarques:
1/avez vous essayé sans “printcap name =” “printing =”, juste en laissant les options par défaut MEME AVEC CUPS ? pour moi ca marche sans probleme, avec cups, il publie automatiquement les nouvelles imprimantes que j’installe sans autre forme de configuration.

2/vous utilisez root comme administrateur de samba ou des imprimantes . C’est dangereux, il vaut mieux créer des users spécifiquement pour ca, et garder le root pour l’admin du serveur sur le serveur lui même. il vaut même mieux mettre un ‘invalid users = root’ pour verrouiller. Ca évite de faire circuler des infos d’autentification de votre su par un réseau windows bien connu pour sa sécurité…

petite remarque pour BoOmSlAnGz: j’ai vu que tu utilisait un réseau de classe A pour ton adressage (10.0.0. ). Si tu n’as pas spécifiquement besoin de 2^24 adresses sur ton réseau, je te signale que ca ralentit certaines opérations sur le réseau (comme par exemple le browsing sur un réseau NT) :slightly_smiling:
sinon rjcb, es tu sur de ta syntaxe avec des listes d’users séparées par des virgules au lieu d’espaces ?


#4

heu oui mais c’est pas moi qui choisi les ip :cry: c’est mon routeur, et c’est un pti routeur pas tres cher qui ne fait pas grand chose lol on ne sait pas changer l’adressage DHCP par un adressage “normal” enfin bon … :frowning:


#5

c koi ton routeur ?


#6

c’est un modem/routeur adsl en fait, un thomson 510 v4 4ports :laughing: un pti truc quoi … lol mais la j’ai l’intention d’acheter un us robotics 905 (je crois) il est bien plus complet et bien plus configurable :slightly_smiling:


#7

tu rigoles, il est trés bien ton routeur… je ne sais pas si il est trés bon en termes de qualité de routage, de sécurité, et pour la tenue de la ligne, mais il a toutes les fonctionnalités qu’on peut demander à un routeur.
Contrairement à ce que tu dis, on peut reconfigurer la plage d’adresses allouées, et non seulement tu dois pouvoir le faire depuis l’interface web
mais en plus, tu peux faire une configuration plus fine avec le Cli en telnet:
speedtouch.com/pdf/ST500 CLI Reference Guide R4.2.pdf
telnet sur ton routeur
plusieurs types de nat, tftp pour sauver la config, etc… il y a même un traceroute !!!

j’ai l’air con, moi, avec mon vieux speedtouch home upgradé en pro :frowning:


#8

bof, il fait meme pas la mise a jour des domaines no-ip, dyndns etc … :frowning: on ne sais pas “couper” le firewall et quelques autres trucs que j’airai aimé avoir, en plus pas moyen de foutre une entree nat pour que je puisse faire serveur web avec ma machine, ssh non plus, pourtant je mappe bien mes ports mais bon, il laisse passer ce que je veux, sauf quand je veux faire un serveur ba je l’ai dans le *** a chaque fois :frowning: lol il laisse pas passer la connexion malgré ma config

oui merci je suis pas debile a ce point non plus :unamused: lol

par cntre j’avai jamais vu qu’on pouvait modif l’adressage lol tu me conseille quoi comme adressage et masque de sous reseau ?

++
:arrow_right: :arrow_right:


#9

192.168.???.0-254/255.255.255.0
prends autrechose que le 0 pour ???, ca t’evitera de devoir changer si tu te connectes à un autre lan par vpn…


#10

la tu n’es pas tres clair… je comprends ce que tu veux faire, mais pas ton pb…


#11

Salut,

J’ai fais ce que tu m’as dit mais tjs rien.
J’imprime une doc via mon poste client et cela maintenant reste en attente d’impression.

Merci


#12

J’ai ajouté une imprimante sur des postes client , nikel reconnu sous le nom de \RJCSERVEUR\printer

Ds la config de redhat de l’imprimante j’ai :

Nom de la file d’attente: printer
type de file d’attente: Connectée localement
dev/usb/lpo

Les pilotes sont ok.

De plus sur samba il faut déclarer le lpo non?

Merci


#13

ici c debian, si tu as des questions redhat, va chez redhat :frowning: