Sarge et ma carte son


#1

Bonjour

Je me permet de poster car j’ai un probléme avec ma carte son Audigy 2 zs et ma debian sarge
Quand je l’ai installée avec le noyau 2.6-7 , je reglais avec la console de mixage de gnome tout à fond mais impossible d’entendre un son (par contre si je met l’ampli + table de mixage a fond , j’entend bien sur un enorme souffle mais aussi le son presque inaudible)
On ma dit que le probléme vient de alsa qui n’est pas integré par defaut dans cette version du noyau
J’ai donc installer le 2.6-8 avec apt-get kernel-image puis rebooter , je lance alsaconf qui me trouve “emu10k1 creatibe labs sb audigy (rev04)” et “legacy probe legacy isa (non-pnp) chips” , je selectionne donc la 1er et me dit qu’il la installé
J’ai alors lancé le alsamixergui et me donne une erreur en disant bt788 … En effet , j’ai une carte télé . Je l’ai donc retiré (je ne l’utilise jamais) , je reboot et je relance , je met donc tous les potentiométres de alsamixergui a fond , je lance un son … et toujours rien
J’ai essayé le live-cd de Ubuntu et le son fonctionne
Je souhaite rester pourtant sur une sarge

Si quelqu’un peut m’aider

Merci


#2

Salut !

Je ne suis vraiment pas expert sur Linux (y a qu’à voir mes autres posts, snif), mais cela ne pourrait -il venir du service que ton système utilise pour le son ?
Au cours de mes errances sur la Toile, j’ai pu voir que les deux prinipaux étaient arts et esd… Lequel utilises-tu ?

… Hum, je fais le mariole, mais mon système n’en utilise aucun, d’après ce que je viens de regarder. Sur ma Debian, les services (au sens daemon) qui semblent avoir un rapport avec le son sont alsa et aumix… Et encore, je n’en vois aucun dans un ps -A ?! Bref, y a mystère, là…

J’ai quand même vu que j’avais installé “arts” ; par contre je ne sais pas si c’est grâce à ça que j’ai du son…

Bref, j’ai pas fait avancer le sujet, mais il reste ne haut des sujets, c’est toujours ça de pris :wink:


#3

[quote=“stephkoil”]Bonjour

Je me permet de poster car j’ai un probléme avec ma carte son Audigy 2 zs et ma debian sarge
Quand je l’ai installée avec le noyau 2.6-7 , je reglais avec la console de mixage de gnome tout à fond mais impossible d’entendre un son (par contre si je met l’ampli + table de mixage a fond , j’entend bien sur un enorme souffle mais aussi le son presque inaudible)
On ma dit que le probléme vient de alsa qui n’est pas integré par defaut dans cette version du noyau
J’ai donc installer le 2.6-8 avec apt-get kernel-image puis rebooter , je lance alsaconf qui me trouve “emu10k1 creatibe labs sb audigy (rev04)” et “legacy probe legacy isa (non-pnp) chips” , je selectionne donc la 1er et me dit qu’il la installé
J’ai alors lancé le alsamixergui et me donne une erreur en disant bt788 … En effet , j’ai une carte télé . Je l’ai donc retiré (je ne l’utilise jamais) , je reboot et je relance , je met donc tous les potentiométres de alsamixergui a fond , je lance un son … et toujours rien
J’ai essayé le live-cd de Ubuntu et le son fonctionne
Je souhaite rester pourtant sur une sarge

Si quelqu’un peut m’aider

Merci[/quote]

as tu ces problemes en tant qu’utilisateur simple ou en tant que root??
si en root le probleme est résolu c’est que tu as oublié de te rajouté dans le groupe audio…

c’est surement pas le cas, mais bon, on ne sait jamais


#4

[quote=“stephkoil”]Bonjour
Je me permet de poster car j’ai un probléme avec ma carte son Audigy 2 zs et ma debian sarge
Quand je l’ai installée avec le noyau 2.6-7

J’ai donc installer le 2.6-8 avec apt-get kernel-image puis rebooter , je lance

[/quote]

J’ai eu le meme soucis que toi.
Donc je vais peut etre pouvoir t’aider,voici la demarche:

Tu parles de plusieurs noyaux…
Tu n’as peut etre simplement pas activé le module snd-emu10k1 dans la config de tes noyaux noyau
Verifies ca, d’abord.

#root> modinfo snd-emu10k1pour savoir si ton noyau gère bien le module.

Au vu de ce que tu as l’air de dire, ca semble bon.

Ensuite:

#root> apt-get remove --purge alsa-base alsa-utils       # je sais c'est violent
# root> apt-get install  alsa-base alsa-utils
# root> alsaconf

moi c’est ce qui m’a permis de resoudre le pb!


#5

Bonjour

Desolé de mon absence mais j’ai eu des petits soucis et tjs avec la carte son

  • Je suis bien dans le groupe audio
  • modinfo snd-emu10k1
    filename: /lib/modules/2.6.8-2-386/kernel/sound/pci/emu10k1/snd-emu10k1.koauthor: Jaroslav Kysela perex@suse.cz
    description: EMU10K1
    license: GPL
    vermagic: 2.6.8-2-386 preempt 386 gcc-3.3
    depends: snd-pcm,snd-ac97-codec,snd-util-mem,snd-page-alloc,snd-rawmidi,snd,snd-hwdep,snd-seq-device
    alias: pci:v00001102d00000002svsdbcsci*
    alias: pci:v00001102d00000004svsdbcsci*
    parm: enable_ir:Enable IR.
    parm: max_buffer_size:Maximum sample buffer size in MB.
    parm: max_synth_voices:Maximum number of voices for WaveTable.
    parm: seq_ports:Allocated sequencer ports for internal synthesizer.
    parm: extout:Available external outputs for FX8010. Zero=default.
    parm: extin:Available external inputs for FX8010. Zero=default.
    parm: enable:Enable the EMU10K1 soundcard.
    parm: id:ID string for the EMU10K1 soundcard.
    parm: index:Index value for the EMU10K1 soundcard.

J’ai essaye
apt-get remove --purge alsa-base alsa-utils
apt-get install alsa-base alsa-utils
alsaconf

mais hélas sans succés

J’ai également demander de l’aide a un utilisateur de léa
je me permet de poster le lien car j’ai essayé quelques manipes
lea-linux.org/pho/read/8/206316#debut

Si quelqu’un a donc une idée
Merci


#6

Je fais aussi partie des heureux utilisateurs de Debian qui ont des problèmes de son :laughing:
Perso, j’ai résolu de façon radicale en virant tout simplement tt ce qui commençait par ‘alsa’ ds synaptic.
Depuis, plus d’alsa mais du son :wink:

Ps : ds system de son/matériel, il faut mettre à détection automatique (je suis sous KDE)


#7

Ricardo t’es sérieux c’est vrai, tu crois que je dois faire ça aussi moi …
J’ai du son sur les événements, mais pas sur les cd ou lecture de fichiers mp3 ? :confused:


#8

C’est un topic ancien mais tu peux tenter le coup, tu ne risque rien.
depuis, j’ai rechargé d’autres distribs Debian et j’ai reconfiguré avec Alsa et ça fonctionne.


#9

Merci ricardo …
Oui j’ai ressorti ce vieux post de derrière les fagots, dans mes recherches pour règler mon prob… des fois qu’une réponse ai été trouvée mais entre temps .
Bon, pour XMMS, en ce qui me concerne, c’est tout bon …
je suis passé par les phases son évenements mais pas mp3, puis l’inverse, puis plus rien, et il me semble que pour avoir les deux, il faut que chacun fasse appel à un plugin différents non ?
donc, j’ai choisi dans option --> preferences --> E/S Audio --> greffon de sortie : eSound 1.2.10 [libesdout.so], configuré en :
“utiliser l’hôte distant” = décoché
"Controle du volume mixeur OSS" = décoché
De sorte que j’ai aussi les évenements sonores (qui doivent faire appel eux à alsa ? ).
Cependant, si à un moment j’avait xmms et vlc qui me donnait du son, maintenant j’ai plus que xmms … pfff et repfff :cry:
Bon allez, dodo.