Secure boot :(

Bonjour,

Il faut que je le crie. Secure boot c’est vraiment pas bien.
Je viens de galérer à installer le pilote nvidia.

celui-ci ne voulais pas charger. J’ai bien suivi le wiki. Le module ne charge pas.
Apres moult installations, en sid en stable.
j’ai compris que le secure boot bloque les nvidias.

voila je devais le dire

Salut, peux-tu détailler tes manips stp? Le sujet me semble intéressant et potentiellement utile pour d’autres. Merci d’avance :wink:

en gros

il faut soit signer les drivers de nvidia. La procédure est difficile.
soit en désactive le Secure boot.

j’ai choisi la deuxième option.

Il y a également une incompatibilité avec virtualbox

Alors, mon avis sur le secure boot et les cartes nvidia, c’est que c’est probablement très bien pour Windows, voire peut-être Mac, à la limite, mais ailleurs, c’est juste le huitième cercle de l’enfer de Dente.

1 J'aime

Le soucis c’est que sur les nouvelles machines

le Secure boot n’est plus désactivable. Je vois mal le pauvre débutant taper tous les lignes de commandes pour qu’il est de la 3d.

en tout cas, j’ai perdu 3 heures car je croyais que Debian était buggué.

C’est quoi la carte-mère ? marque et modèle !?


Dante !

Iel a une dent contre le Secure Boot . . .

Ba marchine de constructeur genre acer asus.
surtout les portables.

Et les cartes nvidia !

Dante :wink: Il y a neuf cercles et 8 fosses dans le huitième :slight_smile:

sur: NvidiaGraphicsDrivers/Troubleshooting - Debian Wiki

Secure Boot

Although Secure Boot is now supported by Debian, the NVIDIA driver requires DKMS, which requires additional setup to be used with Secure Boot. An easier alternative is to disable Secure Boot in your system’s BIOS.

Personnellement j’utilise chkboot pour vérifier que le boot n’a pas été modifié. Ca marche bien.