Serveur mail qui ne veux pas laisser me connecter | RainLoop & Postfix / Dovecot | Debian 9 | Installation DigitalOcean

postfix
dovecot
installation
Tags: #<Tag:0x00007fa94b00b1e8> #<Tag:0x00007fa94b00ac98> #<Tag:0x00007fa94b00a5e0>

#1

Bonjour,
J’ai un gros problème, RainLoop veux pas se connecter aux ports avec sécurité !
SSL est bien configuré (le certificat n’est pas éxpiré, Let’s Encrypt X3), et le pire je n’ai aucun message d’erreur RainLoop, juste les titres “IMAP” & “SMTP” qui se mettent en rouges. Sauf que si je met sans sécurité, ca marche. J’avais testé avant-hier, le serveur fonctionnait bien, je n’ai rien touché à la config.

Voici le tutoriel que j’ai utilisé (attention pour les personnes qui ne sont pas Anglophones):

Des petits logs (/var/log/syslog, avec tail -f):

Nov  4 12:59:56 matteo postfix/smtpd[4931]: connect from unknown[185.234.216.166]
Nov  4 12:59:56 matteo postfix/smtpd[4931]: warning: connect to Milter service unix:/opendkim/opendkim.sock: No such file or directory
Nov  4 12:59:56 matteo postfix/smtpd[4931]: warning: connect to Milter service unix:/clamav/clamav-milter.ctl: No such file or directory
Nov  4 12:59:56 matteo postfix/smtpd[4931]: lost connection after AUTH from unknown[185.234.216.166]
Nov  4 12:59:56 matteo postfix/smtpd[4931]: disconnect from unknown[185.234.216.166] ehlo=1 auth=0/1 commands=1/2
Nov  4 13:00:26 matteo dovecot: imap-login: Disconnected: Inactivity (no auth attempts in 180 secs): user=<>, rip=51.75.190.131, lip=51.75.190.129, TLS handshaking, session=<sncoF4mWauszS76D>

Un petit screen de RainLoop (vous en faites pas pour le domaine nynpo.fr, c’est le même serveur :stuck_out_tongue:):
image

PS: J’ai fait un netstat -ptnl, et les ports:

SMTP: 25, 465, 587 (STARTTLS, donc 587)
IMAP: 143, 993 (SSL/TLS, donc 993)

Et vu que j’ai mis mon serveur dovecot, avec les options:

ssl = required
disable_authplain_text = yes

Si vous avez besoin d’autres précisions comme mon fichier main.cf ou master.cf, n’hésitez pas :stuck_out_tongue:

Bonne soirée à vous :slight_smile:


#2

wlh j’ai r compris frr


#4

Ce message a été signalé par la communauté et temporairement masqué.


#6

Avancée: Si je met port 993 & 587 sans sécurité j RainLoop me préviens d’un timeout. Et pour SMTP ÇA MARCHE


#7

Bonjour,
Il faudra corriger ces deux erreurs de milter :

Nov  4 12:59:56 matteo postfix/smtpd[4931]: warning: connect to Milter service unix:/opendkim/opendkim.sock: No such file or directory
Nov  4 12:59:56 matteo postfix/smtpd[4931]: warning: connect to Milter service unix:/clamav/clamav-milter.ctl: No such file or directory

Il faut bien vérifier tes certificats, leurs droits d’accès, et leur configuration dans Postfix (smtpd_tls_cert_file et smtpd_tls_key_file) et dans Dovecot (ssl_cert et sssl_key). Par ailleurs du peux désactivé IMAP sur le port 143 dans Dovecot pour ne conserver que IMAPS


#8

Bonjour,
Merci à toi Bruno, car personne ne me réponds sauf toi.

Alors pour ta question du milter: c’est fait.
Et pour le SSL j’ai bien mis les bons chemins c’est à dire: /etc/letsencrypt/live/mx01.lapiscraft.fr/fullchain.pem & /etc/letsencrypt/live/mx01.lapiscraft.fr/privkey.pem

-Matteo


#9

Il faut tester avec un autre client que Rainloop, Thunderbird sur une machine distante par exemple, pour voir si le problème ne vient pas de Rainloop.


#10

Je compte le faire


#11

RainLoop je te haie


#12

J’ai testé avec un autre webmail (Gmail) et le MX marche bien donc c’est bien RainLoop
Un petit tail -f log-2019-11-06.txt ce qui donne:

[17:03:27.497][4fcf7fd1] INFO[DATA]: [DATE:06.11.19][OFFSET:-00][RL:1.13.0][PHP:7.0.33-0+deb9u6][IP:80.15.105.16][PID:28124][Apache][apache2handler]
[17:03:27.497][4fcf7fd1] INFO[DATA]: [Suhosin:off][APC:off][MB:on][PDO:mysql][Streams:tcp,udp,unix,udg,ssl,sslv2,tls,tlsv1.0,tlsv1.1,tlsv1.2]
[17:03:27.497][4fcf7fd1] REQUEST[NOTE]: [POST] https://webmail.nynpo.fr/?/Ajax/&q[]=/0/
[17:03:27.497][4fcf7fd1] AJAX[NOTE]: Action: DoAdminDomainTest
[17:03:27.497][4fcf7fd1] POST[DATA]: {"Name":"gmail.com","IncHost":"imap.gmail.com","IncPort":"993","IncSecure":"1","UseSieve":"0","SieveHost":"","SievePort":"4190","SieveSecure":"0","OutHost":"smtp.gmail.com","OutPort":"587","OutSecure":"2","OutAuth":"1","OutUsePhpMail":"0","Action":"AdminDomainTest","XToken":"526bcf4530c21a871a6cfab2b8d1aafd"}
[17:03:27.498][4fcf7fd1] IMAP[NOTE]: Start connection to "ssl://imap.gmail.com:993"

PS: J’ai reinstallé RainLoop donc le souci viens bien de RainLoop, je pense que si personne réponds sur ce topic je demanderais sur leur github: https://github.com/RainLoop/rainloop-webmail