Serveur PXE

Bonjour,

Je viens de terminer l’installation de mon serveur pxe mais bien sûr ca ne marche pas le boot process reste bloqué sur:

iPXE (PCI E2:00.0) starting execution...ok
iPXE initialising devices...ok



iPXE 1.0.0+ -- Open Source Network Boot Firmware -- http://ipxe.org
Features: DNS TFTP HTTP PXE PXEXT Menu

net0: 08:00:27:71:16:3c using 82540em on 0PCI00:03.0 (open)
  [Link:down, TX:0 TXE:0 RX:0 RXE:0]
  [Link status: Down (http://ipxe.org/38086101)]
Waiting for link-up on net0... ok
DHCP (net0 08:00:27:71:16:3c)...... ok
net0: 172.16.16.10/255.255.255.0 gw 172.16.16.1
Next server: 172.16.16.150
Filename: syslinux.efi
tftp://172.16.16.150/syslinux.efi... ok

Par contre un truc me saute aux yeux syslinux.efi n’est pas sur la racine dans ma config mais ds un répertoire /tftpboot.
Avez vous une idée de comment corriger ce fait sans tout casser

Merci

Il faut vérifier la configuration de ton serveur tftp. Il y a normalement un paramètre serveur root directory qui permet de spécifier le répertoire racine. genre:

service tftp
{
protocol    	= udp
port        	= 69
socket_type 	= dgram
wait        	= yes
user        	= nobody
server      	= /usr/sbin/in.tftpd
server_args 	= /tftpboot
disable     	= no
}

Ah j’y pense ça utilise xinetd, donc coté sécurité, ce n’est pas terrible.

Ca me dit rien
Par contre j’ai configuré /etc/default/tftpd-hpa

Je me demande s’il y a pas un souci du à pfsense ou du au fait que je fais ca sous vbox

Ps: mon serveur dhcp debian fonctionne bien

Petite question supplémentaire: pensez vous que le fait que j’ai omis:

###PXE###
option space PXE;
option PXE.mtftp-ip code 1 = ip-address;
option PXE.mtftp-cport code 2 = unsigned integer 16;
option PXE.mtftp-sport code 3 = unsigned integer 16;
option PXE.mtftp-tmout code 4 = unsigned integer 8;
option PXE.mtftp-delay code 5 = unsigned integer 8;
option arch code 93 = unsigned integer 16;

option space ipxe;
option ipxe-encap-opts code 175 = encapsulate ipxe;
option ipxe.priority code 1 = signed integer 8;
option ipxe.keep-san code 8 = unsigned integer 8;
option ipxe.skip-san-boot code 9 = unsigned integer 8;
option ipxe.syslogs code 85 = string;
option ipxe.cert code 91 = string;
option ipxe.privkey code 92 = string;
option ipxe.crosscert code 93 = string;
option ipxe.no-pxedhcp code 176 = unsigned integer 8;
option ipxe.bus-id code 177 = string;
option ipxe.san-filename code 188 = string;
option ipxe.bios-drive code 189 = unsigned integer 8;
option ipxe.username code 190 = string;
option ipxe.password code 191 = string;
option ipxe.reverse-username code 192 = string;
option ipxe.reverse-password code 193 = string;
option ipxe.version code 235 = string;
option iscsi-initiator-iqn code 203 = string;
# Feature indicators
option ipxe.pxeext code 16 = unsigned integer 8;
option ipxe.iscsi code 17 = unsigned integer 8;
option ipxe.aoe code 18 = unsigned integer 8;
option ipxe.http code 19 = unsigned integer 8;
option ipxe.https code 20 = unsigned integer 8;
option ipxe.tftp code 21 = unsigned integer 8;
option ipxe.ftp code 22 = unsigned integer 8;
option ipxe.dns code 23 = unsigned integer 8;
option ipxe.bzimage code 24 = unsigned integer 8;
option ipxe.multiboot code 25 = unsigned integer 8;
option ipxe.slam code 26 = unsigned integer 8;
option ipxe.srp code 27 = unsigned integer 8;
option ipxe.nbi code 32 = unsigned integer 8;
option ipxe.pxe code 33 = unsigned integer 8;
option ipxe.elf code 34 = unsigned integer 8;
option ipxe.comboot code 35 = unsigned integer 8;
option ipxe.efi code 36 = unsigned integer 8;
option ipxe.fcoe code 37 = unsigned integer 8;
option ipxe.vlan code 38 = unsigned integer 8;
option ipxe.menu code 39 = unsigned integer 8;
option ipxe.sdi code 40 = unsigned integer 8;
option ipxe.nfs code 41 = unsigned integer 8;

…dans mon dhcpd.conf soit un élément supplémentaire à mon échec?

Sur la capture ecran je vois link down et puis « ok » j’ai bien configuré toutes les interfaces pourtant

Oui c’est normal, au départ le lien est down, puis ensuite le lien est mis up puis il reçoit les paramètres DHCP.

Désolé de remonter ce sujet mais je souhaiterais bien faire fonctionner ce bouzin…je sens que ce n’est pas grand chose mais…voilà quoi… :crazy_face:

Quelqu’un aurait il une piste?

ps:

En fait j’ai corrigé le probleme de l’interface up en changeant le type d’interface sur l’hyperviseur

Salut,
qu’est-ce qui ne fonctionne pas?

je ne depasse pas l’ecran vu plus haut