Serveur web apache


#1

J’ai placé mon site /WebResto dans le dossier /var/www mais quand j’ouvre mon navigateur à l’adresse suivante localhost/WebResto/
J’ai une insulte qui me dit en substance Forbidden

You don’t have permission to access /WebResto/ on this server.
Apache/2.0.53 (Debian GNU/Linux) mod_python/3.1.3 Python/2.3.5 PHP/4.3.10-9 mod_perl/1.999.20 Perl/v5.8.4 Server at localhost Port 80
Quelqu’un peut-il m’aider à rétablire le dialogue avec mon apache?


#2

Est ce que tu as autoriser le groupe other a visualiser le contenu de ton repertoire et as tu bien configurer les droits apache pour faire la meme chose


#3

Non.
Quelle sont les deux procédures?


#4

pour les droits unix tu te met dans le repertoire “/www” la ou se trouve ton repertoire webresto puis tu lui alloue les droits en lecture seulement au groupe otherchmod o+rx WebResto
Et ensuite il faut que tu lui alloue les memes droits avec apache sinon il va y a avoir quelques problemes :slightly_smiling:<directory /www/WebResto> Order allow,deny Allow from all </directory>A rajouter dans ton fichier de configuration d’apache


#5

Bon, il y avait un souci avec les droits de lecture des fichiers par le groupe other. Grâce a ton aide, c’est plié. Mais cette solution n’est pas trés satisfaisante, car il faut donner les droits dés que je crée un autre répertoire.
N’y a t-il pas une solution avec un ln -s dans mon répertoire var/www/ qui ferait référence à un dossier /home/utilisateur/WebResto par exemple ?
D’autre part, j’ai vu un truc comme ça dans la config d’apache Qu’est-ce que ça veut dire?

[code]#<Directory /home/*/public_html>

AllowOverride FileInfo AuthConfig Limit

Options Indexes SymLinksIfOwnerMatch IncludesNoExec

#

<directory /www/WebResto> #C’est la que j’ai rajouté le code
Order allow,deny
Allow from all

[/code]
Enfin, ne faut il pas donner /var/wwww/Webresto à apache plutot que le chemain ci-dessus ?


#6

[quote=“yannounet”]Bon, il y avait un souci avec les droits de lecture des fichiers par le groupe other. Grâce a ton aide, c’est plié. Mais cette solution n’est pas trés satisfaisante, car il faut donner les droits dés que je crée un autre répertoire.
N’y a t-il pas une solution avec un ln -s dans mon répertoire var/www/ qui ferait référence à un dossier /home/utilisateur/WebResto par exemple ?[/quote]
Tout d’abord désolé de ne pas avoir répondu plus tot mais je suis actuellement en deplacement et je n’ai pas internet ou je vais :s
En fait tu voudrais juste mettre un lien dans ton repertoire www pour pouvoir y acceder ailleur mais tu as une meilleur solution qui consiste a changer ton repertoire web dans la configuration d’apache exemple

<directory /home/utilisateur/web/WebResto> Order allow,deny Allow from all </directory>
Order allow, deny te permet de preciser l’ordre d’autorisation que tu lui fournis par default avec cette regles tu interdit a tout le monde mais comme tu as Allow from all derriere ca autorise a tout le monde mais tu aurais pu mettre Allow from xxx.xxx.xxx.xxx ce qui autoriserais seulement l’adresse ip etc

[quote=“yannounet”]
D’autre part, j’ai vu un truc comme ça dans la config d’apache Qu’est-ce que ça veut dire?

[code]#<Directory /home/*/public_html>

AllowOverride FileInfo AuthConfig Limit

Options Indexes SymLinksIfOwnerMatch IncludesNoExec

#

<directory /www/WebResto> #C’est la que j’ai rajouté le code
Order allow,deny
Allow from all

[/code]
Enfin, ne faut il pas donner /var/wwww/Webresto à apache plutot que le chemain ci-dessus ?[/quote]Au vu des questions que tu pose je pense que tu doit avoir quelques lacunes au niveau configuration d’apache regarde la ca pourras t’aider :slightly_smiling:
httpd.apache.org/docs-2.0/