SERVICE : numéro d'ordre à 01 malgré des dépendances

Bonjour,

J’essaie d’activer un service avec des dépendances :

[code]#!/bin/bash

BEGIN INIT INFO

Provides: serviceZ

Required-Start: $local_fs $network serviceA serviceB serviceC

Required-Stop: $local_fs $network serviceA serviceB serviceC


[/code]

D’autres services biensur font des “Provides de serviceA,B,C”

Pour tant j’ai toujours un numéro d’ordre = 1

/etc/rc4.d/S01serviceZ /etc/rc6.d/K01serviceZ /etc/rc0.d/K01serviceZ /etc/rc2.d/S01serviceZ /etc/rc5.d/S01serviceZ /etc/rc3.d/S01serviceZ /etc/init.d/serviceZ /etc/rc1.d/K01serviceZ

Qu’est-ce que j’ai loupé …

Par avance merci les gens

Alain

Si les service[ABC] sont démarrés dans le runlevel S comme le sont $local_fs et $network, alors c’est normal. Sinon, je sèche…

Merci pour ta réponse.

Les Default-Start sont tous de 2,3,4,5

[code]#!/bin/bash

BEGIN INIT INFO

Provides: {{cassandra1.name}}

Required-Start: $local_fs $network $time

Required-Stop: $local_fs $network

Default-Start: 2 3 4 5

Default-Stop: 0 1 6

Short-Description: {{cassandra1.name}}

Description: {{cassandra1.name}}

END INIT INFO

[/code]

Ensuite les services qui dépendent de ce service ont les même Default-Start/Stop. Suis sur wheezy

Ca me rend dingue ce truc.

Merci pour votre aide

Ce qui est vraiment étonnant c’est qu’un

/usr/share/insserv/check-initd-order -g
me donne pourtant une dépendance correcte cf pj.

Pour activer le service c’est bien :

# update-rc.d service enable ?

Par avance merci

Alain

[mono]enable[/mono] sert à réactiver le démarrage d’un service installé qui avait été désactivé avec [mono]disable[/mono]. Pour installer un service (créer les liens symboliques), il faut utiliser [mono]defaults[/mono]. Attention, cela ne modifie pas les éventuels liens symboliques existants pour ce service (qu’il soit activé ou désactivé).

PS : ton image est trop petite et illisible.

Bon bien c’est pas glorieux mais le pb venais du double espace.

Oui entre [mono]$local_fs[/mono] et [mono]$network[/mono] du coup le parse s’arrêtait là…

Bon merci quand même.

Bon week

Alain

Je n’y aurais pas pensé. Cela ressemble à un bug…