Shutdown -h n'éteint pas la machine

Tags: #<Tag:0x00007ff8e825b528> #<Tag:0x00007ff8e825b460>

Bonjour,
J’utilise la version Bullseye sur un Lenovo Thinkpad T460S
Ma machine ne s’éteint pas complètement lors d’un shutdown -h now.
Les messages défilent et s’arrêtent sur :

[ OK ]Finished Power-Off.
[ OK ]Reached target Power-Off
[98, 782255] reboot: Power down

Ce n’est pas bloquant puisque je peux éteindre en appuyant 5s sur le bouton mais j’aimerais comprendre.

A noter que le reboot fonctionne bien.

Bonsoir,

avec un shutdown -h now?

j’ai eu ça y a très longtemps mais je ne sais plus comment j’ai résolu
regarde du côté des logs, des erreurs dans dmesg

oui oui,
j’ai essayé via Gnome, via une console, via une connexion externe ssh… pareil

Bonsoir,
Tente ceci, edite le fichier /etc/default/grub et modifie la ligne GRUB_CMDLINE_LINUX_DEFAULT en ajoutant acpi=force
Par exemple pour ma part la ligne ressemble a
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
Elle ressemblerai a ceci apres :
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=force"

Ensuite tu execute la commande :
update-grub

Ensuite tu peux redemarrer et apres cela le prochain shutdown devrait bien se derouler.

effectivement, de mémoire c’était un problème acpi

Bonjour et bienvenue sur le forum,

Oui, j’ai rencontré le même souci il y a longtemps.
La solution que j’ai trouvée est de ne plus utiliser shutdown -h now ou halt pour éteindre la machine, mais exclusivement poweroff.
Je n’ai jamais eu de problème avec poweroff.

man poweroff :
systemd is more accurate here, and halt results in halting the machine
only (leaving power on), and poweroff is required to actually power it
off.

1 J'aime

Merci, j’ai essayé acpi=force mais c’est sans effet.

J’ai essayé le poweroff sans succès. J’atteins le même message Reached-Target Power-Off (comme avec le shutdown -h) mais la machine reste allumée.
J’ai l’impression que c’est plutôt le bios de la machine qui y est pour quelque chose. C’est la seule machine qui me fait ça.

Pour ma part j’utilise:
shutdown -P now

pas mieux… Merci

ou peut être shutdown -rf now

j’utilise

halt -p

ou
shutdown -hP now

Et le BIOS dit quelque chose sur ce point justement ?

J’ai essayé les autres options du shutdown mais sans succès.

J’ai bien l’impression que c’est lié à la machine mais je n’ai rien trouvé d’évident dans le setup du Bios. Je suis en dual boot et W10 arrive à éteindre correctement.
Le reboot passe correctement, c’est bien le power-off qui n’est pas appliqué

bonjour,
question de demi-noob : je ne comprends pas l’intérêt de cet appui , pas plus que toutes ces différentes commandes alors que alt+F4 met le bouton éteindre à disposition d’un clic . Est-ce parce qu’un utilisateur avancé se trouve quasimment toujours dans un terminal et qu’avec un alias c’est plus rapide ? ou bien ?

ps : je viens de lire que : " Pour éteindre la machine, utilisez poweroff ou shutdown -h now . Le système d’initialisation systemd fournit des commandes additionnelles qui effectuent la même chose, par exemple systemctl reboot ou systemctl poweroff . " chap 8.1 de debian 11 . Le bouton « éteindre » n’est même pas mentionné !!

Vrai , désolé, j’aurais dû commencer ma question initiale par :
Le menu Gnome/Eteindre puis éteindre n’éteint pas complètement la machine qui laisse l’affichage actif sur le dernier message en mode texte « Power down ».
Voici pourquoi j’ai essayé les diverses commandes en mode console.

ah ok ! je n’avais pas du tout envisagé ce cas de figure , je pensais plutôt " trucs et astuces " .

Ah, le dual boot W10 est une info importante. Sais-tu si fastboot est activé sur ton windows (c’est le cas par défaut) ? fastboot permet de démarrer ton système W10 plus rapidement, mais la contrepartie c’est qu’il place le système en hibernation au lieu de l’éteindre complètement.
Tu peux faire un test simple, pour voir:

  1. Démarre sur W10
  2. Eteins le complètement en utilisant la ligne cmd admin suivante: shutdown /s /f /t 0
  3. Démarre sur Debian
  4. Retente une extinction classique, avec shutdown -h par exemple