[Sid] 156 paquets en souffrance

Tags: #<Tag:0x00007f58cd794a00>

Bonjour à tous, depuis quelques semaines, maintenant, j’ai un gros tas de paquets en souffrance de mise à jour.

les paquets en souffrance
# apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  accountwizard akonadi-backend-mysql akonadi-contacts-data akonadi-mime-data akonadi-server akregator gcc-10-base
  gir1.2-pango-1.0 gnome-desktop3-data gnome-flashback gnome-flashback-common gnome-session-flashback kaddressbook
  kde-config-mailtransport kdepim-addons kdepim-runtime kdepim-themeeditors kf5-kdepim-apps-libs-data
  kf5-messagelib-data kio-ldap kmail knotes korganizer lib64atomic1 lib64gcc-s1 lib64gomp1 lib64itm1 lib64quadmath0
  lib64stdc++6 lib64ubsan1 libatomic1 libcc1-0 libgcc-s1 libgfortran5 libgnome-desktop-3-19 libgomp1 libitm1
  libkf5akonadi-data libkf5akonadiagentbase5 libkf5akonadicalendar-data libkf5akonadicalendar5abi1
  libkf5akonadicontact5 libkf5akonadicore5abi2 libkf5akonadimime5 libkf5akonadinotes5 libkf5akonadiprivate5abi2
  libkf5akonadisearch-bin libkf5akonadisearch-plugins libkf5akonadisearchcore5 libkf5akonadisearchdebug5
  libkf5akonadisearchpim5 libkf5akonadisearchxapian5 libkf5akonadiwidgets5abi1 libkf5alarmcalendar5abi1
  libkf5calendarcore5abi2 libkf5calendarsupport-data libkf5calendarsupport5abi1 libkf5calendarutils5
  libkf5contacteditor5 libkf5contacts-data libkf5contacts5 libkf5eventviews5abi1 libkf5followupreminder5
  libkf5grantleetheme5 libkf5gravatar-data libkf5gravatar5abi2 libkf5identitymanagement5 libkf5imap5
  libkf5incidenceeditor-data libkf5incidenceeditor5abi1 libkf5kaddressbookgrantlee5 libkf5kaddressbookimportexport5
  libkf5kdepimdbusinterfaces5 libkf5kmanagesieve5 libkf5kontactinterface-data libkf5kontactinterface5
  libkf5ksieve-data libkf5ksieve5 libkf5ksieveui5 libkf5ldap5abi1 libkf5libkdepim-plugins libkf5libkdepim5
  libkf5libkdepimakonadi5 libkf5libkleo-data libkf5libkleo5 libkf5mailcommon-data libkf5mailcommon5abi2
  libkf5mailimporter5 libkf5mailimporterakonadi5 libkf5mailtransport-data libkf5mailtransport5
  libkf5mailtransportakonadi5 libkf5mbox5 libkf5messagecomposer5abi1 libkf5messagecore5abi1 libkf5messagelist5abi1
  libkf5messageviewer5abi1 libkf5mime-data libkf5mime5abi1 libkf5mimetreeparser5abi1 libkf5pimcommon-data
  libkf5pimcommon5abi2 libkf5pimcommonakonadi5abi1 libkf5pimtextedit-data libkf5pimtextedit-plugins
  libkf5pimtextedit5abi2 libkf5sendlater5 libkf5templateparser5 libkf5tnef5 libkf5webengineviewer5abi1
  libkpimgapi-data libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapicore5abi1 libkpimgapitasks5
  libkpimimportwizard5 libkpimitinerary5 libkpimpkpass5 libkpimsmtp5abi1 libnautilus-extension1a libobjc4
  libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libquadmath0 libsasl2-modules-kdexoauth2
  libstdc++6 libubsan1 libx32atomic1 libx32gcc-s1 libx32gomp1 libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan1
  mbox-importer nautilus nautilus-data pim-data-exporter pim-sieve-editor python3-chardet python3-lxml
  qemu-system-data qemu-system-x86 ruby-atk ruby-cairo-gobject ruby-gdk-pixbuf2 ruby-gio2 ruby-glib2
  ruby-gobject-introspection ruby-gtk2 ruby-pango ruby-rsvg2 thunar thunar-data
Les paquets suivants seront mis à jour :
  intel-microcode libcpupower1 linux-compiler-gcc-9-x86 linux-libc-dev
4 mis à jour, 0 nouvellement installés, 0 à enlever et 156 non mis à jour.
Il est nécessaire de prendre 4 000 ko dans les archives.
Après cette opération, 45,1 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]

Si je cherche à forcer la mise à jour avec full-upgrade, il veut supprimer pas mal de paquets, un peu trop à mon goût. L’un des problèmes vient de libpango dont la numérotation du paquet a changé, certains paquets ont conservé l’ancienne numérotation, pas d’autres.

les conflits
Les paquets suivants ont des dépendances non satisfaites :
 kdepim-runtime : Dépend: libkf5dav5 (>= 20.04.1) but it is not installable
                  Dépend: libkf5dav5-20.04 which is a virtual package, provided by:
                           - libkf5dav5 (20.04.1-1), but it is not installable

 lib64gcc1 : Dépend: gcc-10-base (= 10.1.0-1) but 10.1.0-3 is to be installed
 libpango1.0-0 : Dépend: libpango-1.0-0 (= 1.42.4-8) but 1.44.7-4 is to be installed
                 Dépend: libpangocairo-1.0-0 (= 1.42.4-8) but 1.44.7-4 is to be installed
                 Dépend: libpangoft2-1.0-0 (= 1.42.4-8) but 1.44.7-4 is to be installed
                 Dépend: libpangoxft-1.0-0 (= 1.42.4-8) but 1.44.7-4 is to be installed
 libx32gcc1 : Dépend: gcc-10-base (= 10.1.0-1) but 10.1.0-3 is to be installed
 libgcc1 : Dépend: gcc-10-base (= 10.1.0-1) but 10.1.0-3 is to be installed
 qemu-system-data : Est en conflit avec: openbios-ppc but 1.1.git20191022-1 is installed
                    Est en conflit avec: openbios-sparc but 1.1.git20191022-1 is installed
 python3-lxml : Casse: python-lxml (< 4.5.0-1.1) but 4.5.0-1+b1 is installed
 python3-chardet : Casse: python-chardet (< 3.0.4-6) but 3.0.4-5 is installed

Bref, c’est un peu le dawa comme dit.
J’attends sagement les mises à jour comme j’ai presque toujours fait ou il y a un truc derrière (une grosse mise à jour en attente) ?

Bonjour nicola,
As-tu installé Synaptic, vérifie les paquets cassés et aussi si tu n’as des fichiers bloquer en version.

Je n’ai aucun paquet cassé, je ne joue pas avec le punaisage de version de paquet.
Disons qu’il veut supprimer pas mal de paquets (dont scratch, xfmedia, amd64-libs, weboob, unar, skychart…) pour cause de paquets incompatibles.

il n’y a pas de problème quand on à des sources.list Debian uniquement, pas plus avec libpango qu’autres choses.

apt policy libpango-1.0-0
libpango-1.0-0:
  Installé : 1.44.7-4
  Candidat : 1.44.7-4
 Table de version :
 *** 1.44.7-4 990
        990 https://cdn-aws.deb.debian.org/debian bullseye/main amd64 Packages
        500 https://cdn-aws.deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.42.4-8~deb10u1 500
        500 https://cdn-aws.deb.debian.org/debian buster/main amd64 Packages
     1.42.4-7~deb10u1 990
        990 https://cdn-aws.deb.debian.org/debian-security buster/updates/main amd64 Packages
     1.40.5-1 500
        500 https://cdn-aws.deb.debian.org/debian stretch/main amd64 Packages

N’aurais tu pas ajouté des sources venu d’ailleurs: Ubuntu, DMO, etc?

Non.
Le bug est déjà remonté dans le BTS. Visiblement, les développeurs s’empaillent pour savoir s’il faut appeler le paquet libpango-1.0-0 ou libpango1.0-0.

le fichier changelog précise :

  * d/control.in: Drop libpango1.0-0 transitional package
(Closes: #940744, #948462)

les bugs en question :

please drop transitional package libpango1.0-0 from src:pango1.0

pango1.0: Please omit libpango1.0-0 on Ubuntu/i386

en résumé : le paquet de transition libpango1.0-0 a eu une utilité à un moment donné et aujourd’hui il n’en a plus

certains paquets ont mal géré la transition (depuis 2013)

libpango-1.0-0: The new package breaks certain packages like dropbox or Minecraft-launcher

avec tout le respect dû, rien à voir avec une bataille de nom

pour connaitre les paquets qui dépendent de libpango-1.0-0

apt-cache rdepends  libpango-1.0-0

Finalement, j’ai mis à jour avec apt full-upgrade.
Parmi les paquets supprimés, le seul que j’ai pu réinstaller est scratch.