SID Soucis VLC / Bluefish... après full-upgrade

Tags: #<Tag:0x00007f63efd81f58> #<Tag:0x00007f63efd81e90>

Bonjour

Suite à une mise à jour de ma SID et plus de 400 paquets non mis à jour, j’ai lancé un full-upgrade qui m’a ramené le nombre de paquets non mis à jour à une petite vingtaine et suppression de plein de paquets obsolètes

Depuis plus de vlc ni de bluefish et si je tente de les réinstaller, apt veut réinstaller des paquets supprimés lors de l’update

Exemple pour bluefish

root@valhala:~# aptitude install bluefish
Les NOUVEAUX paquets suivants vont être installés :     
  bluefish{b} bluefish-data{a} bluefish-plugins{a} libgucharmap-2-90-7{a} 
0 paquets mis à jour, 4 nouvellement installés, 0 à enlever et 19 non mis à jour.
Il est nécessaire de télécharger 3 624 ko/4 088 ko d'archives. Après dépaquetage, 16,3 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 bluefish : Dépend: gvfs-backends but it is not installable
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     bluefish [Non installé]                                  



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                  
1)      libcdio-cdda2 [10.2+2.0.1-1 (now, unstable)]    
2)      libcdio-paranoia2 [10.2+2.0.1-1 (now, unstable)]

      Installer les paquets suivants :                  
3)      gvfs-backends [1.53.90-4 (unstable)]            
4)      libcdio-cdda2t64 [10.2+2.0.1-1.1 (unstable)]    
5)      libcdio-paranoia2t64 [10.2+2.0.1-1.1 (unstable)]
6)      libgdata-common [0.18.1-4 (unstable)]           
7)      libgdata22 [0.18.1-4 (unstable)]                
8)      libgoa-1.0-0b [3.49.0-2+b1 (unstable)]          
9)      libgoa-1.0-common [3.49.0-2 (unstable)]         
10)     libmtp-common [1.1.21-3.1 (unstable)]           
11)     libmtp-runtime [1.1.21-3.1 (unstable)]          
12)     libmtp9t64 [1.1.21-3.1 (unstable)]              
13)     libnfs14 [5.0.2-1 (unstable)]                   



Accepter cette solution ? [Y/n/q/?] 

Pour VLC

aptitude install vlc
Les NOUVEAUX paquets suivants vont être installés :     
  libproxy-tools{a} libva-wayland2{a} libvlc-bin{a} libvlc5{a} libvlccore9{a} libvncclient1{a} libxcb-xv0{a} vlc{b} vlc-bin{a} vlc-l10n{a} 
  vlc-plugin-access-extra{a} vlc-plugin-notify{a} vlc-plugin-qt{a} vlc-plugin-samba{a} vlc-plugin-skins2{a} vlc-plugin-video-output{a} vlc-plugin-video-splitter{a} 
  vlc-plugin-visualization{a} 
0 paquets mis à jour, 18 nouvellement installés, 0 à enlever et 19 non mis à jour.
Il est nécessaire de télécharger 330 ko/9 778 ko d'archives. Après dépaquetage, 52,2 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 vlc : Dépend: vlc-plugin-base (= 3.0.20-3) but it is not installable
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     vlc [Non installé]                                       



Accepter cette solution ? [Y/n/q/?] n
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                    
1)      libzvbi0 [0.2.42-1.1 (now, unstable)]                             

      Installer les paquets suivants :                                    
2)      libaribb24-0t64 [1.0.3-2.1+b1 (unstable)]                         
3)      libdvbpsi10 [1.3.3-1 (unstable)]                                  
4)      libebml5 [1.4.5-1 (unstable)]                                     
5)      libixml11t64 [1:1.14.18-1.1 (unstable)]                           
6)      liblirc-client0t64 [0.10.2-0.7 (unstable)]                        
7)      liblua5.2-0 [5.2.4-3+b2 (unstable)]                               
8)      libmad0 [0.15.1b-10.1+b1 (unstable)]                              
9)      libmatroska7 [1.7.1-1 (unstable)]                                 
10)     libmtp-common [1.1.21-3.1 (unstable)]                             
11)     libmtp-runtime [1.1.21-3.1 (unstable)]                            
12)     libmtp9t64 [1.1.21-3.1 (unstable)]                                
13)     libnfs14 [5.0.2-1 (unstable)]                                     
14)     libopenmpt-modplug1 [0.8.9.0-openmpt1-2+b1 (unstable)]            
15)     libprotobuf-lite32t64 [3.21.12-8.1 (unstable)]                    
16)     libresid-builder0c2a [2.1.1-15+b1 (unstable)]                     
17)     libsidplay2 [2.1.1-15+b1 (unstable)]                              
18)     libspatialaudio0t64 [0.3.0+git20180730+dfsg1-2.1 (unstable)]      
19)     libupnp17t64 [1:1.14.18-1.1 (unstable)]                           
20)     libzvbi0t64 [0.2.42-2 (unstable)]                                 
21)     vlc-data [3.0.20-3 (unstable)]                                    
22)     vlc-plugin-base [3.0.20-3 (unstable)]                             

      Mettre à jour les paquets suivants :                                
23)     libzvbi-common [0.2.42-1.1 (now, unstable) -> 0.2.42-2 (unstable)]



Accepter cette solution ? [Y/n/q/?] 

Et si ça peut servir

root@valhala:~# apt list --upgradable 
En train de lister... Fait
asunder/unstable 3.0.1+ds-1+b1 amd64 [pouvant être mis à jour depuis : 3.0.1+ds-1]
gimp/unstable 2.10.36-3 amd64 [pouvant être mis à jour depuis : 2.10.36-2+b1]
gnome-themes-extra/unstable 3.28-2+b2 amd64 [pouvant être mis à jour depuis : 3.28-2+b1]
gstreamer1.0-plugins-bad/unstable 1.24.0-1 amd64 [pouvant être mis à jour depuis : 1.22.10-1]
gstreamer1.0-pulseaudio/unstable 1.24.0-1 amd64 [pouvant être mis à jour depuis : 1.22.10-1]
gtk2-engines-murrine/unstable 0.98.2-3+b2 amd64 [pouvant être mis à jour depuis : 0.98.2-3+b1]
gtk2-engines-pixbuf/unstable 2.24.33-4 amd64 [pouvant être mis à jour depuis : 2.24.33-3]
hardinfo/unstable 0.5.1+git20180227-2.1+b2 amd64 [pouvant être mis à jour depuis : 0.5.1+git20180227-2.1+b1]
libegl-mesa0/unstable 24.0.2-1 amd64 [pouvant être mis à jour depuis : 23.3.5-1]
libgail-common/unstable 2.24.33-4 amd64 [pouvant être mis à jour depuis : 2.24.33-3]
libgbm1/unstable 24.0.2-1 amd64 [pouvant être mis à jour depuis : 23.3.5-1]
libglapi-mesa/unstable 24.0.2-1 amd64 [pouvant être mis à jour depuis : 23.3.5-1]
libglx-mesa0/unstable 24.0.2-1 amd64 [pouvant être mis à jour depuis : 23.3.5-1]
libgstreamer-plugins-bad1.0-0/unstable 1.24.0-1 amd64 [pouvant être mis à jour depuis : 1.22.10-1]
libgtk2.0-bin/unstable 2.24.33-4 amd64 [pouvant être mis à jour depuis : 2.24.33-3]
libmlt7/unstable 7.22.0-1+b2 amd64 [pouvant être mis à jour depuis : 7.22.0-1+b1]
libzvbi-common/unstable 0.2.42-2 all [pouvant être mis à jour depuis : 0.2.42-1.1]
xsane/unstable 0.999-12+b2 amd64 [pouvant être mis à jour depuis : 0.999-12+b1]
root@valhala:~# apt upgrade 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  asunder gimp gnome-themes-extra gstreamer1.0-plugins-bad gstreamer1.0-pulseaudio gtk2-engines-murrine gtk2-engines-pixbuf hardinfo libegl-mesa0 libgail-common
  libgbm1 libglapi-mesa libglx-mesa0 libgstreamer-plugins-bad1.0-0 libgtk2.0-bin libmlt7 libzvbi-common xsane
0 mis à jour, 0 nouvellement installés, 0 à enlever et 18 non mis à jour.

Quelle est la meilleure marche à suivre ?

  • Attendre la mise à jour des dépôts d’apt en espérant que la situation se règle d’elle même
  • Réinstaller les vieux paquets

D’avance merci :wink:

salut

n’a aucune raison valable d’apparaître

quels sont tes sources.list?
cat /etc/apt/sources.lis{t,t.d/*list}|egrep -v "^#"|egrep -v "^$"
que donne apt-cache policy gvfs-backends

solution éventuelle : faire
apt-get update

remarque
tu es en unstable, ce qui signie instable :slight_smile:

je n’ai pas d’unstable en route mais une trixie qui marche bien mais demande la version ```
vlc-plugin-base (= 3.0.20-1+b2)


https://wiki.debian.org/fr/DebianUnstable

Quelques règles utiles pour les utilisateurs de « testing » ou de Sid

-La chose la plus importante à ne pas oublier, est que l’on participe au développement de Debian quand on utilise « Testing » ou « Unstable ». Cela veut dire que l’on doit être familier de Linux, de Debian et du système de paquet de Debian et que l’on s’intéresse au repérage des bogues et à leur résolution. Il y a deux trois choses à savoir pour se faciliter la vie quand on utilise « Testing » ou Sid :

  • Considérez (en particulier lorsque vous utilisez « Unstable ») la possibilité de désactiver ou supprimer unattended-upgrades afin de contrôler le moment où les mises à jour des packages ont lieu.

  • Toujours être prudent pendant les mises à jour et vérifier si les actions proposées par les outils de gestion de paquets vont bien dans le sens que ce que vous souhaitez ou attendez (c’est-à-dire, par exemple, que vous n’allez pas retirer tout un tas de paquets dont vous avez besoin en acceptant, sans regarder, l’action proposée).
    Choisissez le bon moment pour mettre à niveau : lorsque vous avez le temps d’enquêter sur tout problème potentiel, et après avoir enregistré votre travail et effectué des sauvegardes - pas avant un voyage d’affaires !

  • Utiliser apt upgrade à la place de apt full-upgrade pour éviter toute suppression involontaire de paquets dont vous avez besoin.
    Si un paquet ne peut pas être mis à niveau de façon sûre, marquez-le « hold » en utilisant apt-mark.

  • Installer les paquets apt-listbugs et apt-listchanges pour être au courant des bogues les plus graves ou les changements importants quand vous installez de nouveaux paquets ou durant une mise à jour.

  • Utilisez un système de fichiers compatible avec la copie sur écriture (abrégé en COW) comme btrfs ou tirez parti des instantanés LVM. Prenez des instantanés avant et après une mise à niveau. Dans le cas, si le système est en situation irrécupérable, revenez au dernier instantané d’un LiveCD de secours du système. Un programme autant utile pour ceci que pour des sauvegardes régulières du système est timeshift.
    Créer automatiquement, chaque jour, chaque semaine et chaque mois des sauvegardes pour être sûr que des données corrompues ne soient pas un problème.

  • Garder en permanence sous la main un bon CD, DVD, clé USB Live tel que Debian Live pour pouvoir continuer à intervenir sur le système même s’il ne veut plus démarrer.

Bonjour et merci pour la réponse

Depuis plusieurs années sous SID, jamais eu de réels « gros » soucis. Les recommandations citées sont suivies

Pour les retours

⌚14:38:55 ▶ ragnarok@valhala ▷ ~
$  cat /etc/apt/sources.lis{t,t.d/*list}|egrep -v "^#"|egrep -v "^$"
cat: '/etc/apt/sources.list.d/*list': Aucun fichier ou dossier de ce type
deb http://deb.debian.org/debian/ sid main contrib non-free non-free-firmware 


⌚14:39:00 ▶ ragnarok@valhala ▷ ~
$ apt-cache policy gvfs-backends
gvfs-backends:
  Installé : (aucun)
  Candidat : 1.53.90-4
 Table de version :
     1.53.90-4 500
        500 http://deb.debian.org/debian sid/main amd64 Packages

L’update d’apt a bien sûr était une des choses réalisées en tout début (et relancé par la suite :wink:

Voilà :wink:

salut
dans le doc debian, ils disent de changer le mot stable( ou bokkworm ) par unstable :
ne devrais-tu pas avoir trois lignes de sources?

le policy te donne un backends instalalble, peux -tu l’installer en premier?

je m’en doutais, mais ça coute rien de le préciser ( comme de vérifier si un fil est branché quand on n’a pas d’internet )

Re ;),

sid ou unstable dans le source list ne change rien, je viens de tester

~# apt install gvfs-backends 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 gvfs-backends : Dépend: libcdio-cdda2t64 (>= 10.2+2.0.0) mais ne sera pas installé
                 Dépend: libcdio-paranoia2t64 (>= 10.2+2.0.0) mais ne sera pas installé
                 Dépend: libmtp9t64 (>= 1.1.21) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

A mon avis il faut attendre que les dépendances nécessaires soient disponibles, non ?

Bien sûr que si puisque bluefish/sid dépend de gvfs-backends=1.54.0-1

@crustyourmind
Probablement problème de syncho serveur deb.debian.
Essaie avec un serveur français qui fournit gvfs-backends/1.54.0-1

$ apt-cache madison gvfs-backends
gvfs-backends |   1.54.0-1 | http://ftp.fr.debian.org/debian unstable/main amd64 Packages
gvfs-backends |  1.53.90-2 | http://ftp.fr.debian.org/debian trixie/main amd64 Packages

$ apt show gvfs-backends 
Package: gvfs-backends
Version: 1.54.0-1

puis:

aptitude install libavahi-client3 libavahi-common-data libavahi-common3 gvfs-backends=1.54.0-1

Bonsoir et merci pour les retours

Ai modifié le repo

root@valhala:~# apt-cache madison gvfs-backends
gvfs-backends |   1.54.0-1 | http://ftp.fr.debian.org/debian unstable/main amd64 Packages

et

root@valhala:~# apt show gvfs-backends 
Package: gvfs-backends
Version: 1.54.0-1
Priority: optional
Section: gnome
Source: gvfs
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Installed-Size: 1 929 kB
Depends: gvfs (= 1.54.0-1), gvfs-common (= 1.54.0-1), gvfs-daemons (= 1.54.0-1), gvfs-libs (= 1.54.0-1), psmisc, dconf-gsettings-backend | gsettings-backend, libarchive13t64 (>= 3.0.4), libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libavahi-glib1 (>= 0.6.16), libc6 (>= 2.34), libcdio-cdda2t64 (>= 10.2+2.0.0), libcdio-paranoia2t64 (>= 10.2+2.0.0), libcdio19t64 (>= 2.1.0), libgcrypt20 (>= 1.10.0), libgdata22 (>= 0.18.0), libglib2.0-0t64 (>= 2.77.0), libgoa-1.0-0b (>= 3.17.1), libgphoto2-6t64 (>= 2.5.10), libgphoto2-port12t64 (>= 2.5.10), libgudev-1.0-0 (>= 147), libimobiledevice6 (>= 1.3.0), libmtp9t64 (>= 1.1.21), libnfs14 (>= 1.9.8), libplist3 (>= 2.2.0), libpolkit-gobject-1-0 (>= 0.101), libsmbclient0 (>= 2:4.12.0+dfsg), libsoup-3.0-0 (>= 3.0.3), libusb-1.0-0 (>= 2:1.0.21), libxml2 (>= 2.7.4)
Recommends: gnome-keyring
Suggests: bluez-obexd, pkexec, samba-common, wsdd
Homepage: https://wiki.gnome.org/Projects/gvfs
Tag: admin::file-distribution, admin::filesystem, implemented-in::c,
 interface::graphical, interface::x11, protocol::ftp, protocol::http,
 protocol::sftp, protocol::smb, protocol::webdav, role::plugin,
 role::program, suite::gnome, uitoolkit::gtk, x11::application
Download-Size: 356 kB
APT-Sources: http://ftp.fr.debian.org/debian unstable/main amd64 Packages
Description: système de fichiers virtuel en espace utilisateur – dorsaux
 Gvfs est un système de fichiers virtuel en espace utilisateur où les
 montages sont exécutés en tant que processus distincts auxquels on accède à
 l’aide de D-Bus. Il contient également un module gio qui permet à toutes
 les applications utilisant l’interface de programmation gio d'être
 compatibles sans problème avec gvfs. Il permet aussi de rendre disponibles
 les montages gvfs aux applications n'utilisant pas gio grâce à fuse.
 .
 Ce paquet fournit les dorsaux afc, afp, archive, cdda, dav, dnssd, ftp,
 gphoto2, http, mtp, network, sftp, smb, smb-browse et wsdd.

Par contre il se montre toujours récalcitrant

oot@valhala:~# aptitude install gvfs-backends 
Les NOUVEAUX paquets suivants vont être installés :     
  gvfs-backends{b} libgdata-common{a} libgdata22{a} libgoa-1.0-0b{a} libgoa-1.0-common{a} libnfs14{a} 
Les paquets suivants seront mis à jour : 
  gvfs gvfs-common gvfs-daemons gvfs-libs 
4 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 23 non mis à jour.
Il est nécessaire de télécharger 1 915 ko d'archives. Après dépaquetage, 5 954 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 gvfs-backends : Dépend: libcdio-cdda2t64 (>= 10.2+2.0.0) but it is not going to be installed
                 Dépend: libcdio-paranoia2t64 (>= 10.2+2.0.0) but it is not going to be installed
                 Dépend: libmtp9t64 (>= 1.1.21) but it is not installable
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     gvfs-backends [Non installé]    

Sinon j’attends que les autres paquets tombent dans le repo :wink:

Aptitude permet en simulant de proposer différents choix.
Tout n’est pas toujours liniéaire en sid, ce qui est ‹ normal › puisque ‹ unstable › !!

$ aptitude install gvfs-backends -s
.../...
Supprimer les paquets suivants :
1)      libarchive13 [3.7.2-1 (now, testing, unstable)]
2)      libcdio-cdda2 [10.2+2.0.1-1 (now, testing, unstable)]
3)      libcdio-paranoia2 [10.2+2.0.1-1 (now, testing, unstable)]
.../...
Installer les paquets suivants :
20)     glib-networking [2.80~alpha-1 (testing)]
21)     glib-networking-common [2.80~rc-1 (unstable)]
22)     glib-networking-services [2.80~alpha-1 (testing)]
23)     gvfs [1.54.0-1 (unstable)]
24)     gvfs-daemons [1.54.0-1 (unstable)]
25)     gvfs-libs [1.54.0-1 (unstable)]

Du sid c’est du sid qui a sa propre vie !!!

je pense que c’est ça

pour être sur il faudrait refaire le madison sur les paquets libcdio-cdda2t64 et suivants

bizarre:
http://ftp.debian.org/debian/pool/main/libm/libmtp/libmtp9t64_1.1.21-3.1_amd64.deb existe
peut-etre un

tu pourrais essayer aussi de les télécharger directement, puis dpkg -i

Bin finalement la solution de @Verner à savoir choisir la proposition alternative d’aptitude
Cela m’a donc remis gvfs-backends ce qui m’a permis de réinstaller vlc et bleufish

Un upgrade m’indique

root@valhala:~# apt upgrade 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  asunder gimp gnome-themes-extra gstreamer1.0-plugins-bad gstreamer1.0-pulseaudio gtk2-engines-murrine gtk2-engines-pixbuf
  hardinfo libegl-mesa0 libgail-common libgbm1 libglapi-mesa libglx-mesa0 libgstreamer-plugins-bad1.0-0 libgtk2.0-bin libmlt7
  libxatracker2 mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers xsane
0 mis à jour, 0 nouvellement installés, 0 à enlever et 21 non mis à jour.

Ensuite j’ai quelques paquets de « pinnés » car ils étaient buggés. Donc entre ça et le soucis que certains paquets ne sont peut être pas encore dispo… je vais patienter et voir avec le temps s’il retombe sur ses pattes (longtemps que ma sid n’avait pas galérée … mais ensuite c’est sans doute normal)

Merci pour vos interventions :wink:

Je tiendrais au courant de l’évolution de la situation :wink:
++