Sortie video manquante

Tags: #<Tag:0x00007f362623a858>

Bonjour,

J’ai changé de portable il y a quelques temps, et je désespère de faire marcher mes sorties vidéo, et je ne sais plus trop ou chercher.
le pc : un portable MSI gl75 9sd, portable optimus (intel/nvidia), sous bullseye

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630] (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)

le problème : impossible de connecter un écran en HDMI, et les sorties ne semblent pas être detectées

xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.05*+  60.01    59.97    59.96    48.02    59.93 

Par contre, j’ai bien 2 providers :

xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting
Provider 1: id: 0x249 cap: 0x2, Sink Output crtcs: 4 outputs: 3 associated providers: 0 name:NVIDIA-G0

J’avoue que je sèche complètement…
des idées, des pistes ?

Merci d’avance.

ben deja:

  • nvidia-detect
  • installation du pilote indiquée

on oublie le pilote nouveau qui n’est pas terrible.
personnellement j’utilise les pilotes backports

La réponse de Zargos n’est qu’un début. Ton portable est en effet équipé de la technologie Optimus.
Cela nécessite Bumblebee. Consulte ici pour plus ample détail:

https://wiki.debian.org/Bumblebee

Au risque de faire crier les puristes, je t’informe qu’il existe sur le site d’Ubuntu un tuto qui concerne justement ta machine. Bon d’accord!.. C’est du Ubuntu certes mais entre Ubuntu et Debian, y’a pas grande différence. Faut juste un peu adapter!..

https://forum.ubuntu-fr.org/viewtopic.php?id=2047543

Ou plutôt cela, puisque traduit dans notre langue :

Rien à voir avec le « purisme », ceci n’est qu’une manière déguisée de jeter l’anathème sur ce qui est recommandé de ne pas faire, ni + ni. En effet, l’équipe Debian recommande de ne pas « mélanger les genres », mais pour autant faut-il lire leur recommandation « FrankenDebian »
D’autant que suivre clairement le lien concernant le forum amènera son lot de problèmes, le plus important étant la gestion de la technologie Optimus. Et que s’il suit tel quel, il va au casse pipe.
Dans le cas d’Optimus, non il ne faut pas installer directement le pilote nvidia ; et deuxièmement, sous *Buntu, ils ont le binaire « prime » qui n’existe pas sous Debian.

ça, c’est votre avis, pas partagé. De l’intérêt de bien connaître vraiment le système pour vraiment bien recommandé quoi faire, et le faire pour que ce soit sans douleurs pour l’utilisateur. Merci d’y veiller !

Merci pour vos réponses.

Bumblebee ne permettait pas de résoudre le problème et je trouve un peu dommage de ne pas utiliser les outils codés dans le driver (prime render offload).

Mais en continuant mes fouilles, j’ai trouvé l’origine du problème : il faut un fichier Xorg avec ce matériel.

Section « Module »
Load « modesetting »
EndSection
Section « Device »
Identifier « nvidia »
Driver « nvidia »
BusID « PCI:01:00:0 »
Option « AllowEmptyInitialConfiguration »
EndSection

Suite à cet ajout, j’ai eu mes sorties video, mais plus d’écran (eDP). Pour le faire revenir, 2 commandes :

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Par contre, c’est à faire à chaque boot, donc un petit script Xsession et tout roule maintenant.
Encore merci pour les pistes.

(Et pour ubuntu, si il m’arrive de m’en servir pour trouver des pistes de réflexion, je préfère me baser sur des solutions estampillées debian. J’ai déjà flinguer un système comme ça…)

1 J'aime