Souci apt upgrade/install **Failed to check for processor microcode upgrades.**

apt
needrestart
Tags: #<Tag:0x00007fa92a3d5ab0> #<Tag:0x00007fa92a3d5948>

#1

Bonjour

quand je fait un apt upgrade ou install ,sur Debian 10 j’ai ce message

comment corrgier le souci est pourquoi il est la ? avais vous des idée Merci !!!

update-alternatives: utilisation de « /usr/bin/vim.basic » pour fournir « /usr/bin/ex » (ex) en mode automatique
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) …

**Scanning linux images… **

Running kernel seems to be up-to-date.

Failed to check for processor microcode upgrades.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.


#2

Je ne connais pas ce message. Mais si je devais deviner, je dirais qu’il provient du paquet needrestart qui vérifie si divers composants ont besoins d’être redémarrés suite à une mise à jour. Avec un processeur Intel la vérification du microcode a peut-être besoin du paquet iucode-tool, voire intel-microcode. Ces paquets sont-ils installés ?


#3

Salut
Ce sont des messages d’informations produit par le logiciel needrestart
https://packages.debian.org/fr/buster/needrestart

root@debian:~# /usr/sbin/needrestart
Scanning processes...                                                           
Scanning linux images...                                                        

Running kernel seems to be up-to-date.

Failed to check for processor microcode upgrades.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.
root@debian:~# 

Tu as du l’installer sans faire attention
Ce n’est pas indispensable , d’autant moins sur un PC qui est redémarré souvent
Si ça te gêne tu peux desinstaller

apt remove needrestart

#4

Bonjour

pourtant je reboot la machine j’ai toujours le même message
je ne c’est pas comment ce paquet est arriver la

je teste la des installation est je vous tien au jus

encore merci


#5

Evidemment. Il n’y a aucun raison pour qu’un redémarrage fasse disparaître ce message, et personne dans ce fil n’a prétendu le contraire.

Soit tu désinstalles le paquet qui affiche ces messages, needrestart (mais tu te prives de ses informations), soit tu installes le paquet nécessaire pour que needrestart puisse vérifier le microcode (iucode-tool ou intel-microcode). Le premier est dans la section contrib des dépôts, le second dans la section non-free.


#6

y a t-il un équivalent à iucode-tool pour AMD?


#7

Apparemment non, le paquet amd-microcode n’en contient pas et n’a pas de dépendence similaire.


#8

Bonjour

voila j’ai désinstaller le paquet j’ai plus le problème

encore merci