Soucis de compilation atril

compilation
Tags: #<Tag:0x00007f0944aae7a0>

#1

Bonsoir, bonjour…
Pour m’amuser, je me suis lancé dans la compilation de mate-desktop 1.21 sur une debian 9.
Le tutoriel sur le site de mate est un peu trop ancien (mate 1.12) et incomplet mais il m’a permis d’installer une bonne partie de cet environnement. J’ai un problème au moment de compiler atril. Voiçi le message d’erreur:

  CC       libatrilview_la-ev-form-field-accessible.lo
  CC       libatrilview_la-ev-image-accessible.lo
  CC       libatrilview_la-ev-jobs.lo
ev-jobs.c:882:34: error: unknown type name ‘WebKitWebView’
 web_thumbnail_get_screenshot_cb (WebKitWebView  *webview,
                                  ^~~~~~~~~~~~~
ev-jobs.c:883:34: error: unknown type name ‘WebKitLoadEvent’
                                  WebKitLoadEvent event,
                                  ^~~~~~~~~~~~~~~
ev-jobs.c:899:25: error: unknown type name ‘WebKitWebView’
 webview_load_failed_cb (WebKitWebView  *webview,
                         ^~~~~~~~~~~~~
ev-jobs.c:900:25: error: unknown type name ‘WebKitLoadEvent’
                         WebKitLoadEvent event,
                         ^~~~~~~~~~~~~~~
Makefile:734 : la recette pour la cible « libatrilview_la-ev-jobs.lo » a échouée
make[3]: *** [libatrilview_la-ev-jobs.lo] Erreur 1
make[3] : on quitte le répertoire « /home/cyril/environment/atril-1.21.0/libview »
Makefile:584 : la recette pour la cible « all » a échouée
make[2]: *** [all] Erreur 2
make[2] : on quitte le répertoire « /home/cyril/environment/atril-1.21.0/libview »
Makefile:668 : la recette pour la cible « all-recursive » a échouée
make[1]: *** [all-recursive] Erreur 1
make[1] : on quitte le répertoire « /home/cyril/environment/atril-1.21.0 »
Makefile:554 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2

Pour info:
j’ai recherché des paquets webkit, libwebkit, les paquest dev, je les ai installé mais j’ai toujours
ce même message d’érreur
c’est une vm :slight_smile:
je débute en compilation, voici ce dont je me suis servis pour me documenter:
https://doc.ubuntu-fr.org/tutoriel/compilation
le site mate-desktop pour le tutoriel


#2

Et tu as essayé en installant bien libwebkit2gtk-4.0-dev ?


#3

Bonjour mattotop,
effectivement, celui-là, je ne l’ai pas installé et ça a fonctionné.
J’avais essayé en installant libwebkitgtk-dev, libwebkitgtk-3.0-dev, libwebkit-cil-dev. Mais je suis passé à côté de celui qu’il fallait.
Merci beaucoup!