Souris bluetooth


#1

Bonjour,
Je viens récemment d’acheter une souris bluetooth, mais j’ai quelques soucis avec.
Le curseur “lag” vraiment beaucoup, c’est presque inutilisable (j’ai tester la souris sur mac et un autre Linux Mint ca fonctionne sans problème), et parfois après un reboot je dois la pairer de nouveau. J’ai un dongle usb ASUS BT400 et je suis sous Debian Buster.

Si quelqu’un a une solution, Merci bien.


#2

Accessoirement, quelle carte graphique ?

Tu as essayé d’installer le noyau de ta mint sur ta buster (avecle .deb et gdebi) ou un autre pour voir si ça ne serait pas mieux ?


#3

carte graphique GeForce GTX 980 Ti.
J’ai pas tester d’autre kernels, la Mint est encore en 4.15 alors que Buster en 4.19, je testerais un downgrade pour voir.


#4

Si tu es avec le pilote nouveau et pas le propriétaire, ça pourrait venir de là.

Tu peux aussi t’amuser à compiler un noyau custom plus récent juste pour voir: ma buster est en noyau 5.0 (le 5.2, ne passait pas la compil).


#5

J’utilise le driver proprio.
Ouais pourquoi pas, je vais en tester plusieurs jusqu’a un qui marche, si j’en trouve ^^


#6

J’ai dit ça parce qu’il y a parfois des saccades souris avec certaines configuration de serveur X, mais pour nvidia, c’est plus souvent le X nouveau qui fait ce genre de saccades.
Si tu n’as pas de soucis avec une souris usb, ça doit être que ça n’a rien à voir et qu’il faut chercher du coté de l’usb je pense.


#7

ouais j’ai une seconde souris filaire usb, elle marche nickel. Je vais installer le kernel 5.2 des backports, on verra, mais je risque d’avoir d’autres problemes (les guest additions de virtualbox compile pas), bref je verrais


#8

Je crois que c’est pour ça que j’avais renoncé au 5.2 pour rester en 5.0.


#9

bon meme sur le kernel 5.2 ca ne change rienm et le 4.15 n’est dans les depots :confused:
C’est poossible que ce soit le recepteur qui lag? C’est du bluetooth 4.0, mais bon, c’est qu’une souris


#10

Vah non:

Maintenant, te dire d’où ça peut bien venir…
Tu as épluché kernel.log et syslog pour voir si tu as des warnings/erreurs qui pourraient parler du probléme ?


#11

J’ai juste ce message dans syslog qui apparait quand je connecte la souris

Bluetooth: hci0: advertising data len corrected

Ca aide beaucoup


#12

:rofl:
Bon, en cherchant sur “debian bluetooth mouse lag” j’ai vu parler pas mal d’une mauvaise interaction entre bt et iwlwifi.
C’est pas forcément sous debian que j’ai vu des trucs, mais si tu utilises iwlwifi pour ta connection, ça mérite un test, avec la solution proposée là, il me semble:


#13

ok, mais j’utilise pas iwlwifi le package firmware-iwlwifi n’est même pas installer.


#14

Un peu plus…