Souris non detectee sur PS/2


#1

Bonjour a tous 8)
ma souris depuis le debut n’est pas detectee sur le port PS/2 :frowning:
elle marche trés bien sur un port USB
mais voila j’ai du monde sur USB et je voudrais libérer celui occupe par la souris

Quelqu’un ou quelq’une peut m’aider ? Merci

quelques infos de mon PC
medtect
/dev/psaux
intellimouse

lsmod
mousedev (pas dans etc/modules)
psmouse (dans etc/mouse) :frowning:

cat /dev/input/mice
reponse quand la souris ets sur USB
rien du tout quand la souris est sur PS/2


#2

d’aprés ce que je crois comprendre de tes messages, elle est bien détectée, simplement, il faut reconfigurer X pour prendre son entrée souris sur /dev/psaux quand elle est sur le ps2 et /dev/input/mice quand elle est en usb.
Tu peux faire ça avec’dpkg-reconfigure xserver-xorg’ (si tu es en xorg, sinon, c’est xserver-xfree86).
Tu peux aussi éditer /etc/X11/xorg.conf (respectivement XF86config-4) à la main.
dans ce cas, un ‘man 4x mouse’ devrait t’être utile.


#3

[quote=“MattOTop”]
dans ce cas, un ‘man 4x mouse’ devrait t’être utile.[/quote]

je ne comprends pas grand chose a l’anglais

Question peut-etre un peu bete :
la souris en console est-elle aussi geree par xorg ?


#4

j’ai fait un dpkg-reconfigure xorg

dans /etc/X11/xorg.conf
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

apres un reboot
ma souris n’est toujours pas detectee sur PS/2
ma souris marche tres bien sur USB

message a l’ouverture de KDE
could not start kdeinit check your installation

:question: :question: :question:


#5

et tu as bien sûr ETEIND ta machine pour brancher ta souris en PS2 ?


#6

rien a faire
1ere manip : un reboot
2eme manip : j’ai éteint

:question: :question: :question:


#7

[quote]et tu as bien sûr ETEIND ta machine [/quote] :laughing: :laughing: :laughing:
moi, j’aurais écrit “éteindu” pour faire encore mieux :wink:


#8

c’est la même souris avec un adaptateur sur le PS2 ? tu es sûr de ton adaptateur ?
cat /dev/psaux donne bien ce que tu veux quand tu es en PS2 ?

personnellement, j’ai une habitude qui me permet d’avoir la souris en console aussi, c’est d’installer gpm avec deux souris et ça donnerait chez toi à priori qqchose comme:

[quote="/etc/gpm.conf"]# /etc/gpm.conf - configuration file for gpm(1)

If mouse response seems to be to slow, try using

responsiveness=15. append can contain any random arguments to be

appended to the commandline.

If you edit this file by hand, please be aware it is sourced by

/etc/init.d/gpm and thus all shell meta characters must be

protected from evaluation (i.e. by quoting them).

This file is used by /etc/init.d/gpm and can be modified by

“dpkg-reconfigure gpm” or by hand at your option.

device=/dev/input/mice
responsiveness=
repeat_type=ms3
type=autops2
append=’-M -m /dev/psaux -t autops2’
sample_rate=
[/quote]

Aprés, tu prends ta souris X sur /dev/gpmdata de type ps2, et c’est gpm qui s’occupe de tout injecter dans /dev/gpmdata.


#9

j’ai essaye d’installer gpm
la souris marche plus ou moins bien sur une console
mais pas en PS/2

cat /dev/psaux ne donne jamais rien

j’essaie d’eteindre et de redemarer
puis de voir dmesg

j’ai l’impression qu’il y a un probleme en amont de xorg

NOTA : sous windob, la souris fonctionne sur PS/2, je ne pense pas que cela vienne d’un pb hard


#10

essayes quand même un ‘dpkg-reconfigure gpm’, en console avec le ps2 branché, pour voir.


#11

galere mais j’ai fait la manip

j’ai eteint
j’ai brancher la souris sur PS/2
j’ai configure xserver-xorg et gpm
j’ai essaye avec kde et en console rien a faire :imp:

ce qui est pls etonnant c’est ce qui suit :
j’ai eteint
j’ai brancher la souris sur usb
JE N’AI PAS CHANGE LA CONFIGURATION de xserver-xorg et gpm
CELA MARCHE A RAVIR :imp: :question: :question: :question:

(remarque avec Knoppix 3-9 idem)


#12

je soupçonne fort le plug’n’play (udev, hotplug) de connecter la souris usb à chaud sur le serveur X, evitant la necessité de configurer quoi que ce soit dans le cas de l’USB.
Autre possibilité, et qui explique aussi peut être pourquoi rien ne change quand tu fais ton ‘dpkg-reconfigure’. fais les choses suivantes:
md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
dpkg-reconfigure xserver-xorg
en prenant bien /dev/psaux comme entrée de souris (je sais, tu l’as déjà fait).
puis extinction, reallumage avec le PS2 branché.
Si ça ne marche pas, vraiment, je ne vois pas. Le PS2, normalement, ça marche, point.


#13

[quote=“MattOTop”]
md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
dpkg-reconfigure xserver-xorg
en prenant bien /dev/psaux comme entrée de souris (je sais, tu l’as déjà fait).
puis extinction, reallumage avec le PS2 branché.[/quote]

:frowning: :frowning: rien a faire
reponse de md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
le fichier existe
QUE FAIRE :question: :question:
maintenant j’ai un probleme de plus quand je lance kde :
j’ai une fenetre ridicule qui s’affiche avec le message :
could not start kdeinit check your install

je clique dessus et ca demarre :question: :question:


#14

fais ça en root, ça ira mieux…


#15

bien sur je l’ai fait en root


#16

j’ai supprime /var/lib/xfree86/xorg.conf.md5sum

puis j’ai fait un md5sum

il m’a cree le meme fichier avec la meme cle


#17

bon, maintenant, la reconfiguration de X sur le ps2, qu’est ce que ca donne ?
sinon, pour ton md5sum, quand je dis fais le en tant que root, je dis bien, fais le en tant que root :laughing: , pour une fois, pas avec sudo, car si tu executes bien le md5sum en tant que root, la redirectin du md5sum, elle est executée en tant qu’user, ce qui t’interdit l’accés au fichier. Tu vois ce que je veux dire, je veux dire ?


#18

pas de soucis root c’est root et ce n’est pas sudo
je connaissais la difference

donc ca coince encore.

moi je pense que cela vient d’un driver, non :question:


#19

Un truc idiot, mais as tu chargé le module psmouse?

modprobe psmouse


#20

lsmod
reponse psmouse

je suppose donc qu’il est charge