Srv Samba


#1

Salut !!!

Après quelque temps d’absence me revoilà !! :wink:

Je suis entrain de configurer un serveur SAMBA en tant que PDC avec le fichier de conf suivant :

[code][global]

le nom du domaine

workgroup = pti.loc

le nom “netbios” du serveur (nom que Windows va lire

dans son voisinage réseau )

netbios name = srv-samba

descriptif de la machine (vu dans l’info-bulle)

server string = PDC Samba - PTI.LOC

sécurisation de l’acces au serveur samba

hosts allow = 127.0.0.1
hosts allow = 192.168.1.

cryptage de mot passe pour la compatibilité avec Windows

encrypt passwords = Yes

synchronisation des mot de passe samba avec les mots de passe unix

unix password sync = no

passwd program = /usr/bin/passwd %u

passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*

table de conversion nom windows -> nom unix (ex: administrateur ->root)

username map = /etc/samba/smbusers

création de log par utilisateur

log file = /var/log/samba/log.%m
max log size = 50

ordre de résolution des noms NETBIOS

name resolve order = wins host lmhosts bcast

pour pouvoir synchroniser l’horloge des clients sur celle du serveur

time server = yes

definition du groupe administrateurs

admin users = root

active la fonction contrôleur de domaine au serveur Samba

domain logons = Yes

Déclaration de l’interface d’écoute pour samba

interfaces = 192.168.1.1/24

Priorité du serveur

# définit le niveau de compétence du serveur dans l’élection sur serveur primaire

os level = 95

# élection de serveurs primaires au démarrage

preferred master = True

# désigne le serveur samba comme serveur de domaine

domain master = True

# ne demande pas à Samba d’utiliser la fonction nslookups pour la résolution des noms NetBIOS

dns proxy = No

pour que le serveur samba soit aussi serveur WINS

càd résolve les noms NETBIOS grâce au demon nmbd

wins support = Yes

Définit le script qui sera exécuté sur le client

logon script = %U%U.bat

Utilisé par Windows NT pour stocker le profil utilisateur (ntuser.dat, etc)

logon path = \%L\profiles%U

Chemin réseau du répertoire personnel

logon home = \%L%U

Définit, sous NT, le lecteur de connection au répertoire personnel

logon drive = P:

désactive la préservation de la casse des caractères

preserve case = no

conversion des caractères Windows à Unix et Vice-versa

pour la prise en compte des caractères accentués

dos charset = 850
unix charset = ISO8859-1

fichier de correspondance des nom Unix avec les noms Windows

username map = /etc/samba/smbusers

[netlogon]
comment = Repertoires scripts
path = /opt/samba/netlogon
browseable = No

[profiles]
comment = Homes windows
path = /opt/samba/profiles
browseable = No
read only = No

[homes]
comment = Répertoires personnels
path = /home/%U
browseable = No
read only = No

[share]
comment = Répertoire partagé
path = /opt/samba/share
browseable = no
public = yes
writable = yes
valid users = @smb root[/code]

Lorsque je fais un testparm j’obtiens :

[quote]Load smb config files from /etc/samba/smb.conf
Unknown parameter encountered: "domain admin group"
Ignoring unknown parameter "domain admin group"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[homes]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC[/quote]

J’ai beau chercher, je ne trouve pas de sujet qui traite sur ‘domain admin group’…

Quelqu’un a-t-il un tuyau ?
Merci d’avance !!!


#2

Il ne reconnait pas ce que tu as dit dans

Je n’y connais rien mais,
Es tu sure que c’est la bonne façon de déclarer le “groupe des admins du domaine” en écrivant : “@root” ?
Si oui, ce groupe a t’il été créé ?


#3

Normalement, j’ai mis :

pour l’utilisateur root et j’ai aussi ce message d’erreur… Et l’utilisateur root est belle et bien créé…

Mais j’ai plus l’impression qu’il ne reconnaît pas le paramètre donné… non ?


#4

Pour moi le message d’erreur veut dire que samba ne reconnait pas l’option “domain admin group”… Utilisez vous la bonne version de samba ?

D’ou sortez vous ce paramètre ? Avez vous regardé smb.conf(5) (man 5 samba)

Cdlt,


#5

hum… tu es certain d’avoir cherché ??

gcolpart.com/howto/samba.php4 , eux ne mettent pas de @ devant root, tu as essayé sans le @ ?


#6

c’est “admin users = @root” que vous cherchez ?


#7

[quote=“ed”]Pour moi le message d’erreur veut dire que samba ne reconnait pas l’option “domain admin group”… Utilisez vous la bonne version de samba ?

D’ou sortez vous ce paramètre ? Avez vous regardé smb.conf(5) (man 5 samba)

Cdlt,[/quote]

Justement, j’ai fait un tour sur le man également et c’est pour ça que j’ai posté mon message… car…

hum… tu es certain d’avoir cherché ??

gcolpart.com/howto/samba.php4 , eux ne mettent pas de @ devant root, tu as essayé sans le @ ?[/quote]

…c’est sur le site gcolpart que j’ai chopé l’astuce.

Mais mon sauveur est arrivé !!! :laughing:
Je regarde “admin users” dès ce soir !!


#8

Bon, j’ai pas pu tester hier soir j’étais au concert de Souchon !! Excellent !!

Revenons à nos moutons, vous m’arrêtez si je me trompe…

Exemple :
[ul]admin users = root[/ul]
Est utilisé dans un partage pour spécifier qui est administrateur du dossier ?

Ce que je cherche c’est spécifier les comptes administrateurs du domaine…


#9

P’tite question : est-ce normal lorsque je me logg en tant que root sur le client en Win2k, il n’a pas les droits admins ?

Faut-il créer un script attribuant les droits à chaque utilisateur qui se connecte ?

J’ai mis à jour mon fichier smb.conf.


#10

Est-ce que l’option add group script de smb.conf peut nous aider à gérer les groupes des utilisateurs qui se connectent ?


#11

J’AI TROUVÉ !!!

mdr, je fais les questions/réponses sur mon topic… y doit pas y avoir grand monde…

En fait, samba récupère la liste des groupe de windows (net group -l) et on peut faire correspondre les groupes unix avec les ntgroup (net groupmap list donne la correspondance). Pour modifier une des correspondances il suffit d’utiliser la ligne suivante : net groupmap modify ntgroup=“nom du group NT” unixgroup=nom du groupe UNIX.

Voilà !! Mon PTI Samba est bouclé !!


#12

[quote=“Badaboumpanpan”]J’AI TROUVÉ !!!

mdr, je fais les questions/réponses sur mon topic… y doit pas y avoir grand monde…

En fait, samba récupère la liste des groupe de windows (net group -l) et on peut faire correspondre les groupes unix avec les ntgroup (net groupmap list donne la correspondance). Pour modifier une des correspondances il suffit d’utiliser la ligne suivante : net groupmap modify ntgroup=“nom du group NT” unixgroup=nom du groupe UNIX.

Voilà !! Mon PTI Samba est bouclé !![/quote]Si si il y a du monde mais pour la plupart on ne connais pas les réponses donc je ne fait que lire :slightly_smiling:


#13

:cry:

Je ne comprends pas… plus rien ne fonctionne…
J’arrive à intégrer mes postes clients au domaine mais ensuite je ne peux pas me logger…

[quote]Le système ne peut pas ouvrir de session en raison de l’erreur suivante :

Un périphérique attaché au système ne fonctionne pas correctement.[/quote]

PKOI !!! :cry:
Tout fonctionnait jusqu’à présent…


#14

Voici le log du poste quand il ouvre une session :

[2006/03/05 12:01:11, 1] rpc_server/srv_netlog_nt.c:_net_sam_logon(766) _net_sam_logon: user PTI.LOC\root has user sid S-1-5-21-1743034245-362487719-1546282423-1000 but group sid S-1-5-32-544.

Je peux ouvrir une session si j’enlève les correspondance de groupe… Je ne comprends plus…