Système blqoué (Xorg en état D)


#1

Bonjour à tous,
Je continue avec mon pb de disque? (voir mon précéndent post [Pb (matériel ?) lors d'une installation de Debian 9]
En résumé, j’ai un PC “A” avec un installation neuve de Debian 9 réalisée sur un PC “B” car impossible à faire sur PC “A”
Après login sous gnome, le PC se bloque (plus de souris, plus de clavier), je vois seulement le top suivant lancé à distance.

top - 07:44:02 up  2:28,  4 users,  load average: 94,00, 93,96, 93,41
Tasks: 175 total,   1 running, 165 sleeping,   0 stopped,   9 zombie
%Cpu(s):  0,0 us,  1,0 sy,  0,0 ni,  0,0 id, 99,0 wa,  0,0 hi,  0,0 si,  0,0 st
KiB Mem :   890440 total,   211120 free,   382384 used,   296936 buff/cache
KiB Swap:   975868 total,   975868 free,        0 used.   368084 avail Mem 

  PID PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND               
  690 20   0  101444   3764   2768 S  0,0  0,4   0:08.28 sshd                  
  691 20   0   19892   3424   3044 S  0,0  0,4   0:00.01 bash                                  
 1190 20   0  321044  38172  27364 D  0,0  4,3   0:01.53 Xorg                  
 1281 20   0   11092    332      0 D  0,0  0,0   0:00.00 ssh-agent             
 1299 20   0  639156  14104  11932 D  0,0  1,6   0:00.18 gnome-session-b       
 1379 20   0       0      0      0 Z  0,0  0,0   0:11.88 gnome-shell

Le problème semble venir de Xorg/du disque?, mais je n’ai aucune info supplémentaire car si je sors de top je n’ai plus la main et je ne vois rien dans syslog avant de perdre la main.


#2

J’ai désormais de temps en temps le boot qui se fige sur une erreur disque, y a donc plus photo, le pb vient du disque.
Est-ce qu’un reformatage complet pourrait résoudre le pb? Sais pas, je n’ai jamais eu ce cas de figure. Je ferai l’essai plus tard, car pour l’instant le PC, même partiellement défectueux, est prêté, pour au moins un mois.