Système de fichier crypté, pas de demande du mot de passe [bug de Buster pas résolu au 12/05/19]

mot-de-passe
Tags: #<Tag:0x00007fa931950d58>

#1

J’ai installé debian buster avec l’installateur classique car le programme graphique m’a laissé avec un système imboutable.

Dans le grand fatras que laisse une installation de Win 10 sur une machine du commerce, j’ai créé une partition /boot de 900 Meg, un espace LVM de 400 giga sur lequel est installé un système ext4 crypté.
Au démarrage, le mot de passe ne m’est pas demandé et bien évidemment le démarrage échoue « Failed to find logical volume ».
L e module cryptd est bien chargé.
Des idées ?


#2

Salut

Il faut revoir les bases LVM, volume logique crypté et amorçage /boot séparé.
Tu dois pouvoir faire quelque chose avec les options de Grub.
Est-ce que ton /etc/fstab utilise les UUID ou LABEL ?
Je ne sais pas te dire mieux.

Ça te fait un petit up :wink:


#3

En fait, c’est un bug connu et non corrigé de l’installateur. Il faut modifier à la main grub.cfg, et ce, à chaque fois que le noyau est modifié. C’est une machine pour le boulot, je n’ai pas envie d’arriver au taf et de ne pas pouvoir m’en servir parce que j’aurai pas vu que la mise à jour concernait le noyau. —> (hélas, trois fois hélas) réinstallation de Lubuntu 18.10.


#5

Bug en cours : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917117


#6

As-tu chiffré le volume physique LVM (méthode classique) ou le volume logique contenant la racine ?

Quel bug ? Que faut-il modifier dans grub.cfg ?
S’il s’agit d’un ajout, cela peut être automatisable avec un script dans /etc/grub.d/.
D’autre part, si c’était seulement un bug de l’installateur, il ne serait pas nécessaire de la corriger à chaque fois que grub.cfg est reconstruit. Il suffirait de le faire une fois après l’installation.

Je ne vois pas le rapport entre ton problème et ce bug, qui est par ailleurs marqué comme corrigé depuis janvier. D’autre part il ne concerne que la version signée de GRUB, donc si le secure boot n’est pas activé dans les options UEFI (ce qui doit être le cas car incompatible avec les précédentes versions de Debian), tu peux juste la désinstaller et démarrer avec la version no signée de GRUB.


#7

Bonjour et merci de ton intervention.

Effectivement, j’ai lu trop vite. Ce n’est pas le même bug.

As-tu chiffré le volume physique LVM (méthode classique) ou le volume logique contenant la racine ?

La deuxième solution.
Par ailleurs, j’utilise le secure boot qui marche nickel sous (L)ubuntu (ça m’arrache les touches de le taper, mais c’est ainsi)
J’ai perdu une quinzaine d’heures sur ce truc le WE dernier à faire plusieurs installations en faisant varier quelques paramètres. Je ne m’y remettrai pas avant la sortie définitive de Buster (qui marche comme un charme sur le Ryzen de mon épouse), d’autant plus qu’utilisant exclusivement XMonad, je ne vois pas trop la différence au quotidien entre Debian et Ubuntu.
Bonne journée,


#8

Pour quelle raison ?
As-tu déjà appliqué cette configuration avec une version précédente de Debian ?


#9

Je vais répondre dans l’ordre inverse : c’est comme ça que ça marche sur mon ordinateur fixe en debian 8 puis 9. Pourquoi changer ?

Tu es probablement plus pointu que moi, mais je ne vois pas en quoi l’une ou l’autre des possibilités change grand-chose au processus de démarrage et en particulier aux modules à charger.


#10

A cause de l’ordre dans lequel sont exécutés les scripts d’initialisation des volumes logiques LVM et des volumes chiffrés.