Touches rescapées après un apt-get dist-upgrade ez_" $


#1

Bon, j’avais commencé ce post dans un autre existant et pour ne pas polluer d’avantage le post de Korben, je reprends ici:

Hier, j’ai lancé un apt-get dist-upgrade sur ma Sid/unstable.
Résultat: la console en ligne de commande fonctionne correctement.
Par contre startx me lance sur une inteface X ou il n’y a que la souris qui court encore…
Au clavier, il ne me reste que les touches suivantes: ez_" $ y , . et le pavé numérique …
Rien de plus ! :imp:

J’ai essayé pas mal de trucs:
dpkg-reconfigure locales
dpkg-reconfigure console-data
dpkg-reconfigure xserver-xorg
dpkg-reconfigure --pendings
dpkg-reconfigure -a

Bref, là je commence à sécher… Une idée, avant que je me fâche et que je repasse définitivement en stable ?

PS: Ricardo m’a l’air tout désigné pour cette périlleuse mission :wink:


#2

tu as testé avec deux claviers différents ?
sinon, je te signale qu’un administrateur peut séparer un fil en deux :wink:


#3

[quote=“MattOTop”]tu as testé avec deux claviers différents ?
sinon, je te signale qu’un administrateur peut séparer un fil en deux :wink:[/quote]
Avec un clavier différent … :blush: Je n’y avait même pas pensé … :blush:
Je viens de faire le test et ca ne change rien. Mais bon, à priori si mon clavier fonctionne en console texte et pas sous X, logiquement ca ne devrait pas être un problème du clavier lui-même.

Séparer le fil en deux ? c’est dans les options ? Jamais vu, il faudra que je regarde ça en détail…


#4

C’est le petit bouton en bas à gauche qui ressemble à un symbole de pause.
Sinon, pour ton clavier… Pas d’autre idée.
Tu es en clavier suisse ?
Tu as essayé de changer de windows manager pour être sûr que ça vient de X ?


#5

Oui, je suis en clavier suisse-romand.
J’ai essayé KDE et GNOME, même merde sur les 2… :cry:


#6

et config de xorg en clavier “fr” ?

Tu as bien les xfonts-100dpi-transcoded ainsi que les 75dpi ?
avec MAJ/verrNum, tu peux déplacer le curseur avec le pavé numérique ?

console-tools est bien installé ?


#7

[quote=“ricardo”]et config de xorg en clavier “fr” ?

Tu as bien les xfonts-100dpi-transcoded ainsi que les 75dpi ?
avec MAJ/verrNum, tu peux déplacer le curseur avec le pavé numérique ?

console-tools est bien installé ?[/quote]

Salut Ricardo,
Merci pour tes suggestions, ca re-fonctionne ä peu près …
C’est quand même bizarre cette histoire:

[quote]luciole:~# grep fr /etc/X11/xorg.conf

values from the debconf database.

    #Option         "XkbLayout"     "fr_CH"
    Option          "XkbLayout"     "fr"

luciole:~#[/quote]
1.J’ai pu me logguer avec kdm en mettant clavier français.
2. Bien sûr, quand je suis logguè, je vais dans le centre de config. de KDE pour retrouver mon clavier suisse-romant

Donc, j’ai un mode texte pur en swiss-french, un login manager en clavier français et un Kde en swiss-french…
Et bien sûr, si j’essaye de corriger mon xorg.conf pour remettre "fr_CH, après avoir corrigé dans KDE, je n’ai plus de clavier au prochain re-démarrage de X…

C’est ok pour moi, pour le moment, en attendant que le bug soit corrigé …
Mais bon, qui sait, ils ont peut-ètre décidé de ne plus accepter les suisses sous Debian ? :cry:

Sinon, pour les packages, c’est ok:

luciole:~# dpkg -l console-tools | grep ii ii console-tools 0.2.3dbs-60 Linux console and font utilities luciole:~# dpkg -l xfonts-100dpi-transcoded | grep ii ii xfonts-100dpi-transcoded 1.0.0-2 100 dpi fonts for X (transcoded from ISO 10646-1) luciole:~# dpkg -l xfonts-75dpi-transcoded | grep ii ii xfonts-75dpi-transcoded 1.0.0-2 75 dpi fonts for X (transcoded from ISO 10646-1) luciole:~# dpkg -l console-tools | grep ii ii console-tools 0.2.3dbs-60 Linux console and font utilities luciole:~#

Merci encore pour ton aide ! :wink:


#8

Mais grmblmlmmmm… J’ai plus aucun accent en lisant mes man pages maintenant :

[quote] Vous devez �tre conscient des cons�quences si vous d�sactivez enti�rement la v�rification d�pen-
dante du compteur de montage. Des disques, c�bles, m�moires d�fectueux ou des bogues du noyau peu-
vent corrompre un syst�me de fichiers sans que celui-ci ne soit marqu� comme � sale � ou
� erron� �. Si vous utilisez la journalisation sur votre syst�me de fichier, votre syst�me de
fichiers ne sera jamais marqu� comme sale, et donc ne sera pas v�rifi� normalement. Une erreur de
syst�me de fichier d�tect�e par le noyau peut encore forcer un fsck lors du prochain red�marrage,
mais il sera peut �tre d�j� trop tard � ce moment l� pour pr�venir la perte de donn�es.

          Voir aussi l'option -i pour les v�rifications fonctions du temps �coul�.

[/quote]

:imp: :imp: :imp:


#9

Va voir ds
/etc/profile
et chnage les avant-dernières lignes, justa avnt
umask022
comme yu as changé ton clavier en FR, il me semble qu’il faut aussi modifier là
le mien :

[code]LC_ALL=fr_FR
LANG=french

export LC_ALL LANG
umask 022[/code]

PS :
as-tu pensé à changé le
kde-i18n-ro
par le
kde-i18n-fr

PS2 :
regarde aussi avec les paquets
belocs-locales-bin
belocs-locales-data


#10

Alors Jabba, t’en es où ?


#11

Désolé de n’avoir pas répondu plus tôt, hier j’étais trop occupé au boulot à déconner sur le forum et accessoirement à bosser un peu :laughing:

Bon, alors j’ai modifié .profile et maintenant c’est ok pour les man pages.
Mais décidément, je n’y comprendrais jamais rien dans la gestion de ces saletés de locales…

Si je lance man pour de l’aide:

[code]TUNE2FS(8) TUNE2FS(8)

NAME
tune2fs - adjust tunable filesystem parameters on ext2/ext3 filesystems

SYNOPSIS
tune2fs [ -l ] [ -c max-mount-counts ] [ -e errors-behavior ] [ -f ] [ -i interval-between-checks ] [ -j ] [ -J journal-
options ] [ -m reserved-blocks-percentage ] [ -o [^]mount-options[,…] ] [ -r reserved-blocks-count ] [ -s sparse-super-
flag ] [ -u user ] [ -g group ] [ -C mount-count ] [ -L volume-name ] [ -M last-mounted-directory ] [ -O [^]feature[,…] ]
[ -T time-last-checked ] [ -U UUID ] device

DESCRIPTION
tune2fs allows the system administrator to adjust various tunable filesystem parameters on Linux ext2/ext3 filesystems.[/code]
On constate que tout s’affiche correctement. Super !
Mais regarde quand je quitte la man page:

bej@luciole:~$ man tune2fs man: can't set the locale; make sure $LC_* and $LANG are correct Reformatting tune2fs(8), please wait... bej@luciole:~$
Si j’affiche ma configuration de locales:

bej@luciole:~$ locale locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory LANG=fr_CH@euro LANGUAGE=fr_CH:fr_FR:fr:en_GB:en LC_CTYPE="fr_FR" LC_NUMERIC="fr_FR" LC_TIME="fr_FR" LC_COLLATE="fr_FR" LC_MONETARY="fr_FR" LC_MESSAGES="fr_FR" LC_PAPER="fr_FR" LC_NAME="fr_FR" LC_ADDRESS="fr_FR" LC_TELEPHONE="fr_FR" LC_MEASUREMENT="fr_FR" LC_IDENTIFICATION="fr_FR" LC_ALL=fr_FR bej@luciole:~$
Et pourtant, mes man pages s’affichent maintenant correctement !
Bref, comment remettre toute cette merde au carré ?
Je précise que j’ai eu le même souci le jour ou par curiosité, j’ai voulu mettre une locale autre que english US, sur un de mes serveurs Solaris, au boulot. Donc il semblerait que la gestion des locales soie une galére sur TOUS les Unix/Linux… :open_mouth:
Ricardo, tu nous fais un petit tuto dans le forum T&A concernant la gestion des locales ? :smt100


#12

Ca serait bien, parceque moi non plus je n’ai jamais rien compris :mrgreen:


#13

On vooote tous pour Ricardo, Ricaaaaardoooo ! :smt035 :laughing:


#14

+1 :smt056 Ricardo un tuto :smt026


#15

Ricardo, tu fais le mort ? :smt043
On attends nous :smt005


#16

Saches bien que où que tu te caches, nous te retrouverons … :smt031


#17

Je ne me cache pas mais il fait trop beau en ce moment pour être devant un écran.
Je ferais bien un petit tuto sur les locales mais encore faudrait-il que Jabba soit dépanné complètement.
On verra ça plus tard.

PS :
Jabba, j’aimerais bien voir ton
/etc/profile
en entier


#18

[quote=“ricardo”]Je ne me cache pas mais il fait trop beau en ce moment pour être devant un écran.
Je ferais bien un petit tuto sur les locales mais encore faudrait-il que Jabba soit dépanné complètement.
On verra ça plus tard.

PS :
Jabba, j’aimerais bien voir ton
/etc/profile
en entier[/quote]
Merci Ricardo, mais il semble que mon problème soit dû à un bug dans la gestion des locales. Avec ton aide j’ai pû temporairement contourner le problème. Donc je vais attendre les prochaines mises à jour de la testing pour voir si le bug est résolu…
Dans quelques temps, si le problème ne se résout pas de lui-même, j’enverrais un mail au BTS.
Donc … Pour en revenir à ton futur tuto :smt056 Je dirais que tu peux le commencer quand tu veux ! :wink:


#19

D’autant que le temps n’est plus de la partie, hein ouais ? :smt039


#20

D’autant que le temps n’est plus de la partie, hein ouais ? :smt039[/quote]
Effectivement, chez moi le temps est à la pluie, donc plus aucune excuse ! :smt026

Ricardo ! Au boulot ! Ricardo ! au boulot ! :smt024

Et en plus, avec ce printemps pourri, je suis sûr que dans son atelier, c’est la fricasse, donc c’est pas un temps non plus pour faire de la menuiserie, hein !

:smt041