Touchpad : comprend pas


#1

Bonjour,
depuis que j’ai installé ma debian (testing, noyau 2.6), le touchpad marche, mais je n’arrive pas à activer le tap sur le touchpad, pour simuler le clic gauche. J’ai essayé :

  • tpconfig : j’arrive à rien ;
  • de copier le X86CONFIG-4 de la knoppix (sous laquelle la fonction marche) : toujours sans succès;
    Voici, après plusieurs modifications, le contenu du fichier :
Section "ServerLayout"
	Identifier     "XFree86 Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "PS/2 Mouse" "CorePointer" "Touchpad"
# Serial Mouse not detected
# USB Mouse not detected
EndSection

Section "ServerFlags"
	Option "AllowMouseOpenFail"  "true"
	
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
	FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
	FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
#	FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
#	FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
	FontPath     "/usr/share/fonts/ttf/western"
	FontPath     "/usr/share/fonts/ttf/decoratives"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/truetype/openoffice"
	FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
	FontPath     "/usr/share/fonts/latex-ttf-fonts"
	FontPath     "/usr/X11R6/lib/X11/fonts/defoma/CID"
	FontPath     "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
EndSection

Section "Module"
        Load  "ddc"  # ddc probing of monitor
	Load  "GLcore"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
        Load  "bitmap" # bitmap-fonts
	Load  "speedo"
	Load  "type1"
	Load  "freetype"
	Load  "record"
	Load	"synaptics"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
        Option      "CoreKeyboard"
	Option "XkbRules" "xfree86"
	Option "XkbModel" "pc105"
	Option "XkbLayout" "fr"

EndSection

Section "InputDevice"
   Identifier "Touchpad"
   Driver "synaptics"
   Option "SendCoreEvents"
   Option "Device" "/dev/psaux"
   Option "Protocol" "event"
   # Next line required only if you want to disable the mousepad while typing:
   Option "SHMConfig" "on"
   # The rest of the options are NOT required, just a default similar to the Windows drivers with non of the extra features.
   Option "LeftEdge" "1900"
   Option "RightEdge" "5400"
   Option "TopEdge" "1400"
   Option "BottomEdge" "4500"
   Option "FingerLow" "25"
   Option "FingerHigh" "30"
   Option "MaxTapTime" "180"
   Option "MaxTapMove" "220"
   Option "VertScrollDelta" "100"
   Option "MinSpeed" "0.02"
   Option "MaxSpeed" "0.18"
   Option "AccelFactor" "0.0010"
EndSection

Section "InputDevice"
	Identifier  "Serial Mouse"
	Driver      "mouse"
	Option      "Protocol" "Microsoft"
	Option      "Device" "/dev/ttyS0"
	Option      "Emulate3Buttons" "true"
	Option      "Emulate3Timeout" "70"
	Option	    "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
	Identifier  "PS/2 Mouse"
	Driver      "mouse"
	Option      "Protocol" "auto"
Option          "ZAxisMapping"          "4 5"
	Option      "Device" "/dev/psaux"
	Option      "Emulate3Buttons" "true"
	Option      "Emulate3Timeout" "70"
	Option	    "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
	Option		"SendCoreEvents"	"true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

Voila, qu’en pensez vous (sachant que l’insertion de la section touchpad n’a rien changé) ?


#2

Personne n’a d’idée ?? SCIOUX PLAIT !


#3

Je viens de réussir à identifier le touchpad sur /dev/input/mice (en faisant cat /dev/input/mice et en bougeant le touchpad, il y a une réaction… J’ai donc modifier le fichier XF86CONFIG-4, mais toujours rien :
En faisant :

# tpconfig -i je n’obtient pas mieux que [code]fatal:

No Synaptics or ALPS touchpad device found
[/code]

Qu’est-ce que je peux encore essayer ?
Merci !


#4

Tu as essayé les différents modules pour ta souris ?

Quelque part sous :

/lib/modules/uname -r/kernel/drivers/input/mouse

essaye-les l’un après l’autre …

modprobe le nom_du_module

Tu peux aussi installer mdetect, ca aide des fois .


#5

Merci !!
mdetect m’a aidé : Malgré ce que j’avais compris, il fallait que je choisisse option device "/dev/psaux" option protocole "ImPS/2"

Alors, voila, mon problème est résolu !