Transfert sur un autre disque dur


#1

Lorsque j’ai installer debian, c’était juste pour la tester mais depuis comme je ne boot sous windows que rarement, je souhaiterais lui donner une plus grande place afin de l’aéré un peu. J’ai donc fait l’acquisition d’un disque dur de 80go et je souhaiterais l’y transférer mais en ayant toujours la possibilité de booter sous windows et donc resté en dual boot (Je ne peux pas la retirer du à certains impératif professionnel).

Ma configuration actuelle est un disque dur de 120go rempli en maitre et un de 80go vierge en esclave.df -h Sys. de fich. Tail. Occ. Disp. %Occ. Monté sur /dev/hda3 9,1G 6,1G 2,6G 70% / tmpfs 443M 4,0K 443M 1% /dev/shm /dev/hda5 28G 27G 571M 98% /mnt/hdd1 /dev/hda7 28G 23G 5,2G 82% /mnt/hdd3 /dev/hda6 28G 16G 13G 56% /mnt/hdd2 /dev/hda1 20G 14G 5,8G 71% /mnt/winnt[code]Partition Table for /dev/hda

           First       Last

Type Sector Sector Offset Length Filesystem Type (ID) Flag


1 Primary 0 40965749 63 40965750 HPFS/NTFS (07) Boot
2 Primary 40965750 212989769 0 172024020 W95 Ext’d (LBA) (0F) None
5 Logical 40965750 98317799 63 57352050 W95 FAT32 (0B) None
6 Logical 98317800 155653784 63 57335985 HPFS/NTFS (07) None
7 Logical 155653785 212989769 63 57335985 W95 FAT32 (0B) None
3 Primary 212989770 232332029 0 19342260 Linux (83) None
4 Primary 232332030 234436544 0 2104515 Linux swap / So (82) None[/code]J’aurais donc quelques questions sur le partitionnement de mon disque de 80go ainsi que sur le transfert des données sachant que je n’ai qu’une partition principale pour le moment contenant tout. Voici les différents répertoires que je souhaiterais partitionner ainsi que leur taille actuelle.

/home 1.0 go /usr 3.5 go /var 1.0 go /tmp 71 koAprès avoir consulter le topic de Matt sur le partitionnement forum.debian-fr.org/viewtopic.php?t=2221 et avoir vu les différentes tailles de mes répertoires actuellement j’en viens à celui-ci.partition / 10 Go ext2 partition /swap 1.5 Go partition /home 33.5 Go ext3 partition /usr 15 Go ext2 partition /var 10 Go ext2 partition /tmp 10 Go ext2Maintenant on passe aux questions.

  • Est-il possible de faire le transfert de partition sans problème (utilisation de knoppix je suppose)?
  • Mon partitionnement est-il adéquat?
  • Le fait que mon disque dur de 80 go soit en esclave pose-t-il un problème pour grub?
  • Comment puis-je rester en dual boot reconfiguration de grub suffit ou je doit aussi extraire une partition /boot sur le disque dur maitre?
  • Et enfin comment faire se transfert? Je peux appliquer ce qui est dit dans ce topic forum.debian-fr.org/viewtopic.php?t=2377 pour toutes mes partitions?

#2

[quote]Maintenant on passe aux questions.

  • Est-il possible de faire le transfert de partition sans problème (utilisation de knoppix je suppose)?[/quote]

oui.
il te faudra modifier ton fstab pour lui indiquer les partitions a monter et sur quelle branche (/home , /tmp, …)

l’ancien partitionnement avec un /tmp de 71 ko est pour le moins… surprenant !
je pense que tu t’en tirera mieux avec ce que tu comptes faire :slightly_smiling:

a prioris, aucun soucis de ce coté la

une fois que tu a tout copier sous knoppix, tu montes les nouvelles partitions, tu chroot dedans et tu fais un update-grub

si tu parles de [quote=“Matt”]tu prépares une autre partition ext3* (mettons /dev/hdXY) que tui prépares soit avec fdisk et mkfs.ext3, soit avec qtparted (par exemple) et qui sera ton nouveau /home,
tu fermes toute session X,
tu te logues dans une console (ctrl+alt+F1), et en root ce qui te fait travailler dans /root (aucun fichier ouvert dans /home),
mkdir tmpmnt
mount -t ext3 /dev/hdXY tmpmnt
mv /home/* tmpmnt
(tu deplaces le contenu de /home dans la future partition)
dans tu rajoutes la ligne:

[quote]Code:
/dev/hdXY /home ext3 rw,nosuid,nodev 0 2[/quote]

ensuite
mount /home
et voilà…

  • tu peux aussi ajuster pour prendre un autre systême de fichier genre reiserfs, etc…[/quote]

je pense en effet que tu peux l’appliquer sur toutes les partitions.


#3

l’ancien partitionnement avec un /tmp de 71 ko est pour le moins… surprenant !
je pense que tu t’en tirera mieux avec ce que tu comptes faire :slightly_smiling:[/quote]En fait j’ai du mal m’expliquer ce n’est pas mon ancien partitionnement de /tmp qui fait 71ko c’est la taille de mon répertoire /tmp au moment du post. /tmp fait partit d’une partition avec /usr /home et / j’ai tout laissé dans une seule partition au démarrage. Maintenant je veux optimiser tout ça.

Merci pour tes réponses :wink:


#4

Voila j’ai un petit probleme de partitionnement et je ne comprend pas trop pourquoi

[code]seal:/home/ash# fdisk -l /dev/hdb

Disk /dev/hdb: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 19376 9765472+ 83 Linux
/dev/hdb2 129753 158816 14648256 83 Linux
/dev/hdb3 126847 129752 1464624 82 Linux swap / Solaris
/dev/hdb4 19377 126846 54164880 5 Extended
/dev/hdb5 19377 88094 34633840+ 83 Linux
/dev/hdb6 88095 107470 9765472+ 83 Linux
/dev/hdb7 107471 126846 9765472+ 83 Linux

Partition table entries are not in disk order
seal:/home/ash# tune2fs -L /usr /dev/hdb2
tune2fs 1.39-WIP (31-Dec-2005)
tune2fs: Bad magic number in super-block lors de la tentative d’ouverture de /dev/hdb2
Ne peut repérer un superbloc valide du système de fichiers.
[/code]J’ai essayer avec qtparted et aussi avec cfdisk mais j’arrive toujours au meme problème tune2fs 1.39-WIP (31-Dec-2005) tune2fs: Bad magic number in super-block lors de la tentative d'ouverture de /dev/hdb2Qu’est-ce que je fait mal ?
Problème de disque?


#5

“je sais pas comment te dire ce que je peux pas écrire…” :laughing:

sérieux, j’en sais rien… mais tes partitions ont l’air convenablement créées…
pourquoi utiliser tune2fs ?
dans la manpage j’ai lu :

[quote] -L volume-label
Définit le nom de volume du système de fichiers. Les labels des
systèmes de fichiers ext2 sont limités à 16 caractères ; si vol-
ume-label est plus long que 16 caractères, tune2fs le tronquera
et affichera un avertissement. Le nom de volume peut être
utilisé par mount( 8 ), fsck( 8 ), et /etc/fstab( 5 ) (et probablement
d’autres) en spécifiant LABEL=volume_label à la place du nom de
périphérique comme /dev/hda5.[/quote]

peut etre que :

fonctionnerait mieux… ?


#6

La commande fonctionne correctement pour la première partition mais pas pour hdb2 meme avec tune2fs -L LABEL=/usr /dev/hdb2


#7

Rien a faire j’ai beau essayer avec differents logiciels et de differentes facons j’ai toujours un problème sur le partitionnement de ce disque. qtparted ne peux formater en ext3 apparement et cfdisk apparement fonctionne mais apres j’ai toujours cette erreur au niveau de la “labelisation” des partitions.

qtparted me dit

tune2fs me dit

tune2fs -L /usr /dev/hdb4 tune2fs 1.39-WIP (31-Dec-2005) tune2fs: Bad magic number in super-block lors de la tentative d'ouverture de /dev/hdb4 Ne peut repérer un superbloc valide du système de fichiers.


#8

Bon, je vais me faire tuer mais essaye de récupérer le cd 1 d’une Mandriva. Tu trouveras dans le prog d’install “Diskdrake” un prog de partitionnement très simple et avec lequel j’ai récemment redimensionné une partition contenant des données sans pb. Qd le travail est fait, tu stoppes l’installation évidemment :wink:


#9

Merci de la proposition, j’ai réussi à faire autrement. Voulant voir pourquoi il me disait qu’il y avait une erreur avec mkfs.ext3 j’ai tout fait manuellement.

cfdisk /dev/hdbsuivi du formatage des partitions avec mkfs.ext2 et 3[code]seal:/home/ash# mkfs.ext3 /dev/hdb5
mke2fs 1.39-WIP (31-Dec-2005)
Étiquette de système de fichiers=
Type de système d’exploitation: Linux
Taille de bloc=4096 (log=2)
Taille de fragment=4096 (log=2)
4333280 inodes, 8658460 blocs
432923 blocs (5.00%) réservé pour le super usager
Premier bloc de données=0
265 bloc de groupes
32768 blocs par groupe, 32768 fragments par groupe
16352 inodes par groupe
Archive du superbloc stockée sur les blocs:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624

Écriture des tables d’inodes: complété
Création du journal (32768 blocs): complété
Écriture des superblocs et de l’information de comptabilité du système de fichiers: complété

Le système de fichiers sera automatiquement vérifié tous les 21 montages ou après
180 jours, selon la première éventualité. Utiliser tune2fs -c ou -i pour écraser la valeur.
[/code]pareil pour les autres partitions mais en ext2
ensuite un tune2fs pour les differentes partitions et un mkswap mkswap -L swap /dev/hdb3et tout fonctionne apparement. Aucune erreur d’apparu je ne comprend pas pourquoi qtparted me créé une erreur.


#10

Félicitations ! :wink:


#11

merci bluenote :slightly_smiling:

Afin d’être sur et de ne pas faire de bêtises je voudrais une confirmation sur ce que je m’apprête a faire.

Donc, maintenant que mes partitions sont prêtes, je boot avec knoppix ou tout autre livecd ensuite je vais faire le transfert dans un ordre bien précis afin d’éviter de refaire le travail une deuxième fois. Au démarrage, je monte donc ma première partition qui se trouve en ext3 les autres étant en ext2

pour plus de facilité de compréhension voila un petit fdisk

[code]seal:/home/ash# fdisk -l /dev/hdb

Disk /dev/hdb: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 19376 9765472+ 83 Linux
/dev/hdb2 129753 158816 14648256 83 Linux
/dev/hdb3 126847 129752 1464624 82 Linux swap / Solaris
/dev/hdb4 19377 126846 54164880 5 Extended
/dev/hdb5 19377 88094 34633840+ 83 Linux
/dev/hdb6 88095 107470 9765472+ 83 Linux
/dev/hdb7 107471 126846 9765472+ 83 Linux

Partition table entries are not in disk order[/code]

mkdir /mnt/tmphome mount -t ext3 /dev/hdb5 /mnt/tmphome mv /home/* /mnt/tmphome

ensuite je passe a /var /tmp et /usr

mkdir /mnt/tmpvar mount -t ext2 /dev/hdb6 /mnt/tmpvar mv /var/* /mnt/tmpvar

mkdir /mnt/tmptmp mount -t ext2 /dev/hdb7 /mnt/tmptmp mv /tmp/* /mnt/tmptmp

mkdir /mnt/tmpusr mount -t ext2 /dev/hdb2 /mnt/tmpusr mv /usr/* /mnt/tmpusr

et enfin la derniere

mkdir /mnt/tmpracine mount -t ext2 /dev/hdb1 /mnt/tmpracine mv /* /mnt/tmpracine

Je modifie ensuite mon fstab ce qui devrais donner ceci si je n’ai pas fait d’erreur bien sur
fstab avant

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc    proc        defaults    0    0
/dev/hda3    /    ext3    defaults,errors=remount-ro    0    1
/dev/hda4    none        swap    sw    0    0
/dev/hdc        /media/cdrom0    iso9660 ro,user,noauto        0    0
/dev/hdb        /media/cdrom1    iso9660 ro,user,noauto        0    0
/dev/fd0        /media/floppy0    auto    rw,user,noauto,umask=0    0    0
/dev/hda1    /mnt/winnt    ntfs    ro,user,noauto,umask=0    0    0
/dev/hda5    /mnt/hdd1    vfat    rw,user,auto,umask=0    0    0
/dev/hda6    /mnt/hdd2    ntfs    ro,user,noauto,umask=0    0    0
/dev/hda7    /mnt/hdd3    vfat    rw,user,noauto,umask=0    0    0
/dev/hdd1    /mnt/hdd4    auto    ro,user,noauto,umask=0    0    0
/dev/sda1     /mnt/usbkey    auto    rw,user,noauto,umask=0    0    0

fstab apres

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc    proc        defaults    0    0
/dev/hdb1    /    ext3    defaults,errors=remount-ro    0    1
/dev/hdb2 /usr ext2 rw,nosuid,nodev 0 2
/dev/hdb3    none        swap    sw    0    0
/dev/hdb5 /home ext3 rw,nosuid,nodev 0 2
/dev/hdb6 /var ext2 rw,nosuid,nodev 0 2
/dev/hdb7 /tmp ext2 rw,nosuid,nodev 0 2
/dev/hdc        /media/cdrom0    iso9660 ro,user,noauto        0    0
/dev/hdd        /media/cdrom1    iso9660 ro,user,noauto        0    0
/dev/fd0        /media/floppy0    auto    rw,user,noauto,umask=0    0    0
/dev/hda1    /mnt/winnt    ntfs    ro,user,noauto,umask=0    0    0
/dev/hda5    /mnt/hdd1    vfat    rw,user,auto,umask=0    0    0
/dev/hda6    /mnt/hdd2    ntfs    ro,user,noauto,umask=0    0    0
/dev/hda7    /mnt/hdd3    vfat    rw,user,noauto,umask=0    0    0
/dev/sda1     /mnt/usbkey    auto    rw,user,noauto,umask=0    0    0

Une fois tout ca fait je monte toutes les partitions

mount / mount /tmp mount /home mount /var mount /usr

et ensuite après un chroot je relance la config de grub qui devrait tout remettre comme il faut. Et enfin, je n’aurais plus qu’a rebooter.

Je demande confirmation car je n’en suis pas sur que je ne voudrais pas faire d’erreur qui m’empêcherais de booter sous debian.


#12

ashgenesis, je n’ai pas tout lu mais une chose m’a frappée dans ta table de partition /dev/hdb4 est avant /dev/hdb2 et /dev/hdb3 et ça peut entrainer des pbms…


#13

Merci pour l’info je vais essayer de modifier cela pour qu’il n’y ai pas de problème c’est d’ailleurs pour ca que je l’ai poster :slightly_smiling: je dis essayer car c’est fdisk qui me la fait automatiquement comme ca. Vous auriez d’autres infos sur la manière de procéder correctement?

N’hésitez pas a faire des remarques


#14

peut etre c’est une bétise, mais en procédant ainsi :

[quote]mkdir /mnt/tmphome
mount -t ext3 /dev/hdb5 /mnt/tmphome
mv /home/* tmphome

mkdir /mnt/tmpvar
mount -t ext2 /dev/hdb6 /mnt/tmpvar
mv /var/* tmpvar

mkdir /mnt/tmptmp
mount -t ext2 /dev/hdb7 /mnt/tmptmp
mv /tmp/* tmptmp

mkdir /mnt/tmpusr
mount -t ext2 /dev/hdb2 /mnt/tmpusr
mv /usr/* tmpusr

mkdir /mnt/tmpracine
mount -t ext2 /dev/hdb1 /mnt/tmpracine
mv /* tmpracine[/quote]

je me demande si mv va comprendre l’emplacement de destination. ne faudrait-il pas préciser : mv /home/* /mnt/tmphome et ainsi de suite ?

pour le chroot, je ferais comme ca, mais je suis loin d’être un expert ^^


#15

oui tu as raison, c’est le genre d’erreur que je fait régulièrement. Je corrige Merci :slightly_smiling: