Trouver et modifier ce qui bloque le caractère bell

Tags: #<Tag:0x00007fae52cfe8d0>

Bonjour,
En espérant que vous alliez bien.

Je suis sur debian 10.
uname -a :

Linux Tamie 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux

Je voudrais obtenir un bell à l’écriture d’un bell.
J’entends restaurer le caractere bel par defaut.

Je viens d’installer debian en procédure netinstall.

Merci pour vos lumière.

J’ai installer Mate puis retiirer lightdm, je suis sur fvwm1 je travail dans un xterm ou la console.

Desolé pour les erreur de frappe.
C’est domage, il y a deux jour j’avais le bell et j’ai modifier.
J’ai donc reinstallé une seconde fois et là rien.
Le module est chargé, je sais que le speaker fonctionne.
J’ai suivi 4 tuto mais rien qui aille.
speaker test fonctionne.
pas de black list connu.
Je sèche.

Ah ben voilà.
Il fallait jouer avec speaker test.
Merci.
Le problème est résolu.

ahhhh non.

C’est reparti.

S’il vous plait, aider moi…

Bonjour,

Euh, je ne suis pas sûr d’avoir tout suivi mais alsamixer du paquet alsa-utils, propose peut-être une jauge beep, sur silencieux ou pas.

Merci, mais le volume est au max d’après alsamixer.
D’ailleurs le volume est à moitier dans mate-pannel/sound

le speaker est audble 5 seconde après l’utilisation de speaker-test ; Après plu rien.

Merci en tout.

Hello, si pulseaudio est installé il gère le son par application. À creuser de ce côté, ça coince parfois au niveau des sources selon mon expérience. Peut-être essayer un autre émulateur de terminal que le très basique (à mon goût) xterm, tel que [xfce4-/deepin-/fte-/gnome-/mate-/lx/q]terminal?

Merci.
Il ne semble pas y avoir de problème avec le vte xterm.
Comme je l’ai dit, le bell fonctionne 5 seconde après l’utilisation de speaker-test.
D’ailleur il fonction bien dans d’autre application durant le même lapse de temps.
Donc, soit speaker test fait quelque chose qui lui permet d’utiliser le speaker, soit le système referme le speaker après l’utilisation de speaker-test.
J’ai pas trouvé.

Bonjour

Ça ressemble à une mise en veille (ou mise à « mute » par « auto-mute ») de la carte audio (ou autre sous-ensemble logiciel) que le bell n’arrive pas à « réveiller ».

Peut-être qu’avec alsamixer il faudrait désactiver la fonctionnalité auto-mute

Avant :

┌───────────── AlsaMixer v1.2.4 ─────────────┐
│    Carte: HDA Intel PCH                    │
│     Puce: Realtek ALC3232                  │
│      Vue: Lecture                          │
│ Contrôle: Auto-Mute Mode [Enabled]         │
│      ┌──┐              ┌──┐     ┌──┐       │
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
│      ├──┤   Enabled    ├──┤     └──┘       │
│      │OO│              │MM│                │
│      └──┘              └──┘                │
│    100<>100            0<>0     0<>0       │
│      Beep  <Auto-Mut>Dock Mic Dock Mic     │
└────────────────────────────────────────────┘

Après désactivation de l’Auto-Mute

┌───────────── AlsaMixer v1.2.4 ─────────────┐
│    Carte: HDA Intel PCH                    │
│     Puce: Realtek ALC3232                  │
│      Vue: Lecture                          │
│ Contrôle: Auto-Mute Mode [Disabled]        │
│      ┌──┐              ┌──┐     ┌──┐       │
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
←      │▒▒│              │  │     │  │       →
│      ├──┤   Disabled   ├──┤     └──┘       │
│      │OO│              │MM│                │
│      └──┘              └──┘                │
│    100<>100            0<>0     0<>0       │
│      Beep  <Auto-Mut>Dock Mic Dock Mic     │
└────────────────────────────────────────────┘

Merci MicP

J’ai bien une carte HDA Intel PCH.
Mais pour l’auto - mute, j’ai pas ça dans alsamixer 1.1.8.
j’ai trouvé alsamixer gui avec dselect mais pas mieu à propos de auto - mute.

Je ferais bien un apt-get install alsamixer mais auriez vous mieux à me proposer pour ne pas faire de bêtise ?

C’est peut-être une fonctionnalité de la puce électronique ou/et de la façon dont elle est câblée ou paramétrée par un fichier firmware ou/et un ou des programmes logiciel qui fera qu’alsamixer aura accès à l’auto-mute.
La gestion software du son est devenue un véritable casse-tête avec énormément de fonctionnalités interdépendantes vraiment difficiles à maîtriser sur des machines souvent bien différentes les unes des autres avec des systèmes d’exploitation différents et des environnement de bureau différents.

L’auto-mute n’était qu’une hypothèse, il y a peut-être d’autres pistes…

Merci MicP
Effectivement, je n’ai rien chargé de spécifique à mon hardware.
Et le problème est éventuellement ailleurs ou solvable différemmant.

En tout cas merci de vous être arrêté ici.

J’essaye de reproduire le même contexte dans une machine virtuelle Qemu/KVM,
et je viens de terminer d’installer debian MATE en utilisant le fichier image ISO :

debian-10.9.0-amd64-netinst.iso

Le bell fonctionne (par defaut) dans le terminal MATE
avant le speaker-test et plus de 5 secondes après => bell fonctionne tout le temps,
ainsi que la ligne de commande suivante :

echo -e "\007"

Il faudrait que tu me donnes un peu plus de détails concernant le retrait de lightdm
et si tu l’as remplacé par un autre gestionnaire de connexion,
que tu me dises lequel et comment tu as procédé pour l’installer.
Même chose en ce qui concerne fvwm1

Merci.

MicP,
Euh, comment dire…
Merci pour ton investigation.
Merci pour le temps.

J’utilise dselect.

Donc ; J’ai procédé à l’installation avec les paquet par defaut pour debian et le bureau et j’ai selectionné Mate.
Avec dselect j’ai supprimer lightdm que je n’ai pas remplacé. J’ai redémaré le système et je démare une session X avec startx.
J’ai installé :
emacs-nox
make
lynx
highlight
htop
fvwm1
gpm
gnat-8 et gtkada-bin

J’ai rédigé un .xinitrc
avec l’ouverture de 6 terminaux virtuel xterm.
la ligne commune est xterm -bg color -fg color -geomtry … &
j’ai terminé par :
fvwm1

C’est toute mon install.

Evidemment, il faut faire apt-get install dselect. Si non…

J’oubliais, csh et tcsh.

J’ai fermé la session utilisateur,
ouvert un terminal en mode texte et me suis logué en root
puis j’ai stoppé lightdm.service

mais la commande dselect est absente.

oui, j’ai édité mon message, j’ai oublié 3 chose.

La même ligne ne donne rien chez moi.
J’ai bien un bing lorsuqe je selectionne un theme de son différent dans mate-volume-console. C’est tout ce que je tire pour le moment.

J’entends dans un terminal mate… pareil.

Je n’ai pas encore appris à utiliser dselect
mais je verrais demain, après avoir dormis un peu.


Au cas où,
voilà ce que j’ai quand je lance alsamixer :

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: PulseAudio                               F1:  Aide                 │
│     Puce: PulseAudio                               F2:  Informations Système │
│      Vue: F3:[Lecture] F4: Capture  F5: Tout       F6:  Choisir la carte son │
│ Contrôle: Master                                   Esc: Quitter              │
│                                                                              │
│                                     ┌──┐                                     │
│                                     │  │                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     ├──┤                                     │
│                                     │OO│                                     │
│                                     └──┘                                     │
│                                    93<>92                                    │
│                                  < Master >                                  │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

j’appuie sur F6 pour sélectionner ma carte audio

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: PulseAudio                               F1:  Aide                 │
│     Puce: PulseAudio                               F2:  Informations Système │
│      Vue: F3:[Lecture] F4: Capture  F5: Tout       F6:  Choisir la carte son │
│ Contrôle: Master                                   Esc: Quitter              │
│                                                                              │
│                                     ┌──┐                                     │
│                                     │  │                                     │
│                                     │▒▒│                                     │
│                    ┌──────────── Carte Son ────────────┐                     │
│                    │-  (par défaut)                    │                     │
│                    │0  HDA Intel HDMI                  │                     │
│                    │1  HDA Intel PCH                   │                     │
│                    │   entrez le nom du périphérique...│                     │
│                    └───────────────────────────────────┘                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     │▒▒│                                     │
│                                     ├──┤                                     │
│                                     │OO│                                     │
│                                     └──┘                                     │
│                                    93<>92                                    │
│                                  < Master >                                  │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

Comme je n’utilise pas la sortie HDMI,
je sélectionne la carte HDA Intel PCH

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: HDA Intel PCH                            F1:  Aide                 │
│     Puce: Realtek ALC3232                          F2:  Informations Système │
│      Vue: F3:[Lecture] F4: Capture  F5: Tout       F6:  Choisir la carte son │
│ Contrôle: Master [gain dB: -2,25]                  Esc: Quitter              │
│                                                                              │
│     ┌──┐     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐               │
│     │  │     │▒▒│              │  │     │▒▒│     │  │     │  │               │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │               │
│     ├──┤     ├──┤     ┌──┐     ├──┤     └──┘     ├──┤     └──┘   Follow M    │
│     │OO│     │OO│     │OO│     │MM│              │MM│                        │
│     └──┘     └──┘     └──┘     └──┘              └──┘                        │
│      91    100<>100            0<>0   100<>100   0<>0     0<>0               │
│  < Master >Headphon Headphon Speaker    PCM      Mic    Mic Boos Mic Mute    │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

Pour visualiser tous les contrôles accessibles,
je clique sur F5

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: HDA Intel PCH                            F1:  Aide                 │
│     Puce: Realtek ALC3232                          F2:  Informations Système │
│      Vue: F3: Lecture  F4: Capture  F5:[Tout]      F6:  Choisir la carte son │
│ Contrôle: Master [gain dB: 0,00]                   Esc: Quitter              │
│                                                                              │
│     ┌──┐     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      →
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      │
│     │▒▒│     │▒▒│              │  │     │▒▒│     │  │     │  │     │  │      │
│     ├──┤     ├──┤     ┌──┐     ├──┤     └──┘     ├──┤     └──┘     └──┘      │
│     │OO│     │OO│     │OO│     │MM│              │MM│                        │
│     └──┘     └──┘     └──┘     └──┘              └──┘                        │
│                                                                              │
│     100    100<>100            0<>0   100<>100   0<>0     0<>0     0<>0      │
│  < Master >Headphon Headphon Speaker    PCM      Mic    Mic Boos Mic Boos    │
└──────────────────────────────────────────────────────────────────────────────┘

En cliquant plusieurs fois sur la touche Flèche Droite
je fais apparaître et sélectionne le bouton <Auto-Mut>

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: HDA Intel PCH                            F1:  Aide                 │
│     Puce: Realtek ALC3232                          F2:  Informations Système │
│      Vue: F3: Lecture  F4: Capture  F5:[Tout]      F6:  Choisir la carte son │
│ Contrôle: Auto-Mute Mode [Enabled]                 Esc: Quitter              │
│                                                                              │
│              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│   Enabled    ├──┤     └──┘     └──┘     └──┘     └──┘   Disabled Follow M    │
│              │MM│                                                            │
│              └──┘                                                            │
│                                                                              │
│              0<>0     0<>0     0<>0     0<>0     0<>0                        │
│  <Auto-Mut>Dock Mic Dock Mic Dock Mic Internal Internal Loopback Mute-LED    │
└──────────────────────────────────────────────────────────────────────────────┘

Le bouton <Auto-Mut> est Enabled

mais en cliquant sur la touche Flèche Bas
je le positionne sur Disabled

┌────────────────────────────── AlsaMixer v1.2.4 ──────────────────────────────┐
│    Carte: HDA Intel PCH                            F1:  Aide                 │
│     Puce: Realtek ALC3232                          F2:  Informations Système │
│      Vue: F3: Lecture  F4: Capture  F5:[Tout]      F6:  Choisir la carte son │
│ Contrôle: Auto-Mute Mode [Disabled]                Esc: Quitter              │
│                                                                              │
│              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
←              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│              │  │     │  │     │  │     │  │     │  │                        │
│   Disabled   ├──┤     └──┘     └──┘     └──┘     └──┘   Disabled Follow M    │
│              │MM│                                                            │
│              └──┘                                                            │
│                                                                              │
│              0<>0     0<>0     0<>0     0<>0     0<>0                        │
│  <Auto-Mut>Dock Mic Dock Mic Dock Mic Internal Internal Loopback Mute-LED    │
└──────────────────────────────────────────────────────────────────────────────┘

Il ne reste plus qu’à appuyer sur la touche Échap

Supper.
Déjà un point qui m’échappais. J’avais déjà vu auto mute il y a 4 ou 5 ans.

Il etait enable, j’ai basculer, j’ai redemmaré.
Il est bien disable.
Speaker-test fonctionne mais toujours les même symptome.

Bonne nuit.

Et vous dites que le votre fonctionne…

Il y a un problème avec ce que j’ai installé alors ?

J’ai pas de machine suplementaire, pour recommencer.