Upgrade xserver-xorg


#1

Ce jour, lors d’une mise à jour par apt-get dist-upgrade sur une version unstable, j’ai eu un pb lors de la configuration de xserver-xorg => arrêt de apt-get.

Depuis, à chaque utilisation de apt-get pour mettre à jour un paquet (tiens udev par exemple), j’ai tjs le même Pb et la tentative de mettre à jour xserver-xorg e le même échec.

apt-show-versions xserver-xorg xserver-xorg/unstable upgradeable from 6.8.2.dfsg.1-7 to 6.8.2.dfsg.1-8

l’erreur suivante apparaît après l’écran de choix du device de la souris.

Preconfiguring packages ... auto_answer() resetting template xserver-xorg/autodetect_video_card auto_answer() resetting template xserver-xorg/autodetect_mouse dpkg: error processing xserver-xorg (--remove): Package is in a very bad inconsistent state - you should reinstall it before attempting a removal. terminate called after throwing an instance of 'std::logic_error' what(): basic_string::_S_construct NULL not valid Aborted ian:~# Errors were encountered while processing: xserver-xorg

Si qq1 a une bonne idée pour me sortir de là…
Merci.


#2

tu peux essayer de supprimer le paquet en --force-all avec dpkg, et de le réinstaller a coups de apt-get -f install