Utilisation de GDebi pour l'installation de VS Code sous Debian 11/LXQt

Tags: #<Tag:0x00007fb99be56be8>

Bonjour à tous,

Je commence à apprendre la programmation via le CNAM et en parallèle, j’ai profité de la sortie de Debian 11 pour l’installer sur mon vieux PC portable de 11 ans.

Le professeur me demande d’installer VS Code. J’ai donc téléchargé le fichier .deb (ici) et installer GDebi comme recommandé dans Les cahiers du débutant sur Debian GNU/Linux Bullseye, paragraphe 8.7.1, page 197.

Jusque là, tous va bien. J’ouvre le fichier .deb avec GDebi, il analyse ce dernier. Mais au moment de cliquer sur « Installer le paquet », l’application se ferme, et rien ne se passe.

capture

Impossible d’installer VS Code. Sauriez-vous comment faire ?
D’avance merci.
Cordialement,

-----------------------------------------------------------------------------------------------------------------------------
neofetch

Bonjour,

en root, ou sudfo, as-tu essayé de faire dpkg -i fichier.deb puis apt -f install?

NON !

La bonne manière est, avec des droits administrateurs, dans un terminal/console :

# apt install ./Téléchargements/code*amd64.deb

(en admettant que le paquet debian soit normalement installé dans le répertoire de téléchargement par défaut ; sinon, il faut moduler…)

Et, là, il verra quels sont les problèmes ; et il devrait en avoir :wink:
(parce que si l’install avec Gdebi plante, c’est qu’il y un soucis quelque part ; c’est « rare » quand Gdebi échoue).


Test sous Devuan Ceres :
(ceci n’est pas Debian 11 ; mais c’est similaire dans le processus)

$ sudo apt install ./code*amd64.deb
[sudo] Mot de passe de root : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Note : sélection de « code » au lieu de « ./code_1.59.1-1629375198_amd64.deb »
Les NOUVEAUX paquets suivants seront installés :
  code
0 mis à jour, 1 nouvellement installés, 0 à enlever et 17 non mis à jour.
Il est nécessaire de prendre 0 o/78,1 Mo dans les archives.
Après cette opération, 296 Mo d'espace disque supplémentaires seront utilisés.
Réception de :1 /home/zou/Téléchargements/code_1.59.1-1629375198_amd64.deb code amd64 1.59.1-1629375198 [78,1 MB]
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet code précédemment désélectionné.
(Lecture de la base de données... 290005 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../code_1.59.1-1629375198_amd64.deb ...
Dépaquetage de code (1.59.1-1629375198) ...
Paramétrage de code (1.59.1-1629375198) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (2.0-1) ...
Traitement des actions différées (« triggers ») pour mailcap (3.70) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.4-2+b1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Scanning processes...                                                                                                                                                                         
Scanning processor microcode...                                                                                                                                                               
Scanning linux images...                                                                                                                                                                      

Running kernel seems to be up-to-date.

The processor microcode seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.
N: Le téléchargement est effectué en dehors du bac à sable en tant que « root » car le fichier « /home/myid/Téléchargements/code_1.59.1-1629375198_amd64.deb » n'est pas accessible par l'utilisateur « _apt ». - pkgAcquire::Run (13: Permission non accordée)

Et ce fichu logiciel doit ensuite apparaître dans le menu « Développement » des applications :wink:

Bonjour et merci pour vos réponses.
Je ne sais pas pourquoi, mais j’ai tenté de faire clic-droit sur le fichier et « Installer avec GDebi ». Et là, ça à fonctionné.
Je garde vos conseils si le cas venait à se représenter.

Encore merci.
Cordialement,

-----------------------------------------------------------------------------------------------------------------------------
neofetch

1 J'aime