Utiliser Samba, au secour !


#1

Bonjour, je débute avec Debian et apres avoir trimé pour configurer mon modem, me voilà !
Donc mon system est en dual-boot --> Debian/WinXP et mon nouveau problème est le suivant : je n’arrive pas à acceder à mes partitions windows. J’ai bien utilisé le tuto suivant --> http://people.via.ecp.fr/~alexis/formation-linux/samba.html#AEN7200, mais quand il sagit de donner des “nom de contrôleur de domaine” ou encore de “NetBios”, me vlà perdu… Quand à monter une partition avec la commande ‘mount’, n’en parlons pas


#2

bon. OK. Sans interface graphique, trés bien.
2 choses diférentes:


#3

Je ne suis sûr d’avoir compris ce que tu veux faire :frowning:

1/ Si c’est pour accéder aux partitions Windows de ta propre machine, depuis cette même machine, il est inutile de monter des disques réseau via Samba.
La clé du problème est dans/etc/fstab

2/ Si par contre, tu veux pouvoir lire/écrire ces mêmes partitions depuis une autre machine du réseau local, là, en effet, il faut les rendre accessibles via Samba.

Bref, ça dépend de ce que tu veux faire :question:


#4

Merci à vous deux pour vos réponses.
C’est bien ce que je veux faire : acceder à mes données dans ma deuxième partition ntfs.
Pour l’instant, vu mes compétences avec Linux, j’ai de quoi faire !
Je vous tiens au courant de l’avancement.


#5

Si tu ne veux que partager une partition, et que sous win, tu travaille déjà avec 2 partitions, je te conseilles de reformatter ta partition de données en fat32 pour pouvoir bien l’utiliser sous linux, parcequ’à priori, linux ne sait accèder aux partitions ntfs qu’en lecture, alors que la fat fonctionne trés bien pour y ecrire.
Et aprés, ta fat32, c’est 20 secondes de config pour y avoir accès sous linux.


#6

Ne connaissant pas encore ton niveau, je préfère te donner des informations inutiles que rien du tout :slightly_smiling:

Exemple de mon fstab correspondant :/dev/hdb1 /mnt/hdb1 vfat auto,users,exec,umask=000 0 0
où :
/dev/hdb1 est le second disque dur IDE, la première partition
/mnt/hdb1 est le point de montage => il faut le créer à la main par unsudo mkdir /mnt/hdb1 ou su, puis mkdir /mnt/hdb1
vfat définit une partition fat32
auto stipule de monter cette partition au démarrage du système
users déclare la partition appartenant à tous les utilisateurs
exec permet le lancement d’exécutables depuis cette partition
umask définit les permissions qu’auront les utilisateurs sur la partition

Pour plus de détails, un site qui explique ça bien :http://lea-linux.org/cached/index/Fstab.html


#7

Bonsoir et bonne année !

[color=brown]Décidément, je n’ai pas finis de galèrer, sur le site de Léa, j’ai cru comprendre qu’il me faudrai recompiler mon noyau pour que le kernel detecte mes deux partitions ntfs au démarrage …

Pas évident, pour l’instant, tout ce que j’ai réussi à faire c’est créer un dossier vide hba1 dans mnt !
[/color]


#8

C’est sûr qu’il faut que ton noyau supporte le NTFS, sinon comment veux-tu arriver à les faire lire :slightly_smiling:

Dans ton fichier de config du noyau, tu dois trouver :CONFIG_NTFS_FS=m
Quel noyau as-tu utilisé ? Si c’est toi qui l’a compilé, tu dois savoir le recompiler en ajoutant cette option, non ?

Sinon, il y a fort à parier pour que la configuration de ton noyau standard inclue aussi le support du NFTS, ce serait bien surprenant du contraire.


#9

Le problème c’est que le NTFS est ultra-sécurisé, et ce format t’empéchera d’écire des données sur cette partition, sous Linux. Comme l’a dit MattOTop, il vaut mieux la reformater en Fat32, quite à sauvegarder tes données sur un autre disque ou un CDrom et à les réenregister par la suite.


#10

Je ne sais pas si cela aide mais bon ça ne mange pas de pain. Il existe EXT2IFS, sous windows,il permet de lire et d’écrire sur les partitions ext2 et ext3. Je sais que ça existe mais je n’ai pas testé.


#11

Bon. Pas besoin de recompiler ton noyau: le support ntfs y est intègré, et je crois même en ecriture, mais il est inutilisable…
Le module ntfs linux permet d’ecrire un octet à la place d’un autre dans un fichier, mais pas de manipuler des fichiers entiers.

Quoi qu’il en soit, ca n’est pas parceque c’est actif que c’est forcément visible. Ca demande un peu de config.

Alors ça serait mentir que de dire qu’il n’existe pas de solution: il y a captive-ntfs, mais ca n’est pas un “mount” comme les autres. Ca te monte ta partition en “copy and write”, c’est à dire que ton linux travaille sur des copies des fichiers de ton disque, et n’ecrit ensuite les modifs réelles que quand tu le décides. C’est spécial, et c’est particulier quand à la gestion du montage, etc…

Enfin dans tous les cas, pas besoin de recompiler ton noyau, et j’insiste: le plus simple est de passer par une fat32.

yo4: ext2ifs est pratique, mais ralentit énormément windows donc réservé à un usage ponctuel, et il m’a fait des figeages/crash d’écriture assez violents.

PS: je rappelle que si vous formattez votre fat32 avec une disquette dos faite sous 98, vous pourrez formatter une fat32 > à 32 Go, ce qu’on ne peut plus faire avec 2000/XP qui sont bridé à 32Go pour les partitions fat32 (pour obliger les gens à utiliser NTFS).


#12

Vache ça doit être coquet, :laughing: .


#13

Je ne suis pas d’accord avec ça. Je viens d’acheter un disque dur de 250 Go et l’ai installé sur une machine sous XP Home, et j’ai pu la formatter en fat32 à 200 Go (maxi possible). J’ai donc dû créer 2 partitions : l’une de 200 Go, l’autre de 40 Go environ.


#14

Ok avec vous pour conseiller à Panda de créer une partition fat32 qui servira d’échange de données entre son XP et sa Debian. Par contre, je trouve dommage d’avoir XP en fat32, car on perd quand même l’avantage de la gestion des droits sur les fichiers.
Pour moi, la meilleure solution est :

  • Windows XP sur sa propres partition en NTFS
  • Une partition de données de 5 Go par exemple (ou plus si vraiment beaucoup de données) en fat32, accessible depuis XP ou Debian
  • Les partitions nécessaires et suffisantes à sa Debian.

C’est en tout cas, ce que j’avais fait lorsque j’avais encore XP en double boot. Et c’était assez pratique.


#15

Du temps où j’avais un double boot XP/Debian comme Panda, j’avais testé un logiciel (ext2quelquechose) qui permettait de lire (pas d’écrire) les partitions ext2 depuis XP. Par contre, attention les yeux : les droits sur les fichiers ne sont pas gérés : on peut tout lire, y compris les fichiers root !!


#16

Ok, je vais faire une partition fat32 mais pas maintenant car j’ai 100Go de données à sauvegarder et mon disque dur externe n’en fait que 40…


#17

Me revoilà !
Donc j’ai fait comme Korben me conseil :
XP est sur son NTFS
Mes données sont sur une autre partition mais en FAT32
Et ma Debian prend 50% de mon HDD.
Donc je voudrai apprendre à acceder à ma partition FAT32 depuis Linux.
’^_^’


#18

par exemple.


#19

Mon fstab contient ceci :
[color=indigo]

/etc/fstab: static file system information.

proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 /home ext3 defaults 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
[/color]
Maintenant je ne sais plus quoi faire, les partition win n’apparraissent pas…


#20

C’est normal puisque tu ne les a toujours pas déclarées.
Tu sais écrire, mais est ce que tu sais lire ?[quote=“MattOTop”][quote="/etc/fstab"]/dev/ /repertoire/de/montage vfat users,umask=0 0 0[/quote]
par exemple.[/quote]